Commit ed5986f5 authored by xjm's avatar xjm
Browse files

Issue #3090906 by alexpott, greg.1.anderson, ravi.shankar, xjm, Mixologic,...

Issue #3090906 by alexpott, greg.1.anderson, ravi.shankar, xjm, Mixologic, Mile23: self.version in metapackages considered harmful
parent d510989b
......@@ -2,6 +2,8 @@
namespace Drupal\Composer\Generator\Builder;
use Drupal\Composer\Composer;
/**
* Builder to produce metapackage for drupal/core-recommended.
*/
......@@ -60,7 +62,7 @@ protected function initialPackageMetadata() {
"webflo/drupal-core-strict" => "*",
],
"require" => [
"drupal/core" => "self.version",
"drupal/core" => Composer::drupalVersionBranch(),
],
];
}
......
......@@ -2,6 +2,8 @@
namespace Drupal\Composer\Generator\Builder;
use Drupal\Composer\Composer;
/**
* Builder to produce metapackage for drupal/core-dev-pinned.
*/
......@@ -61,7 +63,7 @@ protected function initialPackageMetadata() {
"webflo/drupal-core-require-dev" => "*",
],
"require" => [
"drupal/core" => "self.version",
"drupal/core" => Composer::drupalVersionBranch(),
],
];
}
......
......@@ -7,7 +7,7 @@
"webflo/drupal-core-strict": "*"
},
"require": {
"drupal/core": "self.version",
"drupal/core": "9.0.x-dev",
"asm89/stack-cors": "1.2.0",
"composer/installers": "v1.7.0",
"composer/semver": "1.5.0",
......
......@@ -7,7 +7,7 @@
"webflo/drupal-core-require-dev": "*"
},
"require": {
"drupal/core": "self.version",
"drupal/core": "9.0.x-dev",
"behat/mink": "1.8.0 | 1.7.1.1 | 1.7.x-dev",
"behat/mink-browserkit-driver": "1.3.3",
"behat/mink-goutte-driver": "v1.2.1",
......
......@@ -6,6 +6,7 @@
use Drupal\Composer\Generator\Builder\DrupalDevDependenciesBuilder;
use Drupal\Composer\Generator\Builder\DrupalPinnedDevDependenciesBuilder;
use PHPUnit\Framework\TestCase;
use Drupal\Composer\Composer;
/**
* Test DrupalCoreRecommendedBuilder
......@@ -28,7 +29,7 @@ public function builderTestData() {
'license' => 'GPL-2.0-or-later',
'require' =>
[
'drupal/core' => 'self.version',
'drupal/core' => Composer::drupalVersionBranch(),
'symfony/polyfill-ctype' => 'v1.12.0',
'symfony/yaml' => 'v3.4.32',
],
......@@ -66,7 +67,7 @@ public function builderTestData() {
'license' => 'GPL-2.0-or-later',
'require' =>
[
'drupal/core' => 'self.version',
'drupal/core' => Composer::drupalVersionBranch(),
'behat/mink' => '1.8.0 | 1.7.1.1 | 1.7.x-dev',
'symfony/css-selector' => 'v4.3.5',
],
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment