Commit c66eb738 authored by webchick's avatar webchick

Issue #2508231 by timmillwood, amateescu, hussainweb, catch, dawehner,...

Issue #2508231 by timmillwood, amateescu, hussainweb, catch, dawehner, David_Rothstein, Mixologic, effulgentsia: Raise minimum required version of PHP to 5.5.9
parent a87f47db
......@@ -18,7 +18,7 @@ Drupal requires:
- A web server with PHP support, for example:
- Apache 2.0 (or greater) (http://httpd.apache.org/).
- Nginx 1.1 (or greater) (http://nginx.com/).
- PHP 5.4.5 (or greater) (http://php.net/). For better security support it is
- PHP 5.5.9 (or greater) (http://php.net/). For better security support it is
recommended to update to at least 5.5.21 or 5.6.5.
- One of the following databases:
- MySQL 5.5.3 (or greater) (http://www.mysql.com/).
......
......@@ -4,7 +4,7 @@
"type": "drupal-core",
"license": "GPL-2.0+",
"require": {
"php": ">=5.4.5",
"php": ">=5.5.9",
"sdboyer/gliph": "0.1.*",
"symfony/class-loader": "2.7.*",
"symfony/console": "2.7.*",
......
......@@ -4,7 +4,7 @@
"Read more about it at https://getcomposer.org/doc/01-basic-usage.md#composer-lock-the-lock-file",
"This file is @generated automatically"
],
"hash": "90d27e9e043ff2ad0966a80a49ef2823",
"hash": "a842b991264d42a2f8c5cecbd82597b1",
"packages": [
{
"name": "behat/mink",
......@@ -3450,7 +3450,7 @@
"prefer-stable": true,
"prefer-lowest": false,
"platform": {
"php": ">=5.4.5"
"php": ">=5.5.9"
},
"platform-dev": []
}
......@@ -23,7 +23,7 @@
/**
* Minimum supported version of PHP.
*/
const DRUPAL_MINIMUM_PHP = '5.4.5';
const DRUPAL_MINIMUM_PHP = '5.5.9';
/**
* Minimum recommended value of PHP memory_limit.
......
......@@ -21,8 +21,8 @@
// The minimum version is specified explicitly, as DRUPAL_MINIMUM_PHP is not
// yet available. It is defined in bootstrap.inc, but it is not possible to
// load that file yet as it would cause a fatal error on older versions of PHP.
if (version_compare(PHP_VERSION, '5.4.5') < 0) {
print 'Your PHP installation is too old. Drupal requires at least PHP 5.4.5. See the <a href="https://www.drupal.org/requirements">system requirements</a> page for more information.';
if (version_compare(PHP_VERSION, '5.5.9') < 0) {
print 'Your PHP installation is too old. Drupal requires at least PHP 5.5.9. See the <a href="https://www.drupal.org/requirements">system requirements</a> page for more information.';
exit;
}
......
......@@ -5,7 +5,7 @@
"homepage": "https://www.drupal.org/project/drupal",
"license": "GPL-2.0+",
"require": {
"php": ">=5.4.2"
"php": ">=5.5.9"
},
"autoload": {
"psr-0": {
......
......@@ -5,7 +5,7 @@
"homepage": "https://www.drupal.org/project/drupal",
"license": "GPL-2.0+",
"require": {
"php": ">=5.4.2",
"php": ">=5.5.9",
"symfony/dependency-injection": "~2.6"
},
"autoload": {
......
......@@ -5,7 +5,7 @@
"homepage": "https://www.drupal.org/project/drupal",
"license": "GPL-2.0+",
"require": {
"php": ">=5.3.10"
"php": ">=5.5.9"
},
"autoload": {
"psr-0": {
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment