Commit 8dc0353a authored by catch's avatar catch
Browse files

Issue #3120124 by effulgentsia, daffie: Raise the minimum MariaDB version to 10.3(.7) in Drupal 9

parent eae7058a
......@@ -52,7 +52,7 @@ Drupal requires:
recommended to update to at least 7.3.13.
- One of the following databases:
- MySQL 5.7.8 (or greater) (http://www.mysql.com/).
- MariaDB 10.2.7 (or greater) (https://mariadb.org/). MariaDB is a fully
- MariaDB 10.3.7 (or greater) (https://mariadb.org/). MariaDB is a fully
compatible drop-in replacement for MySQL.
- Percona Server 5.7.8 (or greater) (http://www.percona.com/). Percona
Server is a backwards-compatible replacement for MySQL.
......
......@@ -24,10 +24,10 @@ class Tasks extends InstallTasks {
/**
* Minimum required MariaDB version.
*
* 10.2.7 is the minimum version that supports the JSON datatype (alias).
* @see https://mariadb.com/kb/en/json-data-type/
* 10.3.7 is the first stable (GA) release in the 10.3 series.
* @see https://mariadb.com/kb/en/changes-improvements-in-mariadb-103/#list-of-all-mariadb-103-releases
*/
const MARIADB_MINIMUM_VERSION = '10.2.7';
const MARIADB_MINIMUM_VERSION = '10.3.7';
/**
* Minimum required MySQLnd version.
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment