Unverified Commit 68a659fd authored by alexpott's avatar alexpott
Browse files

Issue #3079791 by mikelutz, shaal, Wim Leers, hussainweb, xjm, catch, Charlie...

Issue #3079791 by mikelutz, shaal, Wim Leers, hussainweb, xjm, catch, Charlie ChX Negyesi, Mixologic, Gábor Hojtsy, heddn, amateescu: Bump Drupal's minimum PHP version to 7.2 as soon as 9.0.x is branched (a higher version may be required later)
parent e61b7862
......@@ -653,7 +653,7 @@
"dist": {
"type": "path",
"url": "core",
"reference": "f5caa987fc01923d57a6dba206ad8207c073beab"
"reference": "8f9baa64e9b695577dfeca74d0882b9509cced80"
},
"require": {
"asm89/stack-cors": "^1.1",
......@@ -678,7 +678,7 @@
"guzzlehttp/guzzle": "^6.3",
"masterminds/html5": "^2.1",
"pear/archive_tar": "^1.4.5",
"php": ">=7.0.8",
"php": ">=7.2.3",
"stack/builder": "^1.0",
"symfony-cmf/routing": "^1.4",
"symfony/class-loader": "~3.4.0",
......
......@@ -7,7 +7,7 @@
"license": "GPL-2.0-or-later",
"require": {
"composer-plugin-api": "^1.0.0",
"php": ">=7.0.8"
"php": ">=7.2.3"
},
"conflict": {
"drupal-composer/drupal-scaffold": "*"
......
......@@ -14,7 +14,7 @@
"class": "Drupal\\Composer\\Plugin\\VendorHardening\\VendorHardeningPlugin"
},
"require": {
"php": ">=7.0.8",
"php": ">=7.2.3",
"composer-plugin-api": "^1.1"
}
}
......@@ -15,7 +15,7 @@ QUICKSTART
----------------------
Prerequisites:
- PHP 7.0.8 (or greater) (https://php.net).
- PHP 7.2.3 (or greater) (https://php.net).
In the instructions below, replace the version x.y.z with the specific version
you wish to download. Example: 8.6.0.zip. You can find the latest stable version
......
......@@ -17,7 +17,7 @@
"ext-SPL": "*",
"ext-tokenizer": "*",
"ext-xml": "*",
"php": ">=7.0.8",
"php": ">=7.2.3",
"symfony/class-loader": "~3.4.0",
"symfony/console": "~3.4.0",
"symfony/dependency-injection": "~3.4.26",
......
......@@ -34,7 +34,7 @@
* @todo Move this to an appropriate autoloadable class. See
* https://www.drupal.org/project/drupal/issues/2908079
*/
const DRUPAL_MINIMUM_PHP = '7.0.8';
const DRUPAL_MINIMUM_PHP = '7.2.3';
/**
* Minimum supported version of PHP.
......@@ -48,7 +48,7 @@
* @todo Move this to an appropriate autoloadable class. See
* https://www.drupal.org/project/drupal/issues/2908079
*/
const DRUPAL_MINIMUM_SUPPORTED_PHP = '7.0.8';
const DRUPAL_MINIMUM_SUPPORTED_PHP = '7.2.3';
/**
* Minimum recommended version of PHP.
......@@ -60,7 +60,7 @@
* @todo Move this to an appropriate autoloadable class. See
* https://www.drupal.org/project/drupal/issues/2908079
*/
const DRUPAL_RECOMMENDED_PHP = '7.2';
const DRUPAL_RECOMMENDED_PHP = '7.3';
/**
* Minimum recommended value of PHP memory_limit.
......
......@@ -25,8 +25,8 @@
// The minimum version is specified explicitly, as DRUPAL_MINIMUM_PHP is not
// yet available. It is defined in bootstrap.inc, but it is not possible to
// load that file yet as it would cause a fatal error on older versions of PHP.
if (version_compare(PHP_VERSION, '7.0.8') < 0) {
print 'Your PHP installation is too old. Drupal requires at least PHP 7.0.8. See the <a href="https://www.drupal.org/requirements">system requirements</a> page for more information.';
if (version_compare(PHP_VERSION, '7.2.3') < 0) {
print 'Your PHP installation is too old. Drupal requires at least PHP 7.2.3. See the <a href="https://www.drupal.org/requirements">system requirements</a> page for more information.';
exit;
}
......
......@@ -5,7 +5,7 @@
"homepage": "https://www.drupal.org/project/drupal",
"license": "GPL-2.0-or-later",
"require": {
"php": ">=7.0.8",
"php": ">=7.2.3",
"doctrine/common": "^2.7",
"doctrine/annotations": "^1.4",
"drupal/core-file-cache": "^8.8",
......
......@@ -5,7 +5,7 @@
"homepage": "https://www.drupal.org/project/drupal",
"license": "GPL-2.0-or-later",
"require": {
"php": ">=7.0.8"
"php": ">=7.2.3"
},
"autoload": {
"psr-4": {
......
......@@ -5,7 +5,7 @@
"homepage": "https://www.drupal.org/project/drupal",
"license": "GPL-2.0-or-later",
"require": {
"php": ">=7.0.8",
"php": ">=7.2.3",
"zendframework/zend-feed": "^2.12"
},
"autoload": {
......
......@@ -5,7 +5,7 @@
"homepage": "https://www.drupal.org/project/drupal",
"license": "GPL-2.0-or-later",
"require": {
"php": ">=7.0.8",
"php": ">=7.2.3",
"doctrine/common": "^2.7"
},
"autoload": {
......
......@@ -5,7 +5,7 @@
"homepage": "https://www.drupal.org/project/drupal",
"license": "GPL-2.0-or-later",
"require": {
"php": ">=7.0.8",
"php": ">=7.2.3",
"drupal/core-utility": "^8.8"
},
"autoload": {
......
......@@ -11,7 +11,7 @@
"source": "https://www.drupal.org/project/drupal/git-instructions"
},
"require": {
"php": ">=7.0.8",
"php": ">=7.2.3",
"symfony/dependency-injection": ">=3.4 <4.0.0"
},
"suggest": {
......
......@@ -5,7 +5,7 @@
"homepage": "https://www.drupal.org/project/drupal",
"license": "GPL-2.0-or-later",
"require": {
"php": ">=7.0.8"
"php": ">=7.2.3"
},
"autoload": {
"psr-4": {
......
......@@ -5,7 +5,7 @@
"homepage": "https://www.drupal.org/project/drupal",
"license": "GPL-2.0-or-later",
"require": {
"php": ">=7.0.8",
"php": ">=7.2.3",
"drupal/core-file-cache": "^8.8",
"drupal/core-serialization": "^8.8"
},
......
......@@ -5,7 +5,7 @@
"homepage": "https://www.drupal.org/project/drupal",
"license": "GPL-2.0-or-later",
"require": {
"php": ">=7.0.8",
"php": ">=7.2.3",
"symfony/dependency-injection": ">=3.4 <4.0.0",
"symfony/event-dispatcher": ">=3.4 <4.0.0"
},
......
......@@ -5,7 +5,7 @@
"homepage": "https://www.drupal.org/project/drupal",
"license": "GPL-2.0-or-later",
"require": {
"php": ">=7.0.8"
"php": ">=7.2.3"
},
"autoload": {
"psr-4": {
......
......@@ -5,7 +5,7 @@
"homepage": "https://www.drupal.org/project/drupal",
"license": "GPL-2.0-or-later",
"require": {
"php": ">=7.0.8"
"php": ">=7.2.3"
},
"autoload": {
"psr-4": {
......
......@@ -5,7 +5,7 @@
"homepage": "https://www.drupal.org/project/drupal",
"license": "GPL-2.0-or-later",
"require": {
"php": ">=7.0.8"
"php": ">=7.2.3"
},
"autoload": {
"psr-4": {
......
......@@ -9,7 +9,7 @@
"source": "https://www.drupal.org/project/drupal/git-instructions"
},
"require": {
"php": ">=7.0.8",
"php": ">=7.2.3",
"drupal/core-utility": "^8.8"
},
"autoload": {
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment