Commit 13aef438 authored by alexpott's avatar alexpott

Issue #2267551 followup by jfhovinne: [meta] Deal with PHP requirement vs....

Issue #2267551 followup by jfhovinne: [meta] Deal with PHP requirement vs. Debian PHP version numbering.
parent 900d4038
......@@ -19,8 +19,7 @@ Drupal requires:
- A web server with PHP support, for example:
- Apache 2.0 (or greater) (http://httpd.apache.org/).
- Nginx 1.1 (or greater) (http://www.nginx.com/).
- PHP 5.4.5 (or greater) (http://www.php.net/) or the version that ships with
Debian Wheezy (5.4.4-14) (https://www.debian.org/releases/wheezy/).
- PHP 5.4.5 (or greater) (http://www.php.net/).
- One of the following databases:
- MySQL 5.0.15 (or greater) (http://www.mysql.com/).
- MariaDB 5.1.44 (or greater) (http://mariadb.org/). MariaDB is a fully
......
......@@ -22,12 +22,8 @@
/**
* Minimum supported version of PHP.
*
* Minimum version is 5.4.5, or 5.4.4-14+deb7u14 on Debian Wheezy.
*
* @see https://www.drupal.org/node/2267551.
*/
define('DRUPAL_MINIMUM_PHP', PHP_VERSION == '5.4.4-14+deb7u14' ? '5.4.4' : '5.4.5');
const DRUPAL_MINIMUM_PHP = '5.4.5';
/**
* Minimum recommended value of PHP memory_limit.
......
......@@ -21,7 +21,7 @@
// The minimum version is specified explicitly, as DRUPAL_MINIMUM_PHP is not
// yet available. It is defined in bootstrap.inc, but it is not possible to
// load that file yet as it would cause a fatal error on older versions of PHP.
if (version_compare(PHP_VERSION, '5.4.4-14+deb7u14') < 0 && version_compare(PHP_VERSION, '5.4.5') < 0) {
if (version_compare(PHP_VERSION, '5.4.5') < 0) {
print 'Your PHP installation is too old. Drupal requires at least PHP 5.4.5. See the <a href="http://drupal.org/requirements">system requirements</a> page for more information.';
exit;
}
......
......@@ -15,7 +15,7 @@
return;
}
if (version_compare(PHP_VERSION, '5.4.4-14+deb7u14') < 0 && version_compare(PHP_VERSION, '5.4.5') < 0) {
if (version_compare(PHP_VERSION, '5.4.5') < 0) {
$version = PHP_VERSION;
echo <<<EOF
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment