Commit d8b761e0 authored by jrockowitz's avatar jrockowitz
Browse files

Issue #3096426: Update external libraries

parent 22994e5e
......@@ -28,13 +28,13 @@
"type": "package",
"package": {
"name": "algolia/places",
"version": "1.16.4",
"version": "1.17.0",
"type": "drupal-library",
"extra": {
"installer-name": "algolia.places"
},
"dist": {
"url": "https://registry.npmjs.org/places.js/-/places.js-1.16.4.tgz",
"url": "https://registry.npmjs.org/places.js/-/places.js-1.17.0.tgz",
"type": "tar"
},
"require": {
......@@ -46,13 +46,13 @@
"type": "package",
"package": {
"name": "choices/choices",
"version": "7.0.0",
"version": "9.0.1",
"type": "drupal-library",
"extra": {
"installer-name": "choices"
},
"dist": {
"url": "https://github.com/jshjohnson/Choices/archive/v7.0.0.zip",
"url": "https://github.com/jshjohnson/Choices/archive/v9.0.1.zip",
"type": "zip"
},
"require": {
......@@ -186,24 +186,6 @@
}
}
},
"jquery.geocomplete": {
"type": "package",
"package": {
"name": "jquery/geocomplete",
"version": "1.7.0",
"type": "drupal-library",
"extra": {
"installer-name": "jquery.geocomplete"
},
"dist": {
"url": "https://github.com/ubilabs/geocomplete/archive/1.7.0.zip",
"type": "zip"
},
"require": {
"composer/installers": "~1.0"
}
}
},
"jquery.hotkeys": {
"type": "package",
"package": {
......@@ -262,13 +244,13 @@
"type": "package",
"package": {
"name": "jquery/inputmask",
"version": "4.0.8",
"version": "4.0.9",
"type": "drupal-library",
"extra": {
"installer-name": "jquery.inputmask"
},
"dist": {
"url": "https://github.com/RobinHerbots/jquery.inputmask/archive/4.0.8.zip",
"url": "https://github.com/RobinHerbots/jquery.inputmask/archive/4.0.9.zip",
"type": "zip"
},
"require": {
......@@ -280,13 +262,13 @@
"type": "package",
"package": {
"name": "jquery/intl-tel-input",
"version": "15.1.0",
"version": "16.0.0",
"type": "drupal-library",
"extra": {
"installer-name": "jquery.intl-tel-input"
},
"dist": {
"url": "https://github.com/jackocnr/intl-tel-input/archive/v15.1.0.zip",
"url": "https://github.com/jackocnr/intl-tel-input/archive/v16.0.0.zip",
"type": "zip"
},
"require": {
......@@ -316,13 +298,13 @@
"type": "package",
"package": {
"name": "jquery/select2",
"version": "4.0.8",
"version": "4.0.12",
"type": "drupal-library",
"extra": {
"installer-name": "jquery.select2"
},
"dist": {
"url": "https://github.com/select2/select2/archive/4.0.8.zip",
"url": "https://github.com/select2/select2/archive/4.0.12.zip",
"type": "zip"
},
"require": {
......@@ -449,7 +431,6 @@
"ckeditor/link": "*",
"codemirror/codemirror": "*",
"jquery/chosen": "*",
"jquery/geocomplete": "*",
"jquery/hotkeys": "*",
"jquery/icheck": "*",
"jquery/image-picker": "*",
......
......@@ -342,8 +342,8 @@ class WebformLibrariesManager implements WebformLibrariesManagerInterface {
// NOTE: Using NPM/JsDelivr because it contains the '/dist/cdn/' directory.
// @see https://asset-packagist.org/package/detail?fullname=npm-asset/places.js
// @see https://www.jsdelivr.com/package/npm/places.js
'download_url' => Url::fromUri('https://registry.npmjs.org/places.js/-/places.js-1.16.4.tgz'),
'version' => '1.16.4',
'download_url' => Url::fromUri('https://registry.npmjs.org/places.js/-/places.js-1.17.0.tgz'),
'version' => '1.17.0',
'elements' => ['webform_location_places'],
];
$libraries['jquery.geocomplete'] = [
......@@ -370,16 +370,16 @@ class WebformLibrariesManager implements WebformLibrariesManagerInterface {
'description' => $this->t('Input masks ensures a predefined format is entered. This can be useful for dates, numerics, phone numbers, etc…'),
'notes' => $this->t('Input masks are used to ensure predefined and custom formats for text fields.'),
'homepage_url' => Url::fromUri('https://robinherbots.github.io/Inputmask/'),
'download_url' => Url::fromUri('https://github.com/RobinHerbots/jquery.inputmask/archive/4.0.8.zip'),
'version' => '4.0.8',
'download_url' => Url::fromUri('https://github.com/RobinHerbots/jquery.inputmask/archive/4.0.9.zip'),
'version' => '4.0.9',
];
$libraries['jquery.intl-tel-input'] = [
'title' => $this->t('jQuery: International Telephone Input'),
'description' => $this->t("A jQuery plugin for entering and validating international telephone numbers. It adds a flag dropdown to any input, detects the user's country, displays a relevant placeholder and provides formatting/validation methods."),
'notes' => $this->t('International Telephone Input is used by the Telephone element.'),
'homepage_url' => Url::fromUri('https://github.com/jackocnr/intl-tel-input'),
'download_url' => Url::fromUri('https://github.com/jackocnr/intl-tel-input/archive/v15.1.0.zip'),
'version' => '15.1.0',
'download_url' => Url::fromUri('https://github.com/jackocnr/intl-tel-input/archive/v16.0.0.zip'),
'version' => '16.0.0',
];
$libraries['jquery.rateit'] = [
'title' => $this->t('jQuery: RateIt'),
......@@ -438,8 +438,8 @@ class WebformLibrariesManager implements WebformLibrariesManagerInterface {
'description' => $this->t('Select2 gives you a customizable select box with support for searching and tagging.'),
'notes' => $this->t('Select2 is used to improve the user experience for select menus. Select2 is the recommended select menu enhancement library.'),
'homepage_url' => Url::fromUri('https://select2.github.io/'),
'download_url' => Url::fromUri('https://github.com/select2/select2/archive/4.0.8.zip'),
'version' => '4.0.8',
'download_url' => Url::fromUri('https://github.com/select2/select2/archive/4.0.12.zip'),
'version' => '4.0.12',
'module' => $this->moduleHandler->moduleExists('select2') ? 'select2' : '',
];
$libraries['choices'] = [
......@@ -447,8 +447,8 @@ class WebformLibrariesManager implements WebformLibrariesManagerInterface {
'description' => $this->t('Choices.js is a lightweight, configurable select box/text input plugin. Similar to Select2 and Selectize but without the jQuery dependency.'),
'notes' => $this->t('Choices.js is used to improve the user experience for select menus. Choices.js is an alternative to Select2.'),
'homepage_url' => Url::fromUri('https://joshuajohnson.co.uk/Choices/'),
'download_url' => Url::fromUri('https://github.com/jshjohnson/Choices/archive/v7.0.0.zip'),
'version' => '7.0.0',
'download_url' => Url::fromUri('https://github.com/jshjohnson/Choices/archive/v9.0.1.zip'),
'version' => '9.0.1',
];
$libraries['jquery.chosen'] = [
'title' => $this->t('jQuery: Chosen'),
......
......@@ -993,13 +993,13 @@ imce.input:
libraries.choices:
remote: https://github.com/jshjohnson/Choices
version: '7.0.0'
version: '9.0.1'
license:
name: MIT
url: https://github.com/jshjohnson/Choices/blob/master/LICENSE
gpl-compatible: true
cdn:
/libraries/choices/: https://cdn.jsdelivr.net/gh/jshjohnson/Choices@v7.0.0/
/libraries/choices/: https://cdn.jsdelivr.net/gh/jshjohnson/Choices@v9.0.1/
css:
component:
css/webform.choices.base.css: { }
......@@ -1095,13 +1095,13 @@ libraries.codemirror.twig:
libraries.algolia.places:
remote: https://github.com/algolia/places
version: '1.16.4'
version: '1.17.0'
license:
name: MIT
url: https://github.com/algolia/places/blob/master/LICENSE
gpl-compatible: true
cdn:
/libraries/algolia.places/dist/cdn/: https://cdn.jsdelivr.net/npm/places.js@1.16.4/dist/cdn/
/libraries/algolia.places/dist/cdn/: https://cdn.jsdelivr.net/npm/places.js@1.17.0/dist/cdn/
js:
/libraries/algolia.places/dist/cdn/places.js: {}
......@@ -1176,13 +1176,13 @@ libraries.jquery.icheck.square:
libraries.jquery.inputmask:
remote: https://github.com/RobinHerbots/jquery.inputmask
version: '4.0.8'
version: '4.0.9'
license:
name: MIT
url: http://opensource.org/licenses/mit-license.php
gpl-compatible: true
cdn:
/libraries/jquery.inputmask/: https://cdn.jsdelivr.net/gh/RobinHerbots/Inputmask@4.0.8/
/libraries/jquery.inputmask/: https://cdn.jsdelivr.net/gh/RobinHerbots/Inputmask@4.0.9/
js:
/libraries/jquery.inputmask/dist/min/jquery.inputmask.bundle.min.js: { minified: true }
dependencies:
......@@ -1190,13 +1190,13 @@ libraries.jquery.inputmask:
libraries.jquery.intl-tel-input:
remote: https://github.com/jackocnr/intl-tel-input
version: 'v15.1.0'
version: 'v16.0.0'
license:
name: MIT
url: https://github.com/jackocnr/intl-tel-input/blob/master/LICENSE
gpl-compatible: true
cdn:
/libraries/jquery.intl-tel-input/: https://cdn.jsdelivr.net/gh/jackocnr/intl-tel-input@v15.1.0/
/libraries/jquery.intl-tel-input/: https://cdn.jsdelivr.net/gh/jackocnr/intl-tel-input@v16.0.0/
css:
component:
/libraries/jquery.intl-tel-input/build/css/intlTelInput.min.css: { minified: true }
......@@ -1226,13 +1226,13 @@ libraries.jquery.rateit:
libraries.jquery.select2:
remote: https://select2.github.io/
version: '4.0.8'
version: '4.0.12'
license:
name: MIT
url: http://opensource.org/licenses/mit-license.php
gpl-compatible: true
cdn:
/libraries/jquery.select2/dist/: https://cdnjs.cloudflare.com/ajax/libs/select2/4.0.8/
/libraries/jquery.select2/dist/: https://cdnjs.cloudflare.com/ajax/libs/select2/4.0.12/
css:
component:
/libraries/jquery.select2/dist/css/select2.min.css: { minified: true }
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment