Commit 62b8ad0b authored by navneet0693's avatar navneet0693 Committed by GitHub
Browse files

Issue #3134077 by ronaldtebrake,jochemvn, bramtenhove - Drupal 9 compatibility (#2144)



We have added drupal core compatibility to our info.yml files to show all our custom work is compatible by using
core_version_requirement: ^8.8 || ^9

We have ensured to remove all deprecated code which is removed from Drupal 9. The replacement code is compatible with Drupal 8.9 as well so untill all our contributed modules are Drupal 9 ready, we are still installing Drupal 8.9.

We have added phpstan as a github action, to make sure we wont be using any deprecated code anymore either. All new code will be ran at lvl 5 strictness as well, to ensure our code is also hold to a higher standard.
Co-authored-by: jochemvn's avatarjochemvn <jochemvn@gmail.com>
Co-authored-by: ronaldtebrake's avatarronaldtebrake <ronald@goalgorilla.com>
Co-authored-by: bramtenhove's avatarBram ten Hove <bram@getopensocial.com>
parent 90660c2d
......@@ -5,7 +5,7 @@ type: theme
base theme: socialbase
core: 8.x
core_version_requirement: ^8.8 || ^9
libraries:
- socialblue/brand
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment