Commit f8cc9bd4 authored by helmo's avatar helmo

Make the upgrade script slightly more verbose

parent ceaa53c5
......@@ -147,17 +147,23 @@ fi
mkdir -p $BACKUP_DIR
# Upgrade drush if desired and writable.
if [ $NEW_DRUSH_VERSION != $CURRENT_DRUSH_VERSION && -w $DRUSH_DIR ]; then
if [ -d $DRUSH_DIR ]; then
msg "Moving existing drush into $BACKUP_DIR"
mv $DRUSH_DIR $BACKUP_DIR
fi
if [ $NEW_DRUSH_VERSION != $CURRENT_DRUSH_VERSION ]; then
if [ -w $DRUSH_DIR ]; then
if [ -d $DRUSH_DIR ]; then
msg "Moving existing drush into $BACKUP_DIR"
mv $DRUSH_DIR $BACKUP_DIR
fi
cd $HOME
wget http://github.com/drush-ops/drush/archive/${NEW_DRUSH_VERSION}.zip
unzip ${NEW_DRUSH_VERSION}.zip
rm ${NEW_DRUSH_VERSION}.zip
mv drush-$NEW_DRUSH_VERSION $DRUSH_DIR
cd $HOME
wget http://github.com/drush-ops/drush/archive/${NEW_DRUSH_VERSION}.zip
unzip ${NEW_DRUSH_VERSION}.zip
rm ${NEW_DRUSH_VERSION}.zip
mv drush-$NEW_DRUSH_VERSION $DRUSH_DIR
else
msg "Drush dir($DRUSH_DIR) is not writable, not upgrading Drush."
fi
else
mgs "Not upgrading Drush, $CURRENT_DRUSH_VERSION will be used."
fi
# Fetch new version of provision.
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment