Commit 1530886c authored by Adrian Rossouw's avatar Adrian Rossouw Committed by adrian
Browse files

#613302 - slight validation change so that schema version in current release...

#613302 - slight validation change so that schema version in current release is used when schema version in target release not defined
parent 4904ef74
......@@ -56,7 +56,7 @@ function drush_provision_drupal_pre_provision_deploy($url, $backup_file) {
drush_log(dt("Could not find a version of the !name module", array('!name' => $name)), 'warning');
}
else {
if ($module['schema_version'] > $merged_modules[$name]['schema_version']) {
if (($merged_modules[$name]['schema_version'] > 0) && ($module['schema_version'] > $merged_modules[$name]['schema_version'])) {
drush_set_error('PROVISION_SCHEMA_UPGRADE_FAILURE',
dt("The version of the !name module found on this platform has a lower Schema version than the one the site has installed",
array('!name' => $name)));
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment