Commit e9d3ab45 authored by claudiu.cristea's avatar claudiu.cristea

Issue #2817259 by claudiu.cristea: Installation documentation

parent 24482010
......@@ -6,6 +6,10 @@ The module provides a migrate source plugin for importing data from spreadsheet
[The supported source files](https://github.com/PHPOffice/PhpSpreadsheet#file-formats-supported) includes .ods, .xls, .xlsx, .csv.
## Installing PHPSpreadsheet
Usually we use [Composer](https://getcomposer.org/) to install dependencies in Drupal 8. Unfortunately, the `composer.json` file provided in the module root directory is not automatically parsed when the module gets enabled. For this reason, before installing the module, relevant lines from that file should be copied in the project top `composer.json` file. The entries under `"repositories"`, `"require"` and `"autoload"` > `"psr-4"` should be copied under the same arrays, in the top project's `composer.json`. Then a `$ composer update` should be issued.
## Usage
In your migration file:
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment