Commit e820b0fe authored by claudiu.cristea's avatar claudiu.cristea Committed by claudiu.cristea

Issue #2898429 by claudiu.cristea: Require PHP 5.6

parent 8ab3bc08
......@@ -8,6 +8,12 @@ The module provides a migrate source plugin for importing data from spreadsheet
## Installing PHPSpreadsheet
### Requirements
Migrate Spreadsheet module requires PHP >= 5.6 due to its dependency on [PhpOffice/PhpSpreadsheet](https://github.com/PHPOffice/PhpSpreadsheet) library, which requires at least PHP 5.6.
### Get the code
Usually we use [Composer](https://getcomposer.org/) to install dependencies in Drupal 8. All you need to do is to add this module as dependency in your project top `composer.json` file:
```json
......@@ -18,19 +24,16 @@ Usually we use [Composer](https://getcomposer.org/) to install dependencies in D
"drupal/migrate_spreadsheet": "~1.0-beta2",
...
},
"repositories": [
{
"type": "composer",
"url": "https://packages.drupal.org/8"
},
...
],
...
}
```
Then a `$ composer update` should be issued and Composer will install the [PhpOffice/PhpSpreadsheet](https://github.com/PHPOffice/PhpSpreadsheet) dependency.
### Enable the module
Enable the module as any other Drupal module.
## Usage
In the migration file add the plugin provided by this module as source plugin:
......
type: module
name: 'Migrate Spreadsheet'
description: 'Provides a migrate source plugin for importing data from spreadsheet files.'
php: '5.6'
core: '8.x'
package: Migration
dependencies:
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment