Commit 2c0601cb authored by DuaelFr's avatar DuaelFr Committed by borisson_

Issue #3006741 by DuaelFr: Upgrading facets (8006) and block_content (8.6.x)...

Issue #3006741 by DuaelFr: Upgrading facets (8006) and block_content (8.6.x) at the same time cause a fatal error
parent e6c753e3
......@@ -9,6 +9,18 @@ use Drupal\facets\Entity\Facet;
use Drupal\facets\Entity\FacetSource;
use Drupal\block\Entity\Block;
/**
* Implements hook_update_dependencies().
*/
function facets_update_dependencies() {
// block_content_update_8600() adds some fields to Blocks that makes
// facets_update_8006() fail if upgraded at the same time.
$dependencies['facets'][8006] = [
'block_content' => 8600,
];
return $dependencies;
}
/**
* Convert facets on Search Api facet sources to use the display plugin.
*/
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment