Commit f22b1017 authored by Gerhard Killesreiter's avatar Gerhard Killesreiter

#55609, better MySQL requirement docs. Patch by webchick.

parent f830e05a
......@@ -41,8 +41,10 @@ INSTALLATION AND CONFIGURATION
Again, you will be asked for the 'dba_user' database password.
At the MySQL prompt, enter following command:
GRANT ALL PRIVILEGES ON databasename.*
TO username@localhost IDENTIFIED BY 'password';
GRANT SELECT, INSERT, UPDATE, DELETE, CREATE, DROP, INDEX,
ALTER, CREATE TEMPORARY TABLES, LOCK TABLES
ON databasename.*
TO 'username'@'localhost' IDENTIFIED BY 'password';
where
......@@ -50,6 +52,9 @@ INSTALLATION AND CONFIGURATION
'username@localhost' is the username of your MySQL account
'password' is the password required for that username
Note: Unless your database user has all of the privileges listed
above, you will not be able to run Drupal.
If successful, MySQL will reply with:
Query OK, 0 rows affected
......
......@@ -15,7 +15,10 @@ REQUIREMENTS
Drupal requires a web server, PHP4 (4.3.3 or greater) or PHP5
(http://www.php.net/) and either MySQL (http://www.mysql.com/)
or PostgreSQL (http://www.postgresql.org/).
or PostgreSQL (http://www.postgresql.org/). Your database user
will also need sufficient privileges to run Drupal. Please
check the INSTALL.mysql.txt and INSTALL.pgsql.txt for more
detailed information.
NOTE: the Apache web server and MySQL database are strongly recommended;
other web server and database combinations such as IIS and PostgreSQL
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment