Commit d5794aca authored by Dries's avatar Dries

- Patch #1463564 by effulgentsia: Drupal 8 cannot be installed or used on PHP <5.3.3.

parent 4e1353fc
......@@ -3,7 +3,7 @@ SQLITE REQUIREMENTS
-------------------
To use SQLite with your Drupal installation, the following requirements must be
met: Server has PHP 5.3.2 or later with PDO, and the PDO SQLite driver must be
met: Server has PHP 5.3.3 or later with PDO, and the PDO SQLite driver must be
enabled.
SQLITE DATABASE CREATION
......
......@@ -15,7 +15,7 @@ REQUIREMENTS AND NOTES
Drupal requires:
- A web server. Apache (version 2.0 or greater) is recommended.
- PHP 5.3.2 (or greater) (http://www.php.net/).
- PHP 5.3.3 (or greater) (http://www.php.net/).
- One of the following databases:
- MySQL 5.0.15 (or greater) (http://www.mysql.com/).
- MariaDB 5.1.44 (or greater) (http://mariadb.org/). MariaDB is a fully
......
......@@ -22,7 +22,7 @@
/**
* Minimum supported version of PHP.
*/
const DRUPAL_MINIMUM_PHP = '5.3.2';
const DRUPAL_MINIMUM_PHP = '5.3.3';
/**
* Minimum recommended value of PHP memory_limit.
......
......@@ -26,8 +26,8 @@
// The minimum version is specified explicitly, as DRUPAL_MINIMUM_PHP is not
// yet available. It is defined in bootstrap.inc, but it is not possible to
// load that file yet as it would cause a fatal error on older versions of PHP.
if (version_compare(PHP_VERSION, '5.3.2') < 0) {
print 'Your PHP installation is too old. Drupal requires at least PHP 5.3.2. See the <a href="http://drupal.org/requirements">system requirements</a> page for more information.';
if (version_compare(PHP_VERSION, '5.3.3') < 0) {
print 'Your PHP installation is too old. Drupal requires at least PHP 5.3.3. See the <a href="http://drupal.org/requirements">system requirements</a> page for more information.';
exit;
}
......
......@@ -26,8 +26,8 @@
// The minimum version is specified explicitly, as DRUPAL_MINIMUM_PHP is not
// yet available. It is defined in bootstrap.inc, but it is not possible to
// load that file yet as it would cause a fatal error on older versions of PHP.
if (version_compare(PHP_VERSION, '5.3.2') < 0) {
print 'Your PHP installation is too old. Drupal requires at least PHP 5.3.2. See the <a href="http://drupal.org/requirements">system requirements</a> page for more information.';
if (version_compare(PHP_VERSION, '5.3.3') < 0) {
print 'Your PHP installation is too old. Drupal requires at least PHP 5.3.3. See the <a href="http://drupal.org/requirements">system requirements</a> page for more information.';
exit;
}
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment