Commit b966efe5 authored by catch's avatar catch

Issue #3156651 by alexpott, dww, pfrenssen, Kristen Pol, xjm, andypost, Gábor...

Issue #3156651 by alexpott, dww, pfrenssen, Kristen Pol, xjm, andypost, Gábor Hojtsy, bradjones1: Prevent Drupal 8.9 and 9.0 from being installed on PHP 8
parent ac09eeff
......@@ -671,7 +671,7 @@
"dist": {
"type": "path",
"url": "core",
"reference": "00a84fa61ee921f106f7912c3ca0393a2c328e68"
"reference": "9e58f98953ff193220b4366d62446dc984f346d4"
},
"require": {
"asm89/stack-cors": "^1.1",
......@@ -698,7 +698,7 @@
"laminas/laminas-feed": "^2.12",
"masterminds/html5": "^2.1",
"pear/archive_tar": "^1.4.9",
"php": ">=7.0.8",
"php": "^7.0.8",
"psr/log": "^1.0",
"stack/builder": "^1.0",
"symfony-cmf/routing": "^1.4",
......
......@@ -17,7 +17,7 @@
"ext-SPL": "*",
"ext-tokenizer": "*",
"ext-xml": "*",
"php": ">=7.0.8",
"php": "^7.0.8",
"symfony/class-loader": "~3.4.0",
"symfony/console": "~3.4.0",
"symfony/dependency-injection": "~3.4.26",
......
......@@ -29,6 +29,10 @@
print 'Your PHP installation is too old. Drupal requires at least PHP 7.0.8. See the <a href="https://www.drupal.org/requirements">system requirements</a> page for more information.';
exit;
}
elseif (version_compare(PHP_VERSION, '8.0', '>=')) {
print 'Update to the latest release of Drupal 9 for improved PHP 8 support, or use PHP 7.4. See the <a href="https://www.drupal.org/requirements">system requirements</a> page for more information.';
exit;
}
// Initialize the autoloader.
$class_loader = require_once $root_path . '/autoload.php';
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment