Commit b299b9ee authored by Gábor Hojtsy's avatar Gábor Hojtsy

#204411 by catch: elevate MySQL requirements to 4.1.1 (the first production...

#204411 by catch: elevate MySQL requirements to 4.1.1 (the first production MySQL 4.1.x was 4.1.5 anyway)
parent 04daca23
......@@ -18,7 +18,7 @@ Drupal requires a web server, PHP 4 (4.3.5 or greater) or PHP 5
(http://www.php.net/) and either MySQL (http://www.mysql.com/) or PostgreSQL
(http://www.postgresql.org/). The Apache web server and MySQL database are
recommended; other web server and database combinations such as IIS and
PostgreSQL have been tested to a lesser extent. When using MySQL, version 4.1
PostgreSQL have been tested to a lesser extent. When using MySQL, version 4.1.1
or greater is recommended to assure you can safely transfer the database.
For more detailed information about Drupal requirements, see "Requirements"
......
......@@ -80,10 +80,8 @@ function db_connect($url) {
_db_error_page(mysql_error());
}
// On MySQL 4.1 and later, force UTF-8.
if (version_compare(mysql_get_server_info(), '4.1.0', '>=')) {
mysql_query('SET NAMES "utf8"', $connection);
}
// Force UTF-8.
mysql_query('SET NAMES "utf8"', $connection);
return $connection;
}
......
......@@ -29,7 +29,7 @@
/**
* Minimum supported version of MySQL, if it is used.
*/
define('DRUPAL_MINIMUM_MYSQL', '4.1.0');
define('DRUPAL_MINIMUM_MYSQL', '4.1.1');
/**
* Minimum supported version of PostgreSQL, if it is used.
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment