Commit a0935c9a authored by catch's avatar catch

Issue #3156651 by alexpott, dww, pfrenssen, Kristen Pol, xjm, andypost, Gábor...

Issue #3156651 by alexpott, dww, pfrenssen, Kristen Pol, xjm, andypost, Gábor Hojtsy, bradjones1: Prevent Drupal 8.9 and 9.0 from being installed on PHP 8
parent 4dce8e50
......@@ -485,7 +485,7 @@
"dist": {
"type": "path",
"url": "core",
"reference": "5bd6798a64831fa08a343a14a0ee47127c4cb99f"
"reference": "806585e0390b77d1a38aa32b3947f93004788c88"
},
"require": {
"asm89/stack-cors": "^1.1",
......@@ -511,7 +511,7 @@
"laminas/laminas-feed": "^2.12",
"masterminds/html5": "^2.1",
"pear/archive_tar": "^1.4.9",
"php": ">=7.3",
"php": "^7.3",
"psr/log": "^1.0",
"stack/builder": "^1.0",
"symfony-cmf/routing": "^2.1",
......
......@@ -17,7 +17,7 @@
"ext-SPL": "*",
"ext-tokenizer": "*",
"ext-xml": "*",
"php": ">=7.3",
"php": "^7.3",
"symfony/console": "^4.4",
"symfony/dependency-injection": "^4.4",
"symfony/event-dispatcher": "^4.4",
......
......@@ -29,6 +29,10 @@
print 'Your PHP installation is too old. Drupal requires at least PHP 7.3.0. See the <a href="https://www.drupal.org/requirements">system requirements</a> page for more information.';
exit;
}
elseif (version_compare(PHP_VERSION, '8.0', '>=')) {
print 'Update to the latest release of Drupal 9 for improved PHP 8 support, or use PHP 7.4. See the <a href="https://www.drupal.org/requirements">system requirements</a> page for more information.';
exit;
}
// Initialize the autoloader.
$class_loader = require_once $root_path . '/autoload.php';
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment