Commit 92c6453b authored by Gábor Hojtsy's avatar Gábor Hojtsy

Start rolling with Drupal 6 RC4:

 - include Drupal 5.7 changelog
 - correct jQuery version number
 - error level fix for RC
 - version numbers aligned
parent ba74c7ce
// $Id$
Drupal 6.0, xxxx-xx-xx (development version)
Drupal 6.0-rc4, 2008-02-08
----------------------
- New, faster and better menu system.
- New watchdog as a hook functionality.
......@@ -92,7 +92,7 @@ Drupal 6.0, xxxx-xx-xx (development version)
and warn sites if they are missing security updates or newer versions.
Sites deploying from CVS should use http://drupal.org/project/cvs_deploy.
Advanced settings provided by http://drupal.org/project/update_advanced.
- Upgraded the core JavaScript library to jQuery version 1.2.
- Upgraded the core JavaScript library to jQuery version 1.2.3.
- Added a new Schema API, which provides built-in support for core and
contributed modules to work with databases other than MySQL.
- Removed drupal.module. The functionality lives on as the Site network
......@@ -100,6 +100,11 @@ Drupal 6.0, xxxx-xx-xx (development version)
- Removed old system updates. Updates from Drupal versions prior to 5.x will
require upgrading to 5.x before upgrading to 6.x.
Drupal 5.7, 2008-01-28
----------------------
- fixed the input format configuration page.
- fixed a variety of small bugs.
Drupal 5.6, 2008-01-10
----------------------
- fixed a variety of small bugs.
......
......@@ -577,7 +577,7 @@ function drupal_error_handler($errno, $message, $filename, $line, $context) {
return;
}
if ($errno & (E_ALL)) {
if ($errno & (E_ALL ^ E_NOTICE)) {
$types = array(1 => 'error', 2 => 'warning', 4 => 'parse error', 8 => 'notice', 16 => 'core error', 32 => 'core warning', 64 => 'compile error', 128 => 'compile warning', 256 => 'user error', 512 => 'user warning', 1024 => 'user notice', 2048 => 'strict warning', 4096 => 'recoverable fatal error');
// For database errors, we want the line number/file name of the place that
......
......@@ -9,7 +9,7 @@
/**
* The current system version.
*/
define('VERSION', '6.0-dev');
define('VERSION', '6.0-rc4');
/**
* Core API compatibility.
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment