Unverified Commit 7b198e49 authored by alexpott's avatar alexpott

Issue #3117396 by penyaskito, Berdir: Pathauto requirements confusing message when running -dev

parent 84bd3594
......@@ -1306,7 +1306,7 @@ function system_requirements($phase) {
if ($phase === 'install' || $phase === 'update') {
if (\Drupal::moduleHandler()->moduleExists('pathauto')) {
$info = \Drupal::service('extension.list.module')->getExtensionInfo('pathauto');
if (version_compare($info['version'], '8.x-1.5') <= 0) {
if ($info['version'] && version_compare($info['version'], '8.x-1.5') <= 0) {
$requirements['pathauto_module_incompatibility'] = [
'title' => t('Pathauto'),
'description' => t('The Pathauto module is not compatible with the current version of Drupal core. Update the <a href=":url">Pathauto</a> module to 8.x-1.6 or later.', [
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment