Commit 2be8f419 authored by catch's avatar catch

Issue #3056875 by alexpott: Remove drupal-phpunit-upgrade-check from...

Issue #3056875 by alexpott: Remove drupal-phpunit-upgrade-check from run-tests.sh and docs relating to drupal-phpunit-upgrade
parent bed931bb
......@@ -474,23 +474,6 @@ function simpletest_script_init() {
exit(SIMPLETEST_SCRIPT_EXIT_FAILURE);
}
// Detect if we're in the top-level process using the private 'execute-test'
// argument. Determine if being run on drupal.org's testing infrastructure
// using the presence of 'drupaltestbot' in the database url.
// @todo https://www.drupal.org/project/drupalci_testbot/issues/2860941 Use
// better environment variable to detect DrupalCI.
// @todo https://www.drupal.org/project/drupal/issues/2942473 Remove when
// dropping PHPUnit 4 and PHP 5 support.
if (!$args['execute-test'] && preg_match('/drupalci/', $args['sqlite'])) {
// Update PHPUnit if needed and possible. There is a later check once the
// autoloader is in place to ensure we're on the correct version. We need to
// do this before the autoloader is in place to ensure that it is correct.
$composer = ($composer = rtrim('\\' === DIRECTORY_SEPARATOR ? preg_replace('/[\r\n].*/', '', `where.exe composer.phar`) : `which composer.phar`))
? $php . ' ' . escapeshellarg($composer)
: 'composer';
passthru("$composer run-script drupal-phpunit-upgrade-check");
}
$autoloader = require_once __DIR__ . '/../../autoload.php';
// Get URL from arguments.
......
......@@ -74,8 +74,6 @@ chromedriver using port 4444, and keep it running:
* Ensure your vendor directory is populated
(e.g. by running `composer install`)
* If you're running PHP 7.0 or greater you will need to upgrade PHPUnit with
`composer run-script drupal-phpunit-upgrade`
* Install [Node.js](https://nodejs.org/en/download/) and
[yarn](https://yarnpkg.com/en/docs/install). The versions required are
specificed inside core/package.json in the `engines` field
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment