Commit 029a18d7 authored by webchick's avatar webchick

Issue #2203435 by sun: Move all external libraries from core modules into core.libraries.yml.

parent afa38dc2
......@@ -324,6 +324,18 @@ jquery.intrinsic:
dependencies:
- core/jquery
jquery.joyride:
remote: https://github.com/zurb/joyride
version: v2.0.3
js:
assets/vendor/jquery-joyride/jquery.joyride-2.0.3.js: {}
css:
component:
assets/vendor/jquery-joyride/joyride-2.0.3.css: { media: screen }
dependencies:
- core/jquery
- core/jquery.cookie
jquery.once:
remote: https://github.com/RobLoach/jquery-once
version: 1.2.3
......@@ -670,6 +682,16 @@ normalize:
base:
assets/vendor/normalize-css/normalize.css: { every_page: true, weight: -20 }
picturefill:
remote: https://github.com/scottjehl/picturefill
# @todo Contribute upstream and/or replace with upstream version.
# @see https://drupal.org/node/1775530
version: VERSION
js:
assets/vendor/picturefill/picturefill.js: { weight: -10 }
dependencies:
- core/matchmedia
underscore:
remote: https://github.com/jashkenas/underscore
version: 1.5.2
......
......@@ -172,7 +172,7 @@ public function viewElements(FieldItemListInterface $items) {
$elements[$delta] = array(
'#theme' => 'picture_formatter',
'#attached' => array('library' => array(
array('picture', 'picturefill'),
array('core', 'picturefill'),
)),
'#item' => $item,
'#image_style' => $fallback_image_style,
......
# @todo Move into /core/assets and core.library.yml.
picturefill:
remote: https://github.com/scottjehl/picturefill
# @todo Contribute upstream and/or replace with upstream version.
# @see https://drupal.org/node/1775530
version: VERSION
js:
picturefill/picturefill.js: { weight: -10 }
dependencies:
- core/matchmedia
......@@ -6,7 +6,7 @@ tour:
- core/jquery
- core/drupal
- core/backbone
- tour/jquery.joyride
- core/jquery.joyride
- tour/tour-styling
tour-styling:
......@@ -14,16 +14,3 @@ tour-styling:
css:
component:
css/tour.module.css: { media: screen }
# @todo Move into /core/assets and core.library.yml.
jquery.joyride:
remote: https://github.com/zurb/joyride
version: v2.0.3
js:
js/jquery.joyride-2.0.3.js: {}
css:
component:
css/joyride-2.0.3.css: { media: screen }
dependencies:
- core/jquery
- core/jquery.cookie
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment