install.php 1.53 KB
Newer Older
1 2
<?php

3 4 5 6 7
/**
 * @file
 * Initiates a browser-based installation of Drupal.
 */

8 9 10
// Change the directory to the Drupal root.
chdir('..');

11 12
require_once __DIR__ . '/vendor/autoload.php';

13
/**
14
 * Global flag to indicate the site is in installation mode.
15
 *
16 17 18
 * The constant is defined using define() instead of const so that PHP
 * versions prior to 5.3 can display proper PHP requirements instead of causing
 * a fatal error.
19
 */
20
define('MAINTENANCE_MODE', 'install');
21

22
// Exit early if running an incompatible PHP version to avoid fatal errors.
23 24 25
// The minimum version is specified explicitly, as DRUPAL_MINIMUM_PHP is not
// yet available. It is defined in bootstrap.inc, but it is not possible to
// load that file yet as it would cause a fatal error on older versions of PHP.
26 27
if (version_compare(PHP_VERSION, '5.3.10') < 0) {
  print 'Your PHP installation is too old. Drupal requires at least PHP 5.3.10. See the <a href="http://drupal.org/requirements">system requirements</a> page for more information.';
28 29 30
  exit;
}

31 32 33 34 35 36 37 38
// Exit early if the PHP option safe_mode is enabled to avoid fatal errors.
// @todo Remove this check once we require PHP > 5.4 as safe mode is deprecated
// in PHP 5.3 and completely removed in PHP 5.4.
if (ini_get('safe_mode')) {
  print 'Your PHP installation has safe_mode enabled. Drupal requires the safe_mode option to be turned off. See the <a href="http://drupal.org/requirements">system requirements</a> page for more information.';
  exit;
}

39
// Start the installer.
40
require_once __DIR__ . '/includes/install.core.inc';
41
install_drupal();