core.libraries.yml 26.7 KB
Newer Older
1 2 3 4
# All libraries are defined in alphabetical order.

backbone:
  remote: https://github.com/jashkenas/backbone
5
  version: "1.2.3"
6 7
  license:
    name: MIT
8
    url: https://github.com/jashkenas/backbone/blob/1.2.3/LICENSE
9
    gpl-compatible: true
10
  js:
11
    assets/vendor/backbone/backbone-min.js: { weight: -19, minified: true }
12 13 14 15 16
  dependencies:
    - core/underscore

classList:
  remote: https://github.com/eligrey/classList.js
17
  version: "2014-12-13"
18 19
  license:
    name: Public Domain
20
    url: https://github.com/eligrey/classList.js/blob/2014-12-13/LICENSE.md
21
    gpl-compatible: true
22
  js:
23
    assets/vendor/classList/classList.min.js: { weight: -21, browsers: { IE: 'lte IE 9', '!IE': false }, minified: true }
24 25 26

ckeditor:
  remote: https://github.com/ckeditor/ckeditor-dev
27
  version: "4.11.4"
28 29
  license:
    name: GNU-GPL-2.0-or-later
30
    url: https://github.com/ckeditor/ckeditor-dev/blob/4.11.4/LICENSE.md
31
    gpl-compatible: true
32
  js:
33
    assets/vendor/ckeditor/ckeditor.js: { preprocess: false, minified: true }
34 35 36

domready:
  remote: https://github.com/ded/domready
37
  version: "1.0.8"
38 39
  license:
    name: MIT
40
    url: https://github.com/ded/domready/blob/v1.0.8/LICENSE
41
    gpl-compatible: true
42
  js:
43
    assets/vendor/domready/ready.min.js: { weight: -21, minified: true }
44
  deprecated: The "%library_id%" asset library is deprecated in drupal:8.8.0 and is removed from drupal:9.0.0. See https://www.drupal.org/node/3086669
45 46 47 48

drupal:
  version: VERSION
  js:
49
    misc/drupal.js: { weight: -18 }
50
    misc/drupal.init.js: { weight: -17 }
51
  dependencies:
52
    - core/drupalSettings
53 54
  drupalSettings:
    suppressDeprecationErrors: true
55 56 57

drupalSettings:
  version: VERSION
58 59 60 61
  js:
    # Need to specify a negative weight like drupal.js until
    # https://www.drupal.org/node/1945262 is resolved.
    misc/drupalSettingsLoader.js: { weight: -18 }
62 63 64 65 66 67 68 69 70 71
  drupalSettings:
    # These placeholder values will be set by system_js_settings_alter().
    path:
      baseUrl: null
      scriptPath: null
      pathPrefix: null
      currentPath: null
      currentPathIsAdmin: null
      isFront: null
      currentLanguage: null
72
    pluralDelimiter: null
73 74 75 76 77 78 79 80 81 82 83 84 85 86

drupal.active-link:
  version: VERSION
  js:
    misc/active-link.js: {}
  dependencies:
    - core/drupal
    - core/drupalSettings
    - core/classList

drupal.ajax:
  version: VERSION
  js:
    misc/ajax.js: {}
87 88 89 90 91 92
  drupalSettings:
    # These placeholder values will be set by system_js_settings_alter().
    ajaxPageState:
      libraries: null
      theme: null
      theme_token: null
93
    ajaxTrustedUrl: {}
94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111
  dependencies:
    - core/jquery
    - core/drupal
    - core/drupalSettings
    - core/drupal.progress
    - core/jquery.once

drupal.announce:
  version: VERSION
  js:
    misc/announce.js: {}
  dependencies:
    - core/drupal
    - core/drupal.debounce

drupal.autocomplete:
  version: VERSION
  js:
112
    misc/autocomplete.js: { weight: -1 }
113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131
  dependencies:
    - core/jquery
    - core/drupal
    - core/drupalSettings
    - core/drupal.ajax
    - core/jquery.ui.autocomplete

drupal.batch:
  version: VERSION
  js:
    misc/batch.js: { cache: false }
  dependencies:
    - core/jquery
    - core/drupal
    - core/drupalSettings
    - core/drupal.ajax
    - core/drupal.progress
    - core/jquery.once

132 133 134 135 136 137 138
drupal.checkbox:
  version: VERSION
  js:
    misc/checkbox.js: {}
  dependencies:
    - core/drupal

139 140 141
drupal.collapse:
  version: VERSION
  js:
142
    misc/details-aria.js: {}
143 144 145 146 147 148 149 150
    misc/collapse.js: {}
  dependencies:
    - core/jquery
    - core/modernizr
    - core/drupal
    - core/drupal.form
    - core/jquery.once

151 152 153 154 155 156 157
drupal.date:
  version: VERSION
  js:
    misc/date.js: {}
  dependencies:
    - core/drupal
    - core/modernizr
158
    - core/jquery.once
159 160
    - core/jquery.ui.datepicker

161 162 163 164 165 166 167 168 169 170 171
drupal.debounce:
  version: VERSION
  js:
    misc/debounce.js: {}
  dependencies:
    # @todo Remove Drupal dependency.
    - core/drupal

drupal.dialog:
  version: VERSION
  js:
172 173 174
    misc/dialog/dialog.js: {}
    misc/dialog/dialog.position.js: {}
    misc/dialog/dialog.jquery-ui.js: {}
175 176 177 178 179 180 181 182 183 184 185
  dependencies:
    - core/jquery
    - core/drupal
    - core/drupalSettings
    - core/drupal.debounce
    - core/drupal.displace
    - core/jquery.ui.dialog

drupal.dialog.ajax:
  version: VERSION
  js:
186
    misc/dialog/dialog.ajax.js: {}
187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215
  dependencies:
    - core/jquery
    - core/drupal
    - core/drupalSettings
    - core/drupal.ajax
    - core/drupal.dialog

drupal.displace:
  version: VERSION
  js:
    misc/displace.js: {}
  dependencies:
    - core/jquery
    - core/drupal
    - core/drupal.debounce

drupal.dropbutton:
  version: VERSION
  js:
    misc/dropbutton/dropbutton.js: {}
  css:
    component:
      misc/dropbutton/dropbutton.css: {}
  dependencies:
    - core/jquery
    - core/drupal
    - core/drupalSettings
    - core/jquery.once

216 217 218 219 220 221 222
drupal.entity-form:
  version: VERSION
  js:
    misc/entity-form.js: {}
  dependencies:
    - core/drupal.form

223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242
drupal.form:
  version: VERSION
  js:
    misc/form.js: {}
  dependencies:
    - core/jquery
    - core/drupal
    - core/drupal.debounce
    - core/jquery.cookie
    - core/jquery.once

drupal.machine-name:
  version: VERSION
  js:
    misc/machine-name.js: {}
  dependencies:
    - core/jquery
    - core/jquery.once
    - core/drupal
    - core/drupalSettings
243
    - core/drupal.form
244

245 246 247 248 249 250 251 252
drupal.message:
  version: VERSION
  js:
    misc/message.js: {}
  dependencies:
    - core/drupal
    - core/drupal.announce

253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284
drupal.progress:
  version: VERSION
  js:
    misc/progress.js: {}
  dependencies:
    - core/drupal
    - core/jquery
    - core/drupalSettings

drupal.states:
  version: VERSION
  js:
    misc/states.js: {}
  dependencies:
    - core/jquery
    - core/drupal
    - core/drupalSettings
    - core/jquery.once

drupal.tabbingmanager:
  version: VERSION
  js:
    misc/tabbingmanager.js: {}
  dependencies:
    - core/jquery
    # Supplies the ':tabbable' pseudo selector.
    - core/jquery.ui
    - core/drupal

drupal.tabledrag:
  version: VERSION
  js:
285
    misc/tabledrag.js: { weight: -1 }
286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318
  dependencies:
    - core/jquery
    - core/drupal
    - core/drupalSettings
    - core/jquery.once
    - core/jquery.cookie

drupal.tableheader:
  version: VERSION
  js:
    misc/tableheader.js: {}
  dependencies:
    - core/jquery
    - core/drupal
    - core/drupalSettings
    - core/jquery.once
    - core/drupal.displace

drupal.tableresponsive:
  version: VERSION
  js:
    misc/tableresponsive.js: {}
  dependencies:
    - core/jquery
    - core/drupal
    - core/jquery.once

drupal.tableselect:
  version: VERSION
  js:
    misc/tableselect.js: {}
  dependencies:
    - core/drupal
319
    - core/drupal.checkbox
320
    - core/jquery
321
    - core/jquery.once
322 323 324 325 326 327 328

drupal.timezone:
  version: VERSION
  js:
    misc/timezone.js: {}
  dependencies:
    - core/jquery
329
    - core/jquery.once
330 331 332 333 334 335
    - core/drupal

drupal.vertical-tabs:
  version: VERSION
  js:
    # Load before core/drupal.collapse.
336
    misc/vertical-tabs.js: { weight: -1 }
337 338 339 340 341
  css:
    component:
      misc/vertical-tabs.css: {}
  dependencies:
    - core/jquery
342
    - core/jquery.once
343 344 345
    - core/drupal
    - core/drupalSettings
    - core/drupal.form
346
    - core/matchmedia
347 348

html5shiv:
349 350
  # Block the page from being loaded until html5shiv is initialized.
  header: true
351
  remote: https://github.com/aFarkas/html5shiv
352
  version: "3.7.3"
353 354 355 356
  license:
    name: GNU-GPL-2.0-or-later
    url: http://www.gnu.org/licenses/gpl-2.0.html
    gpl-compatible: true
357
  js:
358
    assets/vendor/html5shiv/html5shiv.min.js: { weight: -22, browsers: { IE: 'lte IE 8', '!IE': false }, minified: true }
359
  deprecated: The "%library_id%" asset library is deprecated in drupal:8.8.0 and is removed from drupal:9.0.0. See https://www.drupal.org/node/3086383
360 361 362

jquery:
  remote: https://github.com/jquery/jquery
363
  version: "3.4.1"
364 365
  license:
    name: MIT
366
    url: https://github.com/jquery/jquery/blob/3.4.1/LICENSE.txt
367
    gpl-compatible: true
368
  js:
369
    assets/vendor/jquery/jquery.min.js: { minified: true, weight: -20 }
370 371 372

jquery.cookie:
  remote: https://github.com/carhartl/jquery-cookie
373
  version: "v1.4.1"
374 375
  license:
    name: MIT
376
    url: https://github.com/carhartl/jquery-cookie/blob/v1.4.1/MIT-LICENSE.txt
377
    gpl-compatible: true
378
  js:
379
    assets/vendor/jquery.cookie/jquery.cookie.min.js: { minified: true }
380 381 382 383 384 385
  dependencies:
    - core/jquery

jquery.farbtastic:
  remote: https://github.com/mattfarina/farbtastic
  # @todo Ping @robloach or @mattfarina to retroactively create this release.
386
  version: "1.2"
387 388 389 390
  license:
    name: GNU-GPL-2.0-or-later
    url: https://github.com/mattfarina/farbtastic/blob/master/LICENSE.txt
    gpl-compatible: true
391
  js:
392
    assets/vendor/farbtastic/farbtastic.js: { minified: true }
393 394 395 396 397 398 399
  css:
    component:
      assets/vendor/farbtastic/farbtastic.css: {}
  dependencies:
    - core/jquery

jquery.form:
400 401
  remote: https://github.com/jquery-form/form
  version: "4.22"
402 403
  license:
    name: GNU-GPL-2.0-or-later
404
    url: https://raw.githubusercontent.com/jquery-form/form/master/LICENSE-LGPLv3
405
    gpl-compatible: true
406
  js:
407
    assets/vendor/jquery-form/jquery.form.min.js: { minified: true }
408 409 410
  dependencies:
    - core/jquery

411 412
jquery.joyride:
  remote: https://github.com/zurb/joyride
413 414 415 416 417 418
  # We rely on a fix (commit c2b3866) that occurred after 2.1.0 was released.
  # @see https://www.drupal.org/node/2898808.
  # @todo Update to 2.1.1 or later when that's released.
  # Version is set at 2.1.0.1 allowing version_compare to consider this lower
  # than 2.1.1 however greater than 2.1.0
  version: "2.1.0.1"
419 420
  license:
    name: MIT
421
    url: https://github.com/zurb/joyride/blob/v2.1.0/README.markdown
422
    gpl-compatible: true
423
  js:
424
    assets/vendor/jquery-joyride/jquery.joyride-2.1.js: { }
425 426 427 428
  dependencies:
    - core/jquery
    - core/jquery.cookie

429 430
jquery.once:
  remote: https://github.com/RobLoach/jquery-once
431
  version: "2.2.0"
432 433
  license:
    name: GNU-GPL-2.0-or-later
434
    url: https://raw.githubusercontent.com/RobLoach/jquery-once/2.2.0/LICENSE.md
435
    gpl-compatible: true
436
  js:
437
    assets/vendor/jquery-once/jquery.once.min.js: { weight: -19, minified: true }
438 439 440 441 442
  dependencies:
    - core/jquery

jquery.ui:
  remote: https://github.com/jquery/jquery-ui
443
  version: &jquery_ui_version 1.12.1
444
  license: &jquery_ui_license
445
    name: Public Domain
446
    url: https://github.com/jquery/jquery-ui/blob/1.12.1/LICENSE.txt
447
    gpl-compatible: true
448
  js:
449 450 451 452 453 454 455 456 457
    assets/vendor/jquery.ui/ui/data-min.js: { weight: -11, minified: true }
    assets/vendor/jquery.ui/ui/disable-selection-min.js: { weight: -11, minified: true }
    assets/vendor/jquery.ui/ui/form-min.js: { weight: -11, minified: true }
    assets/vendor/jquery.ui/ui/labels-min.js: { weight: -11, minified: true }
    assets/vendor/jquery.ui/ui/jquery-1-7-min.js: { weight: -11, minified: true }
    assets/vendor/jquery.ui/ui/scroll-parent-min.js: { weight: -11, minified: true }
    assets/vendor/jquery.ui/ui/tabbable-min.js: { weight: -11, minified: true }
    assets/vendor/jquery.ui/ui/unique-id-min.js: { weight: -11, minified: true }
    assets/vendor/jquery.ui/ui/version-min.js: { weight: -11, minified: true }
458
    assets/vendor/jquery.ui/ui/escape-selector-min.js: { weight: -11, minified: true }
459 460 461 462 463 464
    assets/vendor/jquery.ui/ui/focusable-min.js: { weight: -11, minified: true }
    assets/vendor/jquery.ui/ui/ie-min.js: { weight: -11, minified: true }
    assets/vendor/jquery.ui/ui/keycode-min.js: { weight: -11, minified: true }
    assets/vendor/jquery.ui/ui/plugin-min.js: { weight: -11, minified: true }
    assets/vendor/jquery.ui/ui/safe-active-element-min.js: { weight: -11, minified: true }
    assets/vendor/jquery.ui/ui/safe-blur-min.js: { weight: -11, minified: true }
465 466
  css:
    component:
467
      assets/vendor/jquery.ui/themes/base/core.css: {}
468
    theme:
469
      assets/vendor/jquery.ui/themes/base/theme.css: {}
470 471 472 473
  dependencies:
    - core/jquery

jquery.ui.accordion:
474 475
  version: *jquery_ui_version
  license: *jquery_ui_license
476
  js:
477
    assets/vendor/jquery.ui/ui/widgets/accordion-min.js: { minified: true }
478 479
  css:
    component:
480
      assets/vendor/jquery.ui/themes/base/accordion.css: {}
481 482 483
  dependencies:
    - core/jquery.ui
    - core/jquery.ui.widget
484
  deprecated: &jquery_ui_unused_deprecated The "%library_id%" asset library is deprecated in drupal:8.8.0 and is removed from drupal:9.0.0. See https://www.drupal.org/node/3067969
485 486

jquery.ui.autocomplete:
487 488
  version: *jquery_ui_version
  license: *jquery_ui_license
489
  js:
490
    assets/vendor/jquery.ui/ui/widgets/autocomplete-min.js: { minified: true }
491 492
  css:
    component:
493
      assets/vendor/jquery.ui/themes/base/autocomplete.css: {}
494 495 496 497 498 499 500
  dependencies:
    - core/jquery.ui
    - core/jquery.ui.widget
    - core/jquery.ui.position
    - core/jquery.ui.menu

jquery.ui.button:
501 502
  version: *jquery_ui_version
  license: *jquery_ui_license
503
  js:
504
    assets/vendor/jquery.ui/ui/widgets/button-min.js: { minified: true }
505 506
  css:
    component:
507
      assets/vendor/jquery.ui/themes/base/button.css: {}
508 509 510
  dependencies:
    - core/jquery.ui
    - core/jquery.ui.widget
511 512
    - core/jquery.ui.checkboxradio
    - core/jquery.ui.controlgroup
513

514 515 516 517
jquery.ui.checkboxradio:
  version: *jquery_ui_version
  license: *jquery_ui_license
  js:
518
    assets/vendor/jquery.ui/ui/form-reset-mixin-min.js: { minified: true }
519 520 521 522
    assets/vendor/jquery.ui/ui/widgets/checkboxradio-min.js: { minified: true }
  css:
    component:
      assets/vendor/jquery.ui/themes/base/checkboxradio.css: {}
523
      assets/vendor/jquery.ui/themes/base/button.css: {}
524 525 526
  dependencies:
    - core/jquery.ui
    - core/jquery.ui.widget
527
  deprecated: *jquery_ui_unused_deprecated
528 529 530 531 532 533 534 535 536 537 538 539

jquery.ui.controlgroup:
  version: *jquery_ui_version
  license: *jquery_ui_license
  js:
    assets/vendor/jquery.ui/ui/widgets/controlgroup-min.js: { minified: true }
  css:
    component:
      assets/vendor/jquery.ui/themes/base/controlgroup.css: {}
  dependencies:
    - core/jquery.ui
    - core/jquery.ui.widget
540
  deprecated: *jquery_ui_unused_deprecated
541

542
jquery.ui.datepicker:
543 544
  version: *jquery_ui_version
  license: *jquery_ui_license
545
  js:
546
    assets/vendor/jquery.ui/ui/widgets/datepicker-min.js: { minified: true }
547 548
  css:
    component:
549
      assets/vendor/jquery.ui/themes/base/datepicker.css: {}
550 551 552 553
  dependencies:
    - core/jquery.ui

jquery.ui.dialog:
554 555
  version: *jquery_ui_version
  license: *jquery_ui_license
556
  js:
557
    assets/vendor/jquery.ui/ui/widgets/dialog-min.js: { minified: true }
558 559
  css:
    component:
560
      assets/vendor/jquery.ui/themes/base/dialog.css: {}
561 562 563 564 565 566 567 568 569 570
  dependencies:
    - core/jquery.ui
    - core/jquery.ui.widget
    - core/jquery.ui.button
    - core/jquery.ui.draggable
    - core/jquery.ui.mouse
    - core/jquery.ui.position
    - core/jquery.ui.resizable

jquery.ui.draggable:
571 572
  version: *jquery_ui_version
  license: *jquery_ui_license
573
  js:
574
    assets/vendor/jquery.ui/ui/widgets/draggable-min.js: { minified: true }
575 576 577 578 579 580
  dependencies:
    - core/jquery.ui
    - core/jquery.ui.mouse
    - core/jquery.ui.widget

jquery.ui.droppable:
581 582
  version: *jquery_ui_version
  license: *jquery_ui_license
583
  js:
584
    assets/vendor/jquery.ui/ui/widgets/droppable-min.js: { minified: true }
585 586 587 588 589
  dependencies:
    - core/jquery.ui
    - core/jquery.ui.widget
    - core/jquery.ui.mouse
    - core/jquery.ui.draggable
590
  deprecated: *jquery_ui_unused_deprecated
591 592

jquery.ui.effects.core:
593 594
  version: *jquery_ui_version
  license: *jquery_ui_license
595
  js:
596
    assets/vendor/jquery.ui/ui/effect-min.js: { weight: -9, minified: true }
597
  deprecated: *jquery_ui_unused_deprecated
598 599

jquery.ui.effects.blind:
600 601
  version: *jquery_ui_version
  license: *jquery_ui_license
602
  js:
603
    assets/vendor/jquery.ui/ui/effects/effect-blind-min.js: { minified: true }
604 605
  dependencies:
    - core/jquery.ui.effects.core
606
  deprecated: *jquery_ui_unused_deprecated
607 608

jquery.ui.effects.bounce:
609 610
  version: *jquery_ui_version
  license: *jquery_ui_license
611
  js:
612
    assets/vendor/jquery.ui/ui/effects/effect-bounce-min.js: { minified: true }
613 614
  dependencies:
    - core/jquery.ui.effects.core
615
  deprecated: *jquery_ui_unused_deprecated
616 617

jquery.ui.effects.clip:
618 619
  version: *jquery_ui_version
  license: *jquery_ui_license
620
  js:
621
    assets/vendor/jquery.ui/ui/effects/effect-clip-min.js: { minified: true }
622 623
  dependencies:
    - core/jquery.ui.effects.core
624
  deprecated: *jquery_ui_unused_deprecated
625 626

jquery.ui.effects.drop:
627 628
  version: *jquery_ui_version
  license: *jquery_ui_license
629
  js:
630
    assets/vendor/jquery.ui/ui/effects/effect-drop-min.js: { minified: true }
631 632
  dependencies:
    - core/jquery.ui.effects.core
633
  deprecated: *jquery_ui_unused_deprecated
634 635

jquery.ui.effects.explode:
636 637
  version: *jquery_ui_version
  license: *jquery_ui_license
638
  js:
639
    assets/vendor/jquery.ui/ui/effects/effect-explode-min.js: { minified: true }
640 641
  dependencies:
    - core/jquery.ui.effects.core
642
  deprecated: *jquery_ui_unused_deprecated
643 644

jquery.ui.effects.fade:
645 646
  version: *jquery_ui_version
  license: *jquery_ui_license
647
  js:
648
    assets/vendor/jquery.ui/ui/effects/effect-fade-min.js: { minified: true }
649 650
  dependencies:
    - core/jquery.ui.effects.core
651
  deprecated: *jquery_ui_unused_deprecated
652 653

jquery.ui.effects.fold:
654 655
  version: *jquery_ui_version
  license: *jquery_ui_license
656
  js:
657
    assets/vendor/jquery.ui/ui/effects/effect-fold-min.js: { minified: true }
658 659
  dependencies:
    - core/jquery.ui.effects.core
660
  deprecated: *jquery_ui_unused_deprecated
661 662

jquery.ui.effects.highlight:
663 664
  version: *jquery_ui_version
  license: *jquery_ui_license
665
  js:
666
    assets/vendor/jquery.ui/ui/effects/effect-highlight-min.js: { minified: true }
667 668
  dependencies:
    - core/jquery.ui.effects.core
669
  deprecated: *jquery_ui_unused_deprecated
670 671 672 673 674

jquery.ui.effects.puff:
  version: *jquery_ui_version
  license: *jquery_ui_license
  js:
675
    assets/vendor/jquery.ui/ui/effects/effect-puff-min.js: { minified: true }
676 677
  dependencies:
    - core/jquery.ui.effects.core
678
    - core/jquery.ui.effects.scale
679
  deprecated: *jquery_ui_unused_deprecated
680 681

jquery.ui.effects.pulsate:
682 683
  version: *jquery_ui_version
  license: *jquery_ui_license
684
  js:
685
    assets/vendor/jquery.ui/ui/effects/effect-pulsate-min.js: { minified: true }
686 687
  dependencies:
    - core/jquery.ui.effects.core
688
  deprecated: *jquery_ui_unused_deprecated
689 690

jquery.ui.effects.scale:
691 692
  version: *jquery_ui_version
  license: *jquery_ui_license
693
  js:
694
    assets/vendor/jquery.ui/ui/effects/effect-scale-min.js: { minified: true }
695 696
  dependencies:
    - core/jquery.ui.effects.core
697
    - core/jquery.ui.effects.size
698
  deprecated: *jquery_ui_unused_deprecated
699 700

jquery.ui.effects.shake:
701 702
  version: *jquery_ui_version
  license: *jquery_ui_license
703
  js:
704
    assets/vendor/jquery.ui/ui/effects/effect-shake-min.js: { minified: true }
705 706
  dependencies:
    - core/jquery.ui.effects.core
707
  deprecated: *jquery_ui_unused_deprecated
708 709 710 711 712

jquery.ui.effects.size:
  version: *jquery_ui_version
  license: *jquery_ui_license
  js:
713
    assets/vendor/jquery.ui/ui/effects/effect-size-min.js: { minified: true }
714 715
  dependencies:
    - core/jquery.ui.effects.core
716
  deprecated: *jquery_ui_unused_deprecated
717 718

jquery.ui.effects.slide:
719 720
  version: *jquery_ui_version
  license: *jquery_ui_license
721
  js:
722
    assets/vendor/jquery.ui/ui/effects/effect-slide-min.js: { minified: true }
723 724
  dependencies:
    - core/jquery.ui.effects.core
725
  deprecated: *jquery_ui_unused_deprecated
726 727

jquery.ui.effects.transfer:
728 729
  version: *jquery_ui_version
  license: *jquery_ui_license
730
  js:
731
    assets/vendor/jquery.ui/ui/effects/effect-transfer-min.js: { minified: true }
732 733
  dependencies:
    - core/jquery.ui.effects.core
734
  deprecated: *jquery_ui_unused_deprecated
735 736

jquery.ui.menu:
737 738
  version: *jquery_ui_version
  license: *jquery_ui_license
739
  js:
740
    assets/vendor/jquery.ui/ui/widgets/menu-min.js: { minified: true }
741 742
  css:
    component:
743
      assets/vendor/jquery.ui/themes/base/menu.css: {}
744 745
  dependencies:
    - core/jquery.ui
746
    - core/jquery.ui.position
747 748 749
    - core/jquery.ui.widget

jquery.ui.mouse:
750 751
  version: *jquery_ui_version
  license: *jquery_ui_license
752
  js:
753
    assets/vendor/jquery.ui/ui/ie-min.js: { minified: true }
754
    assets/vendor/jquery.ui/ui/widgets/mouse-min.js: { minified: true }
755 756 757 758
  dependencies:
    - core/jquery.ui.widget

jquery.ui.position:
759 760
  version: *jquery_ui_version
  license: *jquery_ui_license
761
  js:
762
    assets/vendor/jquery.ui/ui/position-min.js: { minified: true }
763 764
  dependencies:
    - core/jquery.ui
765 766

jquery.ui.progressbar:
767 768
  version: *jquery_ui_version
  license: *jquery_ui_license
769
  js:
770
    assets/vendor/jquery.ui/ui/widgets/progressbar-min.js: { minified: true }
771 772
  css:
    component:
773
      assets/vendor/jquery.ui/themes/base/progressbar.css: {}
774 775 776
  dependencies:
    - core/jquery.ui
    - core/jquery.ui.widget
777
  deprecated: *jquery_ui_unused_deprecated
778 779

jquery.ui.resizable:
780 781
  version: *jquery_ui_version
  license: *jquery_ui_license
782
  js:
783
    assets/vendor/jquery.ui/ui/widgets/resizable-min.js: { minified: true }
784 785
  css:
    component:
786
      assets/vendor/jquery.ui/themes/base/resizable.css: {}
787 788 789 790 791 792
  dependencies:
    - core/jquery.ui
    - core/jquery.ui.widget
    - core/jquery.ui.mouse

jquery.ui.selectable:
793 794
  version: *jquery_ui_version
  license: *jquery_ui_license
795
  js:
796
    assets/vendor/jquery.ui/ui/widgets/selectable-min.js: { minified: true }
797 798
  css:
    component:
799
      assets/vendor/jquery.ui/themes/base/selectable.css: {}
800 801 802 803
  dependencies:
    - core/jquery.ui
    - core/jquery.ui.mouse
    - core/jquery.ui.widget
804
  deprecated: *jquery_ui_unused_deprecated
805

806 807 808 809
jquery.ui.selectmenu:
  version: *jquery_ui_version
  license: *jquery_ui_license
  js:
810
    assets/vendor/jquery.ui/ui/form-reset-mixin-min.js: { minified: true }
811
    assets/vendor/jquery.ui/ui/widgets/selectmenu-min.js: { minified: true }
812 813 814
  css:
    component:
      assets/vendor/jquery.ui/themes/base/selectmenu.css: {}
815
      assets/vendor/jquery.ui/themes/base/button.css: {}
816 817 818 819 820
  dependencies:
    - core/jquery.ui
    - core/jquery.ui.menu
    - core/jquery.ui.position
    - core/jquery.ui.widget
821
  deprecated: *jquery_ui_unused_deprecated
822

823
jquery.ui.slider:
824 825
  version: *jquery_ui_version
  license: *jquery_ui_license
826
  js:
827
    assets/vendor/jquery.ui/ui/widgets/slider-min.js: { minified: true }
828 829
  css:
    component:
830
      assets/vendor/jquery.ui/themes/base/slider.css: {}
831 832 833 834
  dependencies:
    - core/jquery.ui
    - core/jquery.ui.mouse
    - core/jquery.ui.widget
835
  deprecated: *jquery_ui_unused_deprecated
836 837

jquery.ui.sortable:
838 839
  version: *jquery_ui_version
  license: *jquery_ui_license
840
  js:
841
    assets/vendor/jquery.ui/ui/widgets/sortable-min.js: { minified: true }
842 843 844 845 846 847
  dependencies:
    - core/jquery.ui
    - core/jquery.ui.mouse
    - core/jquery.ui.widget

jquery.ui.spinner:
848 849
  version: *jquery_ui_version
  license: *jquery_ui_license
850
  js:
851
    assets/vendor/jquery.ui/ui/widgets/spinner-min.js: { minified: true }
852 853
  css:
    component:
854
      assets/vendor/jquery.ui/themes/base/spinner.css: {}
855 856 857 858
  dependencies:
    - core/jquery.ui
    - core/jquery.ui.widget
    - core/jquery.ui.button
859
  deprecated: *jquery_ui_unused_deprecated
860 861

jquery.ui.tabs:
862 863
  version: *jquery_ui_version
  license: *jquery_ui_license
864
  js:
865
    assets/vendor/jquery.ui/ui/widgets/tabs-min.js: { minified: true }
866 867
  css:
    component:
868
      assets/vendor/jquery.ui/themes/base/tabs.css: {}
869 870 871
  dependencies:
    - core/jquery.ui
    - core/jquery.ui.widget
872
  deprecated: *jquery_ui_unused_deprecated
873 874

jquery.ui.tooltip:
875 876
  version: *jquery_ui_version
  license: *jquery_ui_license
877
  js:
878
    assets/vendor/jquery.ui/ui/widgets/tooltip-min.js: { minified: true }
879 880
  css:
    component:
881
      assets/vendor/jquery.ui/themes/base/tooltip.css: {}
882 883 884 885
  dependencies:
    - core/jquery.ui
    - core/jquery.ui.widget
    - core/jquery.ui.position
886
  deprecated: *jquery_ui_unused_deprecated
887 888 889

jquery.ui.touch-punch:
  remote: https://github.com/furf/jquery-ui-touch-punch
890
  version: "0.2.3"
891 892 893 894
  license:
    name: GNU-GPL-2.0-or-later
    url: https://github.com/furf/jquery-ui-touch-punch
    gpl-compatible: true
895 896 897 898
  js:
    assets/vendor/jquery-ui-touch-punch/jquery.ui.touch-punch.js: {}
  dependencies:
    - core/jquery.ui
899 900
    - core/jquery.ui.mouse
    - core/jquery.ui.widget
901 902

jquery.ui.widget:
903 904
  version: *jquery_ui_version
  license: *jquery_ui_license
905
  js:
906
    assets/vendor/jquery.ui/ui/widget-min.js: { weight: -10, minified: true }
907 908 909 910 911
  dependencies:
    - core/jquery.ui

matchmedia:
  remote: https://github.com/paulirish/matchMedia.js
912 913
  version: &matchmedia_version 0.2.0
  license: &matchmedia_license
914
    name: MIT
915
    url: https://github.com/paulirish/matchMedia.js/blob/0.2.0/LICENSE.txt
916
    gpl-compatible: true
917
  js:
918
    assets/vendor/matchMedia/matchMedia.min.js: { minified: true }
919
  deprecated: &matchmedia_deprecated The "%library_id%" asset library is deprecated in drupal:8.8.0 and is removed from drupal:9.0.0. See https://www.drupal.org/node/3086653
920 921 922 923 924 925

matchmedia.addListener:
  version: *matchmedia_version
  license: *matchmedia_license
  js:
    assets/vendor/matchMedia/matchMedia.addListener.min.js: { minified: true }
926
  dependencies:
927
    - core/matchmedia
928
  deprecated: *matchmedia_deprecated
929 930

modernizr:
931 932
  # Block the page from being loaded until Modernizr is initialized.
  header: true
933
  remote: https://github.com/Modernizr/Modernizr
934 935 936 937
  license:
    name: MIT
    url: http://modernizr.com/license/
    gpl-compatible: true
938
  version: "v3.3.1"
939
  js:
940
    assets/vendor/modernizr/modernizr.min.js: { preprocess: 0, weight: -21, minified: true }
941 942 943

normalize:
  remote: https://github.com/necolas/normalize.css
944
  version: "3.0.3"
945 946 947 948
  license:
    name: MIT
    url: https://github.com/necolas/normalize.css/blob/master/LICENSE.md
    gpl-compatible: true
949 950
  css:
    base:
951
      assets/vendor/normalize-css/normalize.css: { weight: -20 }
952
      misc/normalize-fixes.css: { weight: -19 }
953

954 955
picturefill:
  remote: https://github.com/scottjehl/picturefill
956
  version: "3.0.1"
957 958
  license:
    name: MIT
959
    url: https://github.com/scottjehl/picturefill/blob/3.0.1/LICENSE
960
    gpl-compatible: true
961
  js:
962
    assets/vendor/picturefill/picturefill.min.js: { weight: -10, minified: true }
963 964 965
  dependencies:
    - core/matchmedia

966 967 968 969 970 971 972 973 974
popperjs:
  version: "1.15.0"
  license:
    name: MIT
    url: https://github.com/FezVrasta/popper.js/blob/v1.15.0/LICENSE.md
    gpl-compatible: true
  js:
    assets/vendor/popperjs/popper.min.js: { minified: true }

975 976
underscore:
  remote: https://github.com/jashkenas/underscore
977
  version: "1.8.3"
978 979
  license:
    name: MIT
980
    url: https://github.com/jashkenas/underscore/blob/1.8.3/LICENSE
981
    gpl-compatible: true
982
  js:
983
    assets/vendor/underscore/underscore-min.js: { weight: -20, minified: true }
984 985 986 987 988 989 990 991 992 993 994 995 996 997 998 999 1000 1001 1002 1003 1004

drupal.dialog.off_canvas:
  version: VERSION
  js:
    misc/dialog/off-canvas.js: {}
  css:
    base:
      misc/dialog/off-canvas.reset.css: {}
      misc/dialog/off-canvas.base.css: {}
      misc/dialog/off-canvas.css: {}
      # Add group setting to make sure this CSS load before any jQuery UI Dialog
      # CSS.
      misc/dialog/off-canvas.theme.css: { group: 200 }
    component:
      misc/dialog/off-canvas.motion.css: {}
      misc/dialog/off-canvas.button.css: {}
      misc/dialog/off-canvas.form.css: {}
      misc/dialog/off-canvas.table.css: {}
      misc/dialog/off-canvas.details.css: {}
      misc/dialog/off-canvas.tabledrag.css: {}
      misc/dialog/off-canvas.dropbutton.css: {}
1005
      misc/dialog/off-canvas.layout.css: {}
1006 1007 1008 1009 1010 1011 1012
  dependencies:
    - core/jquery
    - core/drupal
    - core/drupal.ajax
    - core/drupal.announce
    - core/drupal.dialog
    - core/drupal.dialog.ajax