core.libraries.yml 20.4 KB
Newer Older
1 2 3 4
# All libraries are defined in alphabetical order.

backbone:
  remote: https://github.com/jashkenas/backbone
5
  version: "1.2.3"
6 7
  license:
    name: MIT
8
    url: https://github.com/jashkenas/backbone/blob/1.2.3/LICENSE
9
    gpl-compatible: true
10
  js:
11
    assets/vendor/backbone/backbone-min.js: { weight: -19, minified: true }
12 13 14 15 16
  dependencies:
    - core/underscore

classList:
  remote: https://github.com/eligrey/classList.js
17
  version: "2014-12-13"
18 19
  license:
    name: Public Domain
20
    url: https://github.com/eligrey/classList.js/blob/2014-12-13/LICENSE.md
21
    gpl-compatible: true
22
  js:
23
    assets/vendor/classList/classList.min.js: { weight: -21, browsers: { IE: 'lte IE 9', '!IE': false }, minified: true }
24 25 26

ckeditor:
  remote: https://github.com/ckeditor/ckeditor-dev
27
  version: "4.5.7"
28 29
  license:
    name: GNU-GPL-2.0-or-later
30
    url: https://github.com/ckeditor/ckeditor-dev/blob/4.5.7/LICENSE.md
31
    gpl-compatible: true
32
  js:
33
    assets/vendor/ckeditor/ckeditor.js: { preprocess: false, minified: true }
34 35 36

domready:
  remote: https://github.com/ded/domready
37
  version: "1.0.8"
38 39
  license:
    name: MIT
40
    url: https://github.com/ded/domready/blob/v1.0.8/LICENSE
41
    gpl-compatible: true
42
  js:
43
    assets/vendor/domready/ready.min.js: { weight: -21, minified: true }
44 45 46 47

drupal:
  version: VERSION
  js:
48
    misc/drupal.js: { weight: -18 }
49 50
  dependencies:
    - core/domready
51
    - core/drupalSettings
52 53 54

drupalSettings:
  version: VERSION
55 56 57 58
  js:
    # Need to specify a negative weight like drupal.js until
    # https://www.drupal.org/node/1945262 is resolved.
    misc/drupalSettingsLoader.js: { weight: -18 }
59 60 61 62 63 64 65 66 67 68
  drupalSettings:
    # These placeholder values will be set by system_js_settings_alter().
    path:
      baseUrl: null
      scriptPath: null
      pathPrefix: null
      currentPath: null
      currentPathIsAdmin: null
      isFront: null
      currentLanguage: null
69
    pluralDelimiter: null
70 71 72 73 74 75 76 77 78 79 80 81 82 83

drupal.active-link:
  version: VERSION
  js:
    misc/active-link.js: {}
  dependencies:
    - core/drupal
    - core/drupalSettings
    - core/classList

drupal.ajax:
  version: VERSION
  js:
    misc/ajax.js: {}
84 85 86 87 88 89
  drupalSettings:
    # These placeholder values will be set by system_js_settings_alter().
    ajaxPageState:
      libraries: null
      theme: null
      theme_token: null
90
    ajaxTrustedUrl: {}
91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108
  dependencies:
    - core/jquery
    - core/drupal
    - core/drupalSettings
    - core/drupal.progress
    - core/jquery.once

drupal.announce:
  version: VERSION
  js:
    misc/announce.js: {}
  dependencies:
    - core/drupal
    - core/drupal.debounce

drupal.autocomplete:
  version: VERSION
  js:
109
    misc/autocomplete.js: { weight: -1 }
110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131
  dependencies:
    - core/jquery
    - core/drupal
    - core/drupalSettings
    - core/drupal.ajax
    - core/jquery.ui.autocomplete

drupal.batch:
  version: VERSION
  js:
    misc/batch.js: { cache: false }
  dependencies:
    - core/jquery
    - core/drupal
    - core/drupalSettings
    - core/drupal.ajax
    - core/drupal.progress
    - core/jquery.once

drupal.collapse:
  version: VERSION
  js:
132
    misc/details-aria.js: {}
133 134 135 136 137 138 139 140
    misc/collapse.js: {}
  dependencies:
    - core/jquery
    - core/modernizr
    - core/drupal
    - core/drupal.form
    - core/jquery.once

141 142 143 144 145 146 147
drupal.date:
  version: VERSION
  js:
    misc/date.js: {}
  dependencies:
    - core/drupal
    - core/modernizr
148
    - core/jquery.once
149 150
    - core/jquery.ui.datepicker

151 152 153 154 155 156 157 158 159 160 161
drupal.debounce:
  version: VERSION
  js:
    misc/debounce.js: {}
  dependencies:
    # @todo Remove Drupal dependency.
    - core/drupal

drupal.dialog:
  version: VERSION
  js:
162 163 164
    misc/dialog/dialog.js: {}
    misc/dialog/dialog.position.js: {}
    misc/dialog/dialog.jquery-ui.js: {}
165 166 167 168 169 170 171 172 173 174 175
  dependencies:
    - core/jquery
    - core/drupal
    - core/drupalSettings
    - core/drupal.debounce
    - core/drupal.displace
    - core/jquery.ui.dialog

drupal.dialog.ajax:
  version: VERSION
  js:
176
    misc/dialog/dialog.ajax.js: {}
177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225
  dependencies:
    - core/jquery
    - core/drupal
    - core/drupalSettings
    - core/drupal.ajax
    - core/drupal.dialog

drupal.displace:
  version: VERSION
  js:
    misc/displace.js: {}
  dependencies:
    - core/jquery
    - core/drupal
    - core/drupal.debounce

drupal.dropbutton:
  version: VERSION
  js:
    misc/dropbutton/dropbutton.js: {}
  css:
    component:
      misc/dropbutton/dropbutton.css: {}
  dependencies:
    - core/jquery
    - core/drupal
    - core/drupalSettings
    - core/jquery.once

drupal.form:
  version: VERSION
  js:
    misc/form.js: {}
  dependencies:
    - core/jquery
    - core/drupal
    - core/drupal.debounce
    - core/jquery.cookie
    - core/jquery.once

drupal.machine-name:
  version: VERSION
  js:
    misc/machine-name.js: {}
  dependencies:
    - core/jquery
    - core/jquery.once
    - core/drupal
    - core/drupalSettings
226
    - core/drupal.form
227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259

drupal.progress:
  version: VERSION
  js:
    misc/progress.js: {}
  dependencies:
    - core/drupal
    - core/jquery
    - core/drupalSettings

drupal.states:
  version: VERSION
  js:
    misc/states.js: {}
  dependencies:
    - core/jquery
    - core/drupal
    - core/drupalSettings
    - core/jquery.once

drupal.tabbingmanager:
  version: VERSION
  js:
    misc/tabbingmanager.js: {}
  dependencies:
    - core/jquery
    # Supplies the ':tabbable' pseudo selector.
    - core/jquery.ui
    - core/drupal

drupal.tabledrag:
  version: VERSION
  js:
260
    misc/tabledrag.js: { weight: -1 }
261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294
  dependencies:
    - core/jquery
    - core/drupal
    - core/drupalSettings
    - core/jquery.once
    - core/jquery.cookie

drupal.tableheader:
  version: VERSION
  js:
    misc/tableheader.js: {}
  dependencies:
    - core/jquery
    - core/drupal
    - core/drupalSettings
    - core/jquery.once
    - core/drupal.displace

drupal.tableresponsive:
  version: VERSION
  js:
    misc/tableresponsive.js: {}
  dependencies:
    - core/jquery
    - core/drupal
    - core/jquery.once

drupal.tableselect:
  version: VERSION
  js:
    misc/tableselect.js: {}
  dependencies:
    - core/drupal
    - core/jquery
295
    - core/jquery.once
296 297 298 299 300 301 302

drupal.timezone:
  version: VERSION
  js:
    misc/timezone.js: {}
  dependencies:
    - core/jquery
303
    - core/jquery.once
304 305 306 307 308 309
    - core/drupal

drupal.vertical-tabs:
  version: VERSION
  js:
    # Load before core/drupal.collapse.
310
    misc/vertical-tabs.js: { weight: -1 }
311 312 313 314 315
  css:
    component:
      misc/vertical-tabs.css: {}
  dependencies:
    - core/jquery
316
    - core/jquery.once
317 318 319
    - core/drupal
    - core/drupalSettings
    - core/drupal.form
320
    - core/matchmedia
321 322

html5shiv:
323 324
  # Block the page from being loaded until html5shiv is initialized.
  header: true
325
  remote: https://github.com/aFarkas/html5shiv
326
  version: "3.7.3"
327 328 329 330
  license:
    name: GNU-GPL-2.0-or-later
    url: http://www.gnu.org/licenses/gpl-2.0.html
    gpl-compatible: true
331
  js:
332
    assets/vendor/html5shiv/html5shiv.min.js: { weight: -22, browsers: { IE: 'lte IE 8', '!IE': false }, minified: true }
333 334 335

jquery:
  remote: https://github.com/jquery/jquery
336
  version: "2.1.4"
337 338
  license:
    name: MIT
339
    url: https://github.com/jquery/jquery/blob/2.1.4/MIT-LICENSE.txt
340
    gpl-compatible: true
341
  js:
342
    assets/vendor/jquery/jquery.min.js: { minified: true, weight: -20 }
343 344 345

jquery.cookie:
  remote: https://github.com/carhartl/jquery-cookie
346
  version: "v1.4.1"
347 348
  license:
    name: MIT
349
    url: https://github.com/carhartl/jquery-cookie/blob/v1.4.1/MIT-LICENSE.txt
350
    gpl-compatible: true
351
  js:
352
    assets/vendor/jquery.cookie/jquery.cookie.min.js: { minified: true }
353 354 355 356 357 358
  dependencies:
    - core/jquery

jquery.farbtastic:
  remote: https://github.com/mattfarina/farbtastic
  # @todo Ping @robloach or @mattfarina to retroactively create this release.
359
  version: "1.2"
360 361 362 363
  license:
    name: GNU-GPL-2.0-or-later
    url: https://github.com/mattfarina/farbtastic/blob/master/LICENSE.txt
    gpl-compatible: true
364
  js:
365
    assets/vendor/farbtastic/farbtastic.js: { minified: true }
366 367 368 369 370 371 372 373
  css:
    component:
      assets/vendor/farbtastic/farbtastic.css: {}
  dependencies:
    - core/jquery

jquery.form:
  remote: https://github.com/malsup/form
374
  version: "3.51"
375 376 377 378
  license:
    name: GNU-GPL-2.0-or-later
    url: http://malsup.github.com/gpl-license-v2.txt
    gpl-compatible: true
379
  js:
380
    assets/vendor/jquery-form/jquery.form.min.js: { minified: true }
381 382 383
  dependencies:
    - core/jquery

384 385
jquery.joyride:
  remote: https://github.com/zurb/joyride
386
  version: "v2.1.0"
387 388
  license:
    name: MIT
389
    url: https://github.com/zurb/joyride/blob/v2.1.0/README.markdown
390
    gpl-compatible: true
391
  js:
392
    assets/vendor/jquery-joyride/jquery.joyride-2.1.min.js: { minified: true }
393 394 395 396
  dependencies:
    - core/jquery
    - core/jquery.cookie

397 398
jquery.once:
  remote: https://github.com/RobLoach/jquery-once
399
  version: "2.1.1"
400 401
  license:
    name: GNU-GPL-2.0-or-later
402
    url: https://github.com/RobLoach/jquery-once/blob/2.1.1/LICENSE.md
403
    gpl-compatible: true
404
  js:
405
    assets/vendor/jquery-once/jquery.once.min.js: { weight: -19, minified: true }
406 407 408 409 410
  dependencies:
    - core/jquery

jquery.ui:
  remote: https://github.com/jquery/jquery-ui
411
  version: &jquery_ui_version 1.11.4
412
  license: &jquery_ui_license
413 414
    name: Public Domain
    url: https://github.com/jquery/jquery-ui/blob/1.11.4/LICENSE.txt
415
    gpl-compatible: true
416
  js:
417
    assets/vendor/jquery.ui/ui/core-min.js: { weight: -11, minified: true }
418 419
  css:
    component:
420
      assets/vendor/jquery.ui/themes/base/core.css: {}
421
    theme:
422
      assets/vendor/jquery.ui/themes/base/theme.css: {}
423 424 425 426
  dependencies:
    - core/jquery

jquery.ui.accordion:
427 428
  version: *jquery_ui_version
  license: *jquery_ui_license
429
  js:
430
    assets/vendor/jquery.ui/ui/accordion-min.js: { minified: true }
431 432
  css:
    component:
433
      assets/vendor/jquery.ui/themes/base/accordion.css: {}
434 435 436 437 438
  dependencies:
    - core/jquery.ui
    - core/jquery.ui.widget

jquery.ui.autocomplete:
439 440
  version: *jquery_ui_version
  license: *jquery_ui_license
441
  js:
442
    assets/vendor/jquery.ui/ui/autocomplete-min.js: { minified: true }
443 444
  css:
    component:
445
      assets/vendor/jquery.ui/themes/base/autocomplete.css: {}
446 447 448 449 450 451 452
  dependencies:
    - core/jquery.ui
    - core/jquery.ui.widget
    - core/jquery.ui.position
    - core/jquery.ui.menu

jquery.ui.button:
453 454
  version: *jquery_ui_version
  license: *jquery_ui_license
455
  js:
456
    assets/vendor/jquery.ui/ui/button-min.js: { minified: true }
457 458
  css:
    component:
459
      assets/vendor/jquery.ui/themes/base/button.css: {}
460 461 462 463 464
  dependencies:
    - core/jquery.ui
    - core/jquery.ui.widget

jquery.ui.datepicker:
465 466
  version: *jquery_ui_version
  license: *jquery_ui_license
467
  js:
468
    assets/vendor/jquery.ui/ui/datepicker-min.js: { minified: true }
469 470
  css:
    component:
471
      assets/vendor/jquery.ui/themes/base/datepicker.css: {}
472 473 474 475
  dependencies:
    - core/jquery.ui

jquery.ui.dialog:
476 477
  version: *jquery_ui_version
  license: *jquery_ui_license
478
  js:
479
    assets/vendor/jquery.ui/ui/dialog-min.js: { minified: true }
480 481
  css:
    component:
482
      assets/vendor/jquery.ui/themes/base/dialog.css: {}
483 484 485 486 487 488 489 490 491 492
  dependencies:
    - core/jquery.ui
    - core/jquery.ui.widget
    - core/jquery.ui.button
    - core/jquery.ui.draggable
    - core/jquery.ui.mouse
    - core/jquery.ui.position
    - core/jquery.ui.resizable

jquery.ui.draggable:
493 494
  version: *jquery_ui_version
  license: *jquery_ui_license
495
  js:
496
    assets/vendor/jquery.ui/ui/draggable-min.js: { minified: true }
497 498 499 500 501 502
  dependencies:
    - core/jquery.ui
    - core/jquery.ui.mouse
    - core/jquery.ui.widget

jquery.ui.droppable:
503 504
  version: *jquery_ui_version
  license: *jquery_ui_license
505
  js:
506
    assets/vendor/jquery.ui/ui/droppable-min.js: { minified: true }
507 508 509 510 511 512 513
  dependencies:
    - core/jquery.ui
    - core/jquery.ui.widget
    - core/jquery.ui.mouse
    - core/jquery.ui.draggable

jquery.ui.effects.core:
514 515
  version: *jquery_ui_version
  license: *jquery_ui_license
516
  js:
517
    assets/vendor/jquery.ui/ui/effect-min.js: { weight: -9, minified: true }
518 519

jquery.ui.effects.blind:
520 521
  version: *jquery_ui_version
  license: *jquery_ui_license
522
  js:
523
    assets/vendor/jquery.ui/ui/effect-blind-min.js: { minified: true }
524 525 526 527
  dependencies:
    - core/jquery.ui.effects.core

jquery.ui.effects.bounce:
528 529
  version: *jquery_ui_version
  license: *jquery_ui_license
530
  js:
531
    assets/vendor/jquery.ui/ui/effect-bounce-min.js: { minified: true }
532 533 534 535
  dependencies:
    - core/jquery.ui.effects.core

jquery.ui.effects.clip:
536 537
  version: *jquery_ui_version
  license: *jquery_ui_license
538
  js:
539
    assets/vendor/jquery.ui/ui/effect-clip-min.js: { minified: true }
540 541 542 543
  dependencies:
    - core/jquery.ui.effects.core

jquery.ui.effects.drop:
544 545
  version: *jquery_ui_version
  license: *jquery_ui_license
546
  js:
547
    assets/vendor/jquery.ui/ui/effect-drop-min.js: { minified: true }
548 549 550 551
  dependencies:
    - core/jquery.ui.effects.core

jquery.ui.effects.explode:
552 553
  version: *jquery_ui_version
  license: *jquery_ui_license
554
  js:
555
    assets/vendor/jquery.ui/ui/effect-explode-min.js: { minified: true }
556 557 558 559
  dependencies:
    - core/jquery.ui.effects.core

jquery.ui.effects.fade:
560 561
  version: *jquery_ui_version
  license: *jquery_ui_license
562
  js:
563
    assets/vendor/jquery.ui/ui/effect-fade-min.js: { minified: true }
564 565 566 567
  dependencies:
    - core/jquery.ui.effects.core

jquery.ui.effects.fold:
568 569
  version: *jquery_ui_version
  license: *jquery_ui_license
570
  js:
571
    assets/vendor/jquery.ui/ui/effect-fold-min.js: { minified: true }
572 573 574 575
  dependencies:
    - core/jquery.ui.effects.core

jquery.ui.effects.highlight:
576 577
  version: *jquery_ui_version
  license: *jquery_ui_license
578
  js:
579 580 581 582 583 584 585 586 587
    assets/vendor/jquery.ui/ui/effect-highlight-min.js: { minified: true }
  dependencies:
    - core/jquery.ui.effects.core

jquery.ui.effects.puff:
  version: *jquery_ui_version
  license: *jquery_ui_license
  js:
    assets/vendor/jquery.ui/ui/effect-puff-min.js: { minified: true }
588 589 590 591
  dependencies:
    - core/jquery.ui.effects.core

jquery.ui.effects.pulsate:
592 593
  version: *jquery_ui_version
  license: *jquery_ui_license
594
  js:
595
    assets/vendor/jquery.ui/ui/effect-pulsate-min.js: { minified: true }
596 597 598 599
  dependencies:
    - core/jquery.ui.effects.core

jquery.ui.effects.scale:
600 601
  version: *jquery_ui_version
  license: *jquery_ui_license
602
  js:
603
    assets/vendor/jquery.ui/ui/effect-scale-min.js: { minified: true }
604 605 606 607
  dependencies:
    - core/jquery.ui.effects.core

jquery.ui.effects.shake:
608 609
  version: *jquery_ui_version
  license: *jquery_ui_license
610
  js:
611 612 613 614 615 616 617 618 619
    assets/vendor/jquery.ui/ui/effect-shake-min.js: { minified: true }
  dependencies:
    - core/jquery.ui.effects.core

jquery.ui.effects.size:
  version: *jquery_ui_version
  license: *jquery_ui_license
  js:
    assets/vendor/jquery.ui/ui/effect-size-min.js: { minified: true }
620 621 622 623
  dependencies:
    - core/jquery.ui.effects.core

jquery.ui.effects.slide:
624 625
  version: *jquery_ui_version
  license: *jquery_ui_license
626
  js:
627
    assets/vendor/jquery.ui/ui/effect-slide-min.js: { minified: true }
628 629 630 631
  dependencies:
    - core/jquery.ui.effects.core

jquery.ui.effects.transfer:
632 633
  version: *jquery_ui_version
  license: *jquery_ui_license
634
  js:
635
    assets/vendor/jquery.ui/ui/effect-transfer-min.js: { minified: true }
636 637 638 639
  dependencies:
    - core/jquery.ui.effects.core

jquery.ui.menu:
640 641
  version: *jquery_ui_version
  license: *jquery_ui_license
642
  js:
643
    assets/vendor/jquery.ui/ui/menu-min.js: { minified: true }
644 645
  css:
    component:
646
      assets/vendor/jquery.ui/themes/base/menu.css: {}
647 648 649 650 651
  dependencies:
    - core/jquery.ui
    - core/jquery.ui.widget

jquery.ui.mouse:
652 653
  version: *jquery_ui_version
  license: *jquery_ui_license
654
  js:
655
    assets/vendor/jquery.ui/ui/mouse-min.js: { minified: true }
656 657 658 659
  dependencies:
    - core/jquery.ui.widget

jquery.ui.position:
660 661
  version: *jquery_ui_version
  license: *jquery_ui_license
662
  js:
663
    assets/vendor/jquery.ui/ui/position-min.js: { minified: true }
664 665

jquery.ui.progressbar:
666 667
  version: *jquery_ui_version
  license: *jquery_ui_license
668
  js:
669
    assets/vendor/jquery.ui/ui/progressbar-min.js: { minified: true }
670 671
  css:
    component:
672
      assets/vendor/jquery.ui/themes/base/progressbar.css: {}
673 674 675 676 677
  dependencies:
    - core/jquery.ui
    - core/jquery.ui.widget

jquery.ui.resizable:
678 679
  version: *jquery_ui_version
  license: *jquery_ui_license
680
  js:
681
    assets/vendor/jquery.ui/ui/resizable-min.js: { minified: true }
682 683
  css:
    component:
684
      assets/vendor/jquery.ui/themes/base/resizable.css: {}
685 686 687 688 689 690
  dependencies:
    - core/jquery.ui
    - core/jquery.ui.widget
    - core/jquery.ui.mouse

jquery.ui.selectable:
691 692
  version: *jquery_ui_version
  license: *jquery_ui_license
693
  js:
694
    assets/vendor/jquery.ui/ui/selectable-min.js: { minified: true }
695 696
  css:
    component:
697
      assets/vendor/jquery.ui/themes/base/selectable.css: {}
698 699 700 701 702
  dependencies:
    - core/jquery.ui
    - core/jquery.ui.mouse
    - core/jquery.ui.widget

703 704 705 706 707 708 709 710 711 712 713 714 715 716
jquery.ui.selectmenu:
  version: *jquery_ui_version
  license: *jquery_ui_license
  js:
    assets/vendor/jquery.ui/ui/selectmenu-min.js: { minified: true }
  css:
    component:
      assets/vendor/jquery.ui/themes/base/selectmenu.css: {}
  dependencies:
    - core/jquery.ui
    - core/jquery.ui.menu
    - core/jquery.ui.position
    - core/jquery.ui.widget

717
jquery.ui.slider:
718 719
  version: *jquery_ui_version
  license: *jquery_ui_license
720
  js:
721
    assets/vendor/jquery.ui/ui/slider-min.js: { minified: true }
722 723
  css:
    component:
724
      assets/vendor/jquery.ui/themes/base/slider.css: {}
725 726 727 728 729 730
  dependencies:
    - core/jquery.ui
    - core/jquery.ui.mouse
    - core/jquery.ui.widget

jquery.ui.sortable:
731 732
  version: *jquery_ui_version
  license: *jquery_ui_license
733
  js:
734
    assets/vendor/jquery.ui/ui/sortable-min.js: { minified: true }
735 736 737 738 739 740
  dependencies:
    - core/jquery.ui
    - core/jquery.ui.mouse
    - core/jquery.ui.widget

jquery.ui.spinner:
741 742
  version: *jquery_ui_version
  license: *jquery_ui_license
743
  js:
744
    assets/vendor/jquery.ui/ui/spinner-min.js: { minified: true }
745 746
  css:
    component:
747
      assets/vendor/jquery.ui/themes/base/spinner.css: {}
748 749 750 751 752 753
  dependencies:
    - core/jquery.ui
    - core/jquery.ui.widget
    - core/jquery.ui.button

jquery.ui.tabs:
754 755
  version: *jquery_ui_version
  license: *jquery_ui_license
756
  js:
757
    assets/vendor/jquery.ui/ui/tabs-min.js: { minified: true }
758 759
  css:
    component:
760
      assets/vendor/jquery.ui/themes/base/tabs.css: {}
761 762 763 764 765
  dependencies:
    - core/jquery.ui
    - core/jquery.ui.widget

jquery.ui.tooltip:
766 767
  version: *jquery_ui_version
  license: *jquery_ui_license
768
  js:
769
    assets/vendor/jquery.ui/ui/tooltip-min.js: { minified: true }
770 771
  css:
    component:
772
      assets/vendor/jquery.ui/themes/base/tooltip.css: {}
773 774 775 776 777 778 779
  dependencies:
    - core/jquery.ui
    - core/jquery.ui.widget
    - core/jquery.ui.position

jquery.ui.touch-punch:
  remote: https://github.com/furf/jquery-ui-touch-punch
780
  version: "0.2.3"
781 782 783 784
  license:
    name: GNU-GPL-2.0-or-later
    url: https://github.com/furf/jquery-ui-touch-punch
    gpl-compatible: true
785 786 787 788 789 790
  js:
    assets/vendor/jquery-ui-touch-punch/jquery.ui.touch-punch.js: {}
  dependencies:
    - core/jquery.ui

jquery.ui.widget:
791 792
  version: *jquery_ui_version
  license: *jquery_ui_license
793
  js:
794
    assets/vendor/jquery.ui/ui/widget-min.js: { weight: -10, minified: true }
795 796 797 798 799
  dependencies:
    - core/jquery.ui

matchmedia:
  remote: https://github.com/paulirish/matchMedia.js
800 801
  version: &matchmedia_version 0.2.0
  license: &matchmedia_license
802
    name: MIT
803
    url: https://github.com/paulirish/matchMedia.js/blob/0.2.0/LICENSE.txt
804
    gpl-compatible: true
805
  js:
806 807 808 809 810 811 812
    assets/vendor/matchMedia/matchMedia.min.js: { minified: true }

matchmedia.addListener:
  version: *matchmedia_version
  license: *matchmedia_license
  js:
    assets/vendor/matchMedia/matchMedia.addListener.min.js: { minified: true }
813
  dependencies:
814
    - core/matchmedia
815 816

modernizr:
817 818
  # Block the page from being loaded until Modernizr is initialized.
  header: true
819
  remote: https://github.com/Modernizr/Modernizr
820 821 822 823
  license:
    name: MIT
    url: http://modernizr.com/license/
    gpl-compatible: true
824
  version: "v3.3.1"
825
  js:
826
    assets/vendor/modernizr/modernizr.min.js: { preprocess: 0, weight: -21, minified: true }
827 828 829

normalize:
  remote: https://github.com/necolas/normalize.css
830
  version: "3.0.3"
831 832 833 834
  license:
    name: MIT
    url: https://github.com/necolas/normalize.css/blob/master/LICENSE.md
    gpl-compatible: true
835 836
  css:
    base:
837
      assets/vendor/normalize-css/normalize.css: { weight: -20 }
838

839 840
picturefill:
  remote: https://github.com/scottjehl/picturefill
841
  version: "3.0.1"
842 843
  license:
    name: MIT
844
    url: https://github.com/scottjehl/picturefill/blob/3.0.1/LICENSE
845
    gpl-compatible: true
846
  js:
847
    assets/vendor/picturefill/picturefill.min.js: { weight: -10, minified: true }
848 849 850
  dependencies:
    - core/matchmedia

851 852
underscore:
  remote: https://github.com/jashkenas/underscore
853
  version: "1.8.3"
854 855
  license:
    name: MIT
856
    url: https://github.com/jashkenas/underscore/blob/1.8.3/LICENSE
857
    gpl-compatible: true
858
  js:
859
    assets/vendor/underscore/underscore-min.js: { weight: -20, minified: true }