install.php 1.04 KB
Newer Older
1 2
<?php

3 4 5 6 7
/**
 * @file
 * Initiates a browser-based installation of Drupal.
 */

8 9 10
// Change the directory to the Drupal root.
chdir('..');

11
/**
12
 * Global flag to indicate the site is in installation mode.
13
 *
14 15 16
 * The constant is defined using define() instead of const so that PHP
 * versions prior to 5.3 can display proper PHP requirements instead of causing
 * a fatal error.
17
 */
18
define('MAINTENANCE_MODE', 'install');
19

20
// Exit early if running an incompatible PHP version to avoid fatal errors.
21 22 23
// The minimum version is specified explicitly, as DRUPAL_MINIMUM_PHP is not
// yet available. It is defined in bootstrap.inc, but it is not possible to
// load that file yet as it would cause a fatal error on older versions of PHP.
24 25
if (version_compare(PHP_VERSION, '5.3.10') < 0) {
  print 'Your PHP installation is too old. Drupal requires at least PHP 5.3.10. See the <a href="http://drupal.org/requirements">system requirements</a> page for more information.';
26 27 28
  exit;
}

29
// Start the installer.
30
require_once __DIR__ . '/includes/install.core.inc';
31
install_drupal();