Commit f7b30ad6 authored by catch's avatar catch

Issue #2646100 by gapple: Exception on php7 + APCu without backwards compatibilty enabled

parent d7a6de3d
......@@ -963,11 +963,13 @@ protected function initializeSettings(Request $request) {
}
}
// If the class loader is still the same, possibly upgrade to the APCu class
// If the class loader is still the same, possibly upgrade to the APC class
// loader.
// ApcClassLoader does not support APCu without backwards compatibility
// enabled.
if ($class_loader_class == get_class($this->classLoader)
&& Settings::get('class_loader_auto_detect', TRUE)
&& function_exists('apcu_fetch')) {
&& extension_loaded('apc')) {
$prefix = Settings::getApcuPrefix('class_loader', $this->root);
$apc_loader = new \Symfony\Component\ClassLoader\ApcClassLoader($prefix, $this->classLoader);
$this->classLoader->unregister();
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment