Commit e80f6b8c authored by catch's avatar catch
Browse files

Issue #3264862 by mglaman, ankithashetty, longwave: ContextAwarePluginBase...

Issue #3264862 by mglaman, ankithashetty, longwave: ContextAwarePluginBase class not annotated as deprecated

(cherry picked from commit 4dcb45e2)
parent 565b68ed
......@@ -13,6 +13,11 @@
/**
* Base class for plugins that are context aware.
*
* @deprecated in drupal:9.1.0 and is removed from drupal:10.0.0. Use
* \Drupal\Core\Plugin\ContextAwarePluginTrait instead.
*
* @see https://www.drupal.org/node/3120980
*/
abstract class ContextAwarePluginBase extends ComponentContextAwarePluginBase implements ContextAwarePluginInterface, CacheableDependencyInterface {
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment