Commit e330cfde authored by catch's avatar catch
Browse files

Issue #3087531 by alexpott, jibran, gnikolovski, xjm, Mixologic: Use Diactoros...

Issue #3087531 by alexpott, jibran, gnikolovski, xjm, Mixologic: Use Diactoros LTS version 1.7, not 1.8 which is out of security coverage
parent 414fb974
...@@ -653,7 +653,7 @@ ...@@ -653,7 +653,7 @@
"dist": { "dist": {
"type": "path", "type": "path",
"url": "core", "url": "core",
"reference": "98e264668acbc33027a30953a7e194715b3ce33f" "reference": "9faae700fd9adfe0a1c5ffd73dcc334b3be5ce5a"
}, },
"require": { "require": {
"asm89/stack-cors": "^1.1", "asm89/stack-cors": "^1.1",
...@@ -697,7 +697,7 @@ ...@@ -697,7 +697,7 @@
"symfony/yaml": "^4.4", "symfony/yaml": "^4.4",
"twig/twig": "^1.38.2", "twig/twig": "^1.38.2",
"typo3/phar-stream-wrapper": "^3.1.3", "typo3/phar-stream-wrapper": "^3.1.3",
"zendframework/zend-diactoros": ">=1.7 <1.8", "zendframework/zend-diactoros": "^1.8",
"zendframework/zend-feed": "^2.12" "zendframework/zend-feed": "^2.12"
}, },
"conflict": { "conflict": {
...@@ -3637,16 +3637,16 @@ ...@@ -3637,16 +3637,16 @@
}, },
{ {
"name": "zendframework/zend-diactoros", "name": "zendframework/zend-diactoros",
"version": "1.7.2", "version": "1.8.7",
"source": { "source": {
"type": "git", "type": "git",
"url": "https://github.com/zendframework/zend-diactoros.git", "url": "https://github.com/zendframework/zend-diactoros.git",
"reference": "741e7a571836f038de731105f4742ca8a164e43a" "reference": "a85e67b86e9b8520d07e6415fcbcb8391b44a75b"
}, },
"dist": { "dist": {
"type": "zip", "type": "zip",
"url": "https://api.github.com/repos/zendframework/zend-diactoros/zipball/741e7a571836f038de731105f4742ca8a164e43a", "url": "https://api.github.com/repos/zendframework/zend-diactoros/zipball/a85e67b86e9b8520d07e6415fcbcb8391b44a75b",
"reference": "741e7a571836f038de731105f4742ca8a164e43a", "reference": "a85e67b86e9b8520d07e6415fcbcb8391b44a75b",
"shasum": "" "shasum": ""
}, },
"require": { "require": {
...@@ -3659,18 +3659,27 @@ ...@@ -3659,18 +3659,27 @@
"require-dev": { "require-dev": {
"ext-dom": "*", "ext-dom": "*",
"ext-libxml": "*", "ext-libxml": "*",
"phpunit/phpunit": "^5.7.16 || ^6.0.8", "php-http/psr7-integration-tests": "dev-master",
"phpunit/phpunit": "^5.7.16 || ^6.0.8 || ^7.2.7",
"zendframework/zend-coding-standard": "~1.0" "zendframework/zend-coding-standard": "~1.0"
}, },
"type": "library", "type": "library",
"extra": { "extra": {
"branch-alias": { "branch-alias": {
"dev-master": "1.7.x-dev", "dev-release-1.8": "1.8.x-dev"
"dev-develop": "1.8.x-dev",
"dev-release-2.0": "2.0.x-dev"
} }
}, },
"autoload": { "autoload": {
"files": [
"src/functions/create_uploaded_file.php",
"src/functions/marshal_headers_from_sapi.php",
"src/functions/marshal_method_from_sapi.php",
"src/functions/marshal_protocol_version_from_sapi.php",
"src/functions/marshal_uri_from_sapi.php",
"src/functions/normalize_server.php",
"src/functions/normalize_uploaded_files.php",
"src/functions/parse_cookie_header.php"
],
"psr-4": { "psr-4": {
"Zend\\Diactoros\\": "src/" "Zend\\Diactoros\\": "src/"
} }
...@@ -3686,7 +3695,7 @@ ...@@ -3686,7 +3695,7 @@
"psr", "psr",
"psr-7" "psr-7"
], ],
"time": "2018-05-29T16:53:08+00:00" "time": "2019-08-06T17:53:53+00:00"
}, },
{ {
"name": "zendframework/zend-escaper", "name": "zendframework/zend-escaper",
......
...@@ -43,7 +43,7 @@ ...@@ -43,7 +43,7 @@
"egulias/email-validator": "^2.0", "egulias/email-validator": "^2.0",
"masterminds/html5": "^2.1", "masterminds/html5": "^2.1",
"symfony/psr-http-message-bridge": "^1.2.0", "symfony/psr-http-message-bridge": "^1.2.0",
"zendframework/zend-diactoros": ">=1.7 <1.8", "zendframework/zend-diactoros": "^1.8",
"composer/semver": "^1.0", "composer/semver": "^1.0",
"asm89/stack-cors": "^1.1", "asm89/stack-cors": "^1.1",
"pear/archive_tar": "^1.4.8" "pear/archive_tar": "^1.4.8"
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment