Commit e2258e26 authored by catch's avatar catch
Browse files

Issue #3085062 by jibran, amateescu, larowlan, xjm, Berdir: Declare a conflict...

Issue #3085062 by jibran, amateescu, larowlan, xjm, Berdir: Declare a conflict on pathauto versions that aren't compatible with 8.8.0
parent 8015c87f
......@@ -653,7 +653,7 @@
"dist": {
"type": "path",
"url": "core",
"reference": "8830b3c971fde18c39a7818d1722fbcab385641a"
"reference": "98e264668acbc33027a30953a7e194715b3ce33f"
},
"require": {
"asm89/stack-cors": "^1.1",
......@@ -701,6 +701,7 @@
"zendframework/zend-feed": "^2.12"
},
"conflict": {
"drupal/pathauto": "<1.6",
"drush/drush": "<8.1.10"
},
"replace": {
......
......@@ -49,6 +49,7 @@
"pear/archive_tar": "^1.4.8"
},
"conflict": {
"drupal/pathauto": "<1.6",
"drush/drush": "<8.1.10"
},
"replace": {
......
......@@ -1096,6 +1096,23 @@ function system_requirements($phase) {
}
}
// Prevent installation or update if the Pathauto module is installed and its
// version is less than 1.6.
if ($phase === 'install' || $phase === 'update') {
if (\Drupal::moduleHandler()->moduleExists('pathauto')) {
$info = \Drupal::service('extension.list.module')->getExtensionInfo('pathauto');
if (version_compare($info['version'], '8.x-1.5') <= 0) {
$requirements['pathauto_module_incompatibility'] = [
'title' => t('Pathauto'),
'description' => t('The Pathauto module is not compatible with the current version of Drupal core. Update the <a href=":url">Pathauto</a> module to 8.x-1.6 or later.', [
':url' => 'https://drupal.org/project/pathauto',
]),
'severity' => REQUIREMENT_ERROR,
];
}
}
}
return $requirements;
}
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment