Commit e20ff5e0 authored by xjm's avatar xjm
Browse files

Issue #3086379 by zrpnr, lauriii, johndevman, xjm: Deprecate html5shiv and remove usages in core

(cherry picked from commit df9fd065)
parent abf0b95c
......@@ -356,6 +356,7 @@ html5shiv:
gpl-compatible: true
js:
assets/vendor/html5shiv/html5shiv.min.js: { weight: -22, browsers: { IE: 'lte IE 8', '!IE': false }, minified: true }
deprecated: The "%library_id%" asset library is deprecated in drupal:8.8.0 and is removed from drupal:9.0.0. See https://www.drupal.org/node/3086383
jquery:
remote: https://github.com/jquery/jquery
......
......@@ -142,6 +142,7 @@ public static function getSkippedDeprecations() {
'The "Symfony\Component\BrowserKit\Response::getStatus()" method is deprecated since Symfony 4.3, use getStatusCode() instead.',
// @todo Remove in https://www.drupal.org/project/drupal/issues/3082655
'Drupal\Tests\BrowserTestBase::$defaultTheme is required in drupal:9.0.0 when using an install profile that does not set a default theme. See https://www.drupal.org/node/2352949, which includes recommendations on which theme to use.',
'The "core/html5shiv" asset library is deprecated in drupal:8.8.0 and is removed from drupal:9.0.0. See https://www.drupal.org/node/3086383',
];
}
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment