Commit dafad70b authored by xjm's avatar xjm
Browse files

Issue #3133604 by Berdir, dww: Dependency compatibility check in system...

Issue #3133604 by Berdir, dww: Dependency compatibility check in system doesn't check if version is defined

(cherry picked from commit 4da7958d)
parent 9859bdd2
......@@ -47,6 +47,7 @@ class ThemeExtensionList extends ExtensionList {
'comment_user_verification',
],
'screenshot' => 'screenshot.png',
'version' => NULL,
'php' => DRUPAL_MINIMUM_PHP,
'libraries' => [],
'libraries_extend' => [],
......
......@@ -30,4 +30,12 @@ public function testGetlist() {
$this->assertArrayHasKey('test_theme', $extensions);
}
/**
* Tests that themes have an empty default version set.
*/
public function testThemeWithoutVersion() {
$theme = \Drupal::service('extension.list.theme')->get('test_theme_settings_features');
$this->assertNull($theme->info['version']);
}
}
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment