Commit c8108b8a authored by catch's avatar catch
Browse files

Issue #3123326 by Neslee Canil Pinto, longwave, Berdir: Remove pathauto...

Issue #3123326 by Neslee Canil Pinto, longwave, Berdir: Remove pathauto version check from 9.0, no incompatible version is Drupal 9 compatible
parent d808600d
......@@ -457,7 +457,7 @@
"dist": {
"type": "path",
"url": "core",
"reference": "ee859e3b680da3526344d30756dc360185d8b412"
"reference": "e3d324da27c1060f5f9982ee20aa7f9845303fd2"
},
"require": {
"asm89/stack-cors": "^1.1",
......@@ -504,7 +504,6 @@
"typo3/phar-stream-wrapper": "^3.1.3"
},
"conflict": {
"drupal/pathauto": "<1.6",
"drush/drush": "<8.1.10"
},
"replace": {
......
......@@ -48,7 +48,6 @@
"psr/log": "^1.0"
},
"conflict": {
"drupal/pathauto": "<1.6",
"drush/drush": "<8.1.10"
},
"replace": {
......
......@@ -1220,23 +1220,6 @@ function system_requirements($phase) {
}
}
// Prevent installation or update if the Pathauto module is installed and its
// version is less than 1.6.
if ($phase === 'install' || $phase === 'update') {
if (\Drupal::moduleHandler()->moduleExists('pathauto')) {
$info = \Drupal::service('extension.list.module')->getExtensionInfo('pathauto');
if (version_compare($info['version'], '8.x-1.5') <= 0) {
$requirements['pathauto_module_incompatibility'] = [
'title' => t('Pathauto'),
'description' => t('The Pathauto module is not compatible with the current version of Drupal core. Update the <a href=":url">Pathauto</a> module to 8.x-1.6 or later.', [
':url' => 'https://drupal.org/project/pathauto',
]),
'severity' => REQUIREMENT_ERROR,
];
}
}
}
// Ensure that no module has a current schema version that is lower than the
// one that was last removed.
if ($phase == 'update') {
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment