Commit bf4e48d3 authored by Gábor Hojtsy's avatar Gábor Hojtsy
Browse files

Issue #3098489 by catch, lauriii, DamienMcKenna, zrpnr, longwave, bnjmnm:...

Issue #3098489 by catch, lauriii, DamienMcKenna, zrpnr, longwave, bnjmnm: Remove deprecated jQuery UI library definitions
parent b28328b7
......@@ -469,56 +469,36 @@ jquery.ui.button:
version: *jquery_ui_version
license: *jquery_ui_license
js:
assets/vendor/jquery.ui/ui/widgets/checkboxradio-min.js: { minified: true }
assets/vendor/jquery.ui/ui/widgets/controlgroup-min.js: { minified: true }
assets/vendor/jquery.ui/ui/widgets/button-min.js: { minified: true }
css:
component:
assets/vendor/jquery.ui/themes/base/checkboxradio.css: {}
assets/vendor/jquery.ui/themes/base/controlgroup.css: {}
assets/vendor/jquery.ui/themes/base/button.css: {}
dependencies:
- core/jquery.ui
- core/jquery.ui.widget
- core/jquery.ui.checkboxradio
- core/jquery.ui.controlgroup
jquery.ui.checkboxradio:
jquery.ui.dialog:
version: *jquery_ui_version
license: *jquery_ui_license
js:
assets/vendor/jquery.ui/ui/form-reset-mixin-min.js: { minified: true }
assets/vendor/jquery.ui/ui/widgets/checkboxradio-min.js: { minified: true }
css:
component:
assets/vendor/jquery.ui/themes/base/checkboxradio.css: {}
assets/vendor/jquery.ui/themes/base/button.css: {}
dependencies:
- core/jquery.ui
- core/jquery.ui.widget
deprecated: &jquery_ui_unused_deprecated The "%library_id%" asset library is deprecated in drupal:8.8.0 and is removed from drupal:9.0.0. See https://www.drupal.org/node/3067969
jquery.ui.controlgroup:
version: *jquery_ui_version
license: *jquery_ui_license
js:
assets/vendor/jquery.ui/ui/widgets/controlgroup-min.js: { minified: true }
css:
component:
assets/vendor/jquery.ui/themes/base/controlgroup.css: {}
dependencies:
- core/jquery.ui
- core/jquery.ui.widget
deprecated: *jquery_ui_unused_deprecated
jquery.ui.dialog:
version: *jquery_ui_version
license: *jquery_ui_license
js:
assets/vendor/jquery.ui/ui/widgets/button-min.js: { minified: true }
assets/vendor/jquery.ui/ui/widgets/dialog-min.js: { minified: true }
css:
component:
assets/vendor/jquery.ui/themes/base/checkboxradio.css: {}
assets/vendor/jquery.ui/themes/base/controlgroup.css: {}
assets/vendor/jquery.ui/themes/base/button.css: {}
assets/vendor/jquery.ui/themes/base/dialog.css: {}
dependencies:
- core/jquery.ui
- core/jquery.ui.widget
- core/jquery.ui.button
- core/jquery.ui.draggable
- core/jquery.ui.mouse
- core/jquery.ui.position
......
<?php
namespace Drupal\KernelTests\Core\Asset;
use Drupal\KernelTests\KernelTestBase;
/**
* Tests that deprecated asset libraries trigger a deprecation error.
*
* @group Asset
* @group legacy
*/
class LegacyLibraryDiscoveryTest extends KernelTestBase {
/**
* The library discovery service.
*
* @var \Drupal\Core\Asset\LibraryDiscoveryInterface
*/
protected $libraryDiscovery;
/**
* {@inheritdoc}
*/
protected function setUp() {
parent::setUp();
$this->libraryDiscovery = $this->container->get('library.discovery');
}
/**
* Tests that the jquery.ui.checkboxradio library is deprecated.
*
* @expectedDeprecation The "core/jquery.ui.checkboxradio" asset library is deprecated in drupal:8.8.0 and is removed from drupal:9.0.0. See https://www.drupal.org/node/3067969
* @doesNotPerformAssertions
*/
public function testJqueryUiCheckboxradio() {
$this->libraryDiscovery->getLibraryByName('core', 'jquery.ui.checkboxradio');
}
/**
* Tests that the jquery.ui.controlgroup library is deprecated.
*
* @expectedDeprecation The "core/jquery.ui.controlgroup" asset library is deprecated in drupal:8.8.0 and is removed from drupal:9.0.0. See https://www.drupal.org/node/3067969
* @doesNotPerformAssertions
*/
public function testJqueryUiControlgroup() {
$this->libraryDiscovery->getLibraryByName('core', 'jquery.ui.controlgroup');
}
}
......@@ -174,8 +174,6 @@ public static function getSkippedDeprecations() {
'The "Symfony\Component\Process\Process::inheritEnvironmentVariables()" method is deprecated since Symfony 4.4, env variables are always inherited.',
'The "Symfony\Component\Debug\BufferingLogger" class is deprecated since Symfony 4.4, use "Symfony\Component\ErrorHandler\BufferingLogger" instead.',
'Using the "Symfony\Component\Validator\Constraints\Length" constraint with the "min" option without setting the "allowEmptyString" one is deprecated and defaults to true. In 5.0, it will become optional and default to false.',
'The "core/jquery.ui.checkboxradio" asset library is deprecated in drupal:8.8.0 and is removed from drupal:9.0.0. See https://www.drupal.org/node/3067969',
'The "core/jquery.ui.controlgroup" asset library is deprecated in drupal:8.8.0 and is removed from drupal:9.0.0. See https://www.drupal.org/node/3067969',
// The following deprecation is listed for Twig 2 compatibility when unit
// testing using \Symfony\Component\ErrorHandler\DebugClassLoader.
'The "Twig\Environment::getTemplateClass()" method is considered internal. It may change without further notice. You should not extend it from "Drupal\Core\Template\TwigEnvironment".',
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment