Commit a64943de authored by larowlan's avatar larowlan

Issue #2880387 by Kingdutch: Avoid unnecessary array operations in update_get_update_list

parent d3612415
......@@ -323,8 +323,7 @@ function update_get_update_list() {
continue;
}
$updates = array_combine($updates, $updates);
foreach (array_keys($updates) as $update) {
foreach ($updates as $update) {
if ($update == \Drupal::CORE_MINIMUM_SCHEMA_VERSION) {
$ret[$module]['warning'] = '<em>' . $module . '</em> module cannot be updated. It contains an update numbered as ' . \Drupal::CORE_MINIMUM_SCHEMA_VERSION . ' which is reserved for the earliest installation of a module in Drupal ' . \Drupal::CORE_COMPATIBILITY . ', before any updates. In order to update <em>' . $module . '</em> module, you will need to install a version of the module with valid updates.';
continue 2;
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment