Unverified Commit a17f93cc authored by alexpott's avatar alexpott
Browse files

Issue #3265376 by xjm: Fix UpdateScriptTest when MINIMUM_SUPPORTED_PHP is used

(cherry picked from commit 3f55b826)
parent aa05014a
......@@ -661,6 +661,7 @@ public function testMaintenanceModeLink() {
$this->drupalLogin($full_admin_user);
$this->drupalGet($this->updateUrl, ['external' => TRUE]);
$this->assertSession()->statusCodeEquals(200);
$this->updateRequirementsProblem();
$this->clickLink('maintenance mode');
$this->assertSession()->statusCodeEquals(200);
$this->assertSession()->elementContains('css', 'main h1', 'Maintenance mode');
......@@ -670,6 +671,7 @@ public function testMaintenanceModeLink() {
$this->drupalLogin($this->updateUser);
$this->drupalGet($this->updateUrl, ['external' => TRUE]);
$this->assertSession()->statusCodeEquals(200);
$this->updateRequirementsProblem();
$this->clickLink('maintenance mode');
$this->assertSession()->statusCodeEquals(200);
$this->assertSession()->elementContains('css', 'main h1', 'Maintenance mode');
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment