Commit 972d4f8d authored by Dries's avatar Dries
Browse files

- Patch #120291 by njivy: collapse.js compatible with jQuery 1.1.1.

parent e6543caa
......@@ -7,17 +7,12 @@ Drupal.toggleFieldset = function(fieldset) {
if ($(fieldset).is('.collapsed')) {
var content = $('> div', fieldset).hide();
$(fieldset).removeClass('collapsed');
content.slideDown(300, {
complete: function() {
content.slideDown(300,
function() {
// Make sure we open to height auto
$(this).css('height', 'auto');
Drupal.collapseScrollIntoView(this.parentNode);
this.parentNode.animating = false;
},
step: function() {
// Scroll the fieldset into view
Drupal.collapseScrollIntoView(this.parentNode);
}
});
if (typeof Drupal.textareaAttach != 'undefined') {
// Initialize resizable textareas that are now revealed
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment