Commit 7f2f0072 authored by Gábor Hojtsy's avatar Gábor Hojtsy

#105405 by chx, Pancho: (regression) remove web server version checking; it is...

#105405 by chx, Pancho: (regression) remove web server version checking; it is not in Drupal 5; Apache 1.3 is surpassed for a long time now
parent d171a9e7
......@@ -24,34 +24,12 @@ function system_requirements($phase) {
);
}
// Test web server
// Web server information.
$software = $_SERVER['SERVER_SOFTWARE'];
$requirements['webserver'] = array(
'title' => $t('Web server'),
'value' => $software,
);
// Use server info string, if present.
if ($software && preg_match('![0-9]!', $software)) {
list($server, $version) = split('[ /]', $software);
switch ($server) {
case 'Apache':
if (version_compare($version, DRUPAL_MINIMUM_APACHE) < 0) {
$requirements['webserver']['description'] = $t('Your Apache server is too old. Drupal requires at least Apache %version.', array('%version' => DRUPAL_MINIMUM_APACHE));
$requirements['webserver']['severity'] = REQUIREMENT_ERROR;
}
break;
default:
$requirements['webserver']['description'] = $t('The web server you\'re using has not been tested with Drupal and might not work properly.');
$requirements['webserver']['severity'] = REQUIREMENT_WARNING;
break;
}
}
else {
$requirements['webserver']['value'] = $software ? $software : $t('Unknown');
$requirements['webserver']['description'] = $t('Unable to determine your web server type and version. Drupal might not work properly.');
$requirements['webserver']['severity'] = REQUIREMENT_WARNING;
}
// Test PHP version
$requirements['php'] = array(
......
......@@ -36,11 +36,6 @@
*/
define('DRUPAL_MINIMUM_PGSQL', '7.4');
/**
* Minimum supported version of Apache, if it is used.
*/
define('DRUPAL_MINIMUM_APACHE', '1.3');
/**
* Maximum age of temporary files in seconds.
*/
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment