Commit 613b5616 authored by drumm's avatar drumm
Browse files

#105303 by Gábor Hojtsy. Improve translation converage for installation.

parent 9d368500
......@@ -21,7 +21,7 @@ function mysql_is_available() {
*/
function drupal_test_mysql($url, &$success) {
if (!mysql_is_available()) {
drupal_set_message('PHP MySQL support not enabled.', 'error');
drupal_set_message(st('PHP MySQL support not enabled.'), 'error');
return FALSE;
}
......
......@@ -21,7 +21,7 @@ function mysqli_is_available() {
*/
function drupal_test_mysqli($url, &$success) {
if (!mysqli_is_available()) {
drupal_set_message('PHP MySQLi support not enabled.', 'error');
drupal_set_message(st('PHP MySQLi support not enabled.'), 'error');
return FALSE;
}
......
......@@ -21,7 +21,7 @@ function pgsql_is_available() {
*/
function drupal_test_pgsql($url, &$success) {
if (!pgsql_is_available()) {
drupal_set_message('PHP PostgreSQL support not enabled.', 'error');
drupal_set_message(st('PHP PostgreSQL support not enabled.'), 'error');
return FALSE;
}
......
......@@ -453,14 +453,14 @@ function theme_install_page($content) {
$messages = drupal_set_message();
if (isset($messages['error'])) {
$errors = count($messages['error']) > 1 ? 'errors' : 'error';
$output .= "<h3>The following $errors must be resolved before you can continue the installation process:</h3>";
$title = count($messages['error']) > 1 ? st('The following errors must be resolved before you can continue the installation process') : st('The following error must be resolved before you can continue the installation process');
$output .= '<h3>' .$title. ':</h3>';
$output .= theme('status_messages', 'error');
}
if (isset($messages['status'])) {
$warnings = count($messages['status']) > 1 ? 'warnings' : 'warning';
$output .= "<h4>The following installation $warnings should be carefully reviewed, but in most cases may be safely ignored:</h4>";
$warnings = count($messages['status']) > 1 ? st('The following installation warnings should be carefully reviewed, but in most cases may be safely ignored') : st('The following installation warning should be carefully reviewed, but in most cases may be safely ignored');
$output .= '<h4>' .$title. ':</h4>';
$output .= theme('status_messages', 'status');
}
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment