Commit 496b3b8c authored by webchick's avatar webchick
Browse files

#524664 by codecowboy and mfb: drupal_error_handler() does not support PHP 5.3.0 error constants.

parent 271fbd6b
......@@ -1067,6 +1067,11 @@ function _drupal_error_handler($error_level, $message, $filename, $line, $contex
E_STRICT => 'Strict warning',
E_RECOVERABLE_ERROR => 'Recoverable fatal error'
);
// E_DEPRECATED and E_USER_DEPRECATED were added in PHP 5.3.0.
if (defined('E_DEPRECATED')) {
$types[E_DEPRECATED] = 'Deprecated function';
$types[E_USER_DEPRECATED] = 'User deprecated function';
}
$caller = _drupal_get_last_caller(debug_backtrace());
// We treat recoverable errors as fatal.
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment