Commit 1488b8bf authored by webchick's avatar webchick
Browse files

Issue #1969714 by yched: Fixed Stale class names for FieldInstance in phpdocs.

parent 7cf52a7b
...@@ -42,7 +42,7 @@ class DateTimeDatelistWidget extends WidgetBase { ...@@ -42,7 +42,7 @@ class DateTimeDatelistWidget extends WidgetBase {
* The plugin_id for the widget. * The plugin_id for the widget.
* @param array $plugin_definition * @param array $plugin_definition
* The plugin implementation definition. * The plugin implementation definition.
* @param \Drupal\field\FieldInstance $instance * @param \Drupal\field\Plugin\Core\Entity\FieldInstance $instance
* The field instance to which the widget is associated. * The field instance to which the widget is associated.
* @param array $settings * @param array $settings
* The widget settings. * The widget settings.
......
...@@ -36,7 +36,7 @@ class DateTimeDefaultWidget extends WidgetBase { ...@@ -36,7 +36,7 @@ class DateTimeDefaultWidget extends WidgetBase {
* The plugin_id for the widget. * The plugin_id for the widget.
* @param array $plugin_definition * @param array $plugin_definition
* The plugin implementation definition. * The plugin implementation definition.
* @param \Drupal\field\FieldInstance $instance * @param \Drupal\field\Plugin\Core\Entity\FieldInstance $instance
* The field instance to which the widget is associated. * The field instance to which the widget is associated.
* @param array $settings * @param array $settings
* The widget settings. * The widget settings.
......
...@@ -21,7 +21,7 @@ interface EditorInterface extends PluginInspectionInterface { ...@@ -21,7 +21,7 @@ interface EditorInterface extends PluginInspectionInterface {
/** /**
* Checks whether this editor is compatible with a given field instance. * Checks whether this editor is compatible with a given field instance.
* *
* @param \Drupal\field\FieldInstance $instance * @param \Drupal\field\Plugin\Core\Entity\FieldInstance $instance
* The field instance of the field being edited. * The field instance of the field being edited.
* @param array $items * @param array $items
* The field's item values. * The field's item values.
...@@ -37,7 +37,7 @@ public function isCompatible(FieldInstance $instance, array $items); ...@@ -37,7 +37,7 @@ public function isCompatible(FieldInstance $instance, array $items);
* Will only be called by \Drupal\edit\MetadataGeneratorInterface::generate() * Will only be called by \Drupal\edit\MetadataGeneratorInterface::generate()
* when the passed in field instance & item values will use this editor. * when the passed in field instance & item values will use this editor.
* *
* @param \Drupal\field\FieldInstance $instance * @param \Drupal\field\Plugin\Core\Entity\FieldInstance $instance
* The field instance of the field being edited. * The field instance of the field being edited.
* @param array $items * @param array $items
* The field's item values. * The field's item values.
......
...@@ -19,7 +19,7 @@ interface EditorSelectorInterface { ...@@ -19,7 +19,7 @@ interface EditorSelectorInterface {
* *
* @param string $formatter_type * @param string $formatter_type
* The field's formatter type name. * The field's formatter type name.
* @param \Drupal\field\FieldInstance $instance * @param \Drupal\field\Plugin\Core\Entity\FieldInstance $instance
* The field's instance info. * The field's instance info.
* @param array $items * @param array $items
* The field's item values. * The field's item values.
......
...@@ -20,7 +20,7 @@ interface MetadataGeneratorInterface { ...@@ -20,7 +20,7 @@ interface MetadataGeneratorInterface {
* *
* @param \Drupal\Core\Entity\EntityInterface $entity * @param \Drupal\Core\Entity\EntityInterface $entity
* The entity being edited. * The entity being edited.
* @param \Drupal\field\FieldInstance $instance * @param \Drupal\field\Plugin\Core\Entity\FieldInstance $instance
* The field instance of the field being edited. * The field instance of the field being edited.
* @param string $langcode * @param string $langcode
* The name of the language for which the field is being edited. * The name of the language for which the field is being edited.
......
...@@ -26,7 +26,7 @@ abstract class FormatterBase extends PluginSettingsBase implements FormatterInte ...@@ -26,7 +26,7 @@ abstract class FormatterBase extends PluginSettingsBase implements FormatterInte
/** /**
* The field instance definition. * The field instance definition.
* *
* @var Drupal\field\FieldInstance * @var \Drupal\field\Plugin\Core\Entity\FieldInstance
*/ */
protected $instance; protected $instance;
...@@ -58,7 +58,7 @@ abstract class FormatterBase extends PluginSettingsBase implements FormatterInte ...@@ -58,7 +58,7 @@ abstract class FormatterBase extends PluginSettingsBase implements FormatterInte
* The plugin_id for the formatter. * The plugin_id for the formatter.
* @param array $plugin_definition * @param array $plugin_definition
* The plugin implementation definition. * The plugin implementation definition.
* @param Drupal\field\FieldInstance $instance * @param \Drupal\field\Plugin\Core\Entity\FieldInstance $instance
* The field instance to which the formatter is associated. * The field instance to which the formatter is associated.
* @param array $settings * @param array $settings
* The formatter settings. * The formatter settings.
......
...@@ -27,7 +27,7 @@ abstract class WidgetBase extends PluginSettingsBase implements WidgetInterface ...@@ -27,7 +27,7 @@ abstract class WidgetBase extends PluginSettingsBase implements WidgetInterface
/** /**
* The field instance definition. * The field instance definition.
* *
* @var Drupal\field\FieldInstance * @var \Drupal\field\Plugin\Core\Entity\FieldInstance
*/ */
protected $instance; protected $instance;
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment