Commit 1198809b authored by catch's avatar catch
Browse files

Issue #2919215 by alexpott, longwave, dawehner: Deprecate feed.bridge.writer

(cherry picked from commit a0e1956f)
parent ed951b05
......@@ -1449,6 +1449,7 @@ services:
- [setContainer, ['@service_container']]
- [setStandalone, ['\Laminas\Feed\Writer\StandaloneExtensionManager']]
arguments: ['feed.writer.']
deprecated: The "%service_id%" service is deprecated in drupal:9.4.0 and is removed from drupal:10.0.0. Use \Laminas\Feed\Writer\StandaloneExtensionManager or create your own service. See https://www.drupal.org/node/3258440
# Laminas Feed reader plugins. Plugin instances should not be shared.
feed.reader.dublincoreentry:
class: Laminas\Feed\Reader\Extension\DublinCore\Entry
......
......@@ -41,6 +41,14 @@ public function testLaminasFeedServices($type, $service, $class) {
$this->assertIsObject($this->container->get($service));
}
/**
* Tests the deprecated Laminas bridge service.
*/
public function testLaminasBridgeService() {
$this->expectDeprecation("The \"feed.bridge.writer\" service is deprecated in drupal:9.4.0 and is removed from drupal:10.0.0. Use \Laminas\Feed\Writer\StandaloneExtensionManager or create your own service. See https://www.drupal.org/node/3258440");
$this->assertIsObject($this->container->get('feed.bridge.writer'));
}
public function providerLaminasFeedServices() {
return [
['reader', 'dublincoreentry', 'DublinCore\Entry'],
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment