core.libraries.yml 27.7 KB
Newer Older
1
2
3
4
# All libraries are defined in alphabetical order.

backbone:
  remote: https://github.com/jashkenas/backbone
5
  version: "1.4.0"
6
7
  license:
    name: MIT
8
    url: https://raw.githubusercontent.com/jashkenas/backbone/1.4.0/LICENSE
9
    gpl-compatible: true
10
  js:
11
    assets/vendor/backbone/backbone-min.js: { weight: -19, minified: true }
12
13
14
15
  dependencies:
    - core/underscore

ckeditor:
16
  remote: https://github.com/ckeditor/ckeditor4
17
  version: "4.16.2"
18
19
  license:
    name: GNU-GPL-2.0-or-later
20
    url: https://raw.githubusercontent.com/ckeditor/ckeditor4/4.16.2/LICENSE.md
21
    gpl-compatible: true
22
  js:
23
    assets/vendor/ckeditor/ckeditor.js: { preprocess: false, minified: true }
24

25
26
27
28
29
30
31
32
33
34
css.escape:
  remote: https://github.com/mathiasbynens/CSS.escape
  version: "1.5.1"
  license:
    name: MIT
    url: https://raw.githubusercontent.com/mathiasbynens/CSS.escape/v1.5.1/LICENSE-MIT.txt
    gpl-compatible: true
  js:
    assets/vendor/css-escape/css.escape.js: { weight: -20 }

35
36
37
drupal:
  version: VERSION
  js:
38
    misc/drupal.js: { weight: -18 }
39
    misc/drupal.init.js: { weight: -17 }
40
  dependencies:
41
    - core/drupalSettings
42
43
  drupalSettings:
    suppressDeprecationErrors: true
44
45
46

drupalSettings:
  version: VERSION
47
48
49
50
  js:
    # Need to specify a negative weight like drupal.js until
    # https://www.drupal.org/node/1945262 is resolved.
    misc/drupalSettingsLoader.js: { weight: -18 }
51
52
53
54
55
56
57
58
59
60
  drupalSettings:
    # These placeholder values will be set by system_js_settings_alter().
    path:
      baseUrl: null
      scriptPath: null
      pathPrefix: null
      currentPath: null
      currentPathIsAdmin: null
      isFront: null
      currentLanguage: null
61
    pluralDelimiter: null
62
63
64
65
66
67
68
69
70
71
72
73
74

drupal.active-link:
  version: VERSION
  js:
    misc/active-link.js: {}
  dependencies:
    - core/drupal
    - core/drupalSettings

drupal.ajax:
  version: VERSION
  js:
    misc/ajax.js: {}
75
76
77
78
79
80
  drupalSettings:
    # These placeholder values will be set by system_js_settings_alter().
    ajaxPageState:
      libraries: null
      theme: null
      theme_token: null
81
    ajaxTrustedUrl: {}
82
83
84
85
86
  dependencies:
    - core/jquery
    - core/drupal
    - core/drupalSettings
    - core/drupal.progress
87
    - core/once
88
    - core/tabbable
89
90
91
92
93
94
95
96
97

drupal.announce:
  version: VERSION
  js:
    misc/announce.js: {}
  dependencies:
    - core/drupal
    - core/drupal.debounce

98
99
100
101
102
103
104
105
106
107
loadjs:
  remote: https://github.com/muicss/loadjs
  version: "4.2.0"
  license:
    name: MIT
    url: https://raw.githubusercontent.com/muicss/loadjs/4.2.0/LICENSE.txt
    gpl-compatible: true
  js:
    assets/vendor/loadjs/loadjs.min.js: { minified: true }

108
109
110
drupal.autocomplete:
  version: VERSION
  js:
111
    misc/autocomplete.js: { weight: -1 }
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
    # The remaining JavaScript assets previously came from core/jquery.ui, a
    # deprecated library.
    # All weights are based on on the requirements defined within each file.
    # @todo replace with solution in https://drupal.org/node/3076171
    assets/vendor/jquery.ui/ui/widgets/autocomplete-min.js: { weight: -11.7, minified: true }
    assets/vendor/jquery.ui/ui/labels-min.js: { weight: -11.7, minified: true }
    assets/vendor/jquery.ui/ui/widgets/menu-min.js: { weight: -11.7, minified: true }
    assets/vendor/jquery.ui/ui/data-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/disable-selection-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/escape-selector-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/focusable-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/form-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/ie-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/jquery-1-7-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/keycode-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/plugin-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/safe-active-element-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/safe-blur-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/scroll-parent-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/unique-id-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/widget-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/version-min.js: { weight: -11.9, minified: true }
  # All CSS assets previously came from core/jquery.ui, a deprecated library.
  # @todo replace with solution found in https://drupal.org/node/3076171
  css:
    component:
      assets/vendor/jquery.ui/themes/base/autocomplete.css: { weight: -11.7 }
      assets/vendor/jquery.ui/themes/base/menu.css: { weight: -11.7 }
      assets/vendor/jquery.ui/themes/base/core.css: { weight: -11.8 }
    theme:
      assets/vendor/jquery.ui/themes/base/theme.css: { weight: -11.8 }
143
144
145
146
147
  dependencies:
    - core/jquery
    - core/drupal
    - core/drupalSettings
    - core/drupal.ajax
148
    - core/tabbable.jquery.shim
149
150
    - core/drupal.jquery.position

151

152
153
154
155
156
drupal.array.find:
  version: VERSION
  js:
    misc/polyfills/array.find.js: { weight: -20 }

157
158
159
160
161
162
163
164
165
166
drupal.batch:
  version: VERSION
  js:
    misc/batch.js: { cache: false }
  dependencies:
    - core/jquery
    - core/drupal
    - core/drupalSettings
    - core/drupal.ajax
    - core/drupal.progress
167
    - core/once
168

169
170
171
172
173
174
175
drupal.checkbox:
  version: VERSION
  js:
    misc/checkbox.js: {}
  dependencies:
    - core/drupal

176
177
178
drupal.collapse:
  version: VERSION
  js:
179
    misc/details-summarized-content.js: {}
180
    misc/details-aria.js: {}
181
182
183
184
185
186
    misc/collapse.js: {}
  dependencies:
    - core/jquery
    - core/modernizr
    - core/drupal
    - core/drupal.form
187
    - core/once
188

189
190
191
192
193
194
195
drupal.date:
  version: VERSION
  js:
    misc/date.js: {}
  dependencies:
    - core/drupal
    - core/modernizr
196
    - core/once
197

198
199
200
201
202
203
204
205
206
207
208
drupal.debounce:
  version: VERSION
  js:
    misc/debounce.js: {}
  dependencies:
    # @todo Remove Drupal dependency.
    - core/drupal

drupal.dialog:
  version: VERSION
  js:
209
210
211
    misc/dialog/dialog.js: {}
    misc/dialog/dialog.position.js: {}
    misc/dialog/dialog.jquery-ui.js: {}
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
    # The remaining JavaScript assets previously came from core/jquery.ui, a
    # deprecated library.
    # All weights are based on on the requirements defined within each file.
    # @todo replace with solution in https://drupal.org/node/2158943
    assets/vendor/jquery.ui/ui/widgets/dialog-min.js: { weight: -11.4, minified: true }
    assets/vendor/jquery.ui/ui/widgets/button-min.js: { weight: -11.5, minified: true }
    assets/vendor/jquery.ui/ui/widgets/checkboxradio-min.js: { weight: -11.6, minified: true }
    assets/vendor/jquery.ui/ui/widgets/draggable-min.js: { weight: -11.6, minified: true }
    assets/vendor/jquery.ui/ui/widgets/resizable-min.js: { weight: -11.6, minified: true }
    assets/vendor/jquery.ui/ui/widgets/controlgroup-min.js: { weight: -11.7, minified: true }
    assets/vendor/jquery.ui/ui/form-reset-mixin-min.js: { weight: -11.7, minified: true }
    assets/vendor/jquery.ui/ui/labels-min.js: { weight: -11.7, minified: true }
    assets/vendor/jquery.ui/ui/widgets/mouse-min.js: { weight: -11.7, minified: true }
    assets/vendor/jquery.ui/ui/data-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/disable-selection-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/form-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/jquery-1-7-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/scroll-parent-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/unique-id-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/escape-selector-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/focusable-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/ie-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/keycode-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/plugin-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/safe-active-element-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/safe-blur-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/widget-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/version-min.js: { weight: -11.9, minified: true }
  # All CSS assets previously came from core/jquery.ui, a deprecated library.
  # @todo replace with solution found in https://drupal.org/node/2158943
  css:
    component:
      assets/vendor/jquery.ui/themes/base/dialog.css: { weight: -11.4 }
      assets/vendor/jquery.ui/themes/base/button.css: { weight: -11.5 }
      assets/vendor/jquery.ui/themes/base/checkboxradio.css: { weight: -11.6 }
      assets/vendor/jquery.ui/themes/base/resizable.css: { weight: -11.6 }
      assets/vendor/jquery.ui/themes/base/controlgroup.css: { weight: -11.7 }
      assets/vendor/jquery.ui/themes/base/core.css: { weight: -11.8 }
    theme:
      assets/vendor/jquery.ui/themes/base/theme.css: { weight: -11.8 }
252
253
254
255
256
257
  dependencies:
    - core/jquery
    - core/drupal
    - core/drupalSettings
    - core/drupal.debounce
    - core/drupal.displace
258
    - core/tabbable.jquery.shim
259
    - core/drupal.jquery.position
260
261
262
263

drupal.dialog.ajax:
  version: VERSION
  js:
264
    misc/dialog/dialog.ajax.js: {}
265
266
267
268
269
270
  dependencies:
    - core/jquery
    - core/drupal
    - core/drupalSettings
    - core/drupal.ajax
    - core/drupal.dialog
271
    - core/tabbable
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292

drupal.displace:
  version: VERSION
  js:
    misc/displace.js: {}
  dependencies:
    - core/jquery
    - core/drupal
    - core/drupal.debounce

drupal.dropbutton:
  version: VERSION
  js:
    misc/dropbutton/dropbutton.js: {}
  css:
    component:
      misc/dropbutton/dropbutton.css: {}
  dependencies:
    - core/jquery
    - core/drupal
    - core/drupalSettings
293
    - core/once
294

295
296
297
298
299
300
301
drupal.element.closest:
  version: VERSION
  js:
    misc/polyfills/element.closest.js: { weight: -20 }
  dependencies:
    - core/drupal.element.matches

302
303
304
305
306
drupal.element.matches:
  version: VERSION
  js:
    misc/polyfills/element.matches.js: { weight: -20 }

307
308
309
310
311
312
313
drupal.entity-form:
  version: VERSION
  js:
    misc/entity-form.js: {}
  dependencies:
    - core/drupal.form

314
315
316
317
318
319
320
321
drupal.form:
  version: VERSION
  js:
    misc/form.js: {}
  dependencies:
    - core/jquery
    - core/drupal
    - core/drupal.debounce
322
    - core/once
323
324
325
326
327
328
329

drupal.machine-name:
  version: VERSION
  js:
    misc/machine-name.js: {}
  dependencies:
    - core/jquery
330
    - core/once
331
332
    - core/drupal
    - core/drupalSettings
333
    - core/drupal.form
334

335
336
337
338
339
340
341
342
drupal.message:
  version: VERSION
  js:
    misc/message.js: {}
  dependencies:
    - core/drupal
    - core/drupal.announce

343
344
345
346
347
drupal.nodelist.foreach:
  version: VERSION
  js:
    misc/polyfills/nodelist.foreach.js: { weight: -20 }

348
349
350
351
352
drupal.object.assign:
  version: VERSION
  js:
    misc/polyfills/object.assign.js: { weight: -20 }

353
354
355
356
357
358
359
360
361
362
363
364
365
366
367
368
369
drupal.progress:
  version: VERSION
  js:
    misc/progress.js: {}
  dependencies:
    - core/drupal
    - core/jquery
    - core/drupalSettings

drupal.states:
  version: VERSION
  js:
    misc/states.js: {}
  dependencies:
    - core/jquery
    - core/drupal
    - core/drupalSettings
370
    - core/once
371
372
373
374
375
376
377
378

drupal.tabbingmanager:
  version: VERSION
  js:
    misc/tabbingmanager.js: {}
  dependencies:
    - core/jquery
    - core/drupal
379
    - core/tabbable
380
381
382
383

drupal.tabledrag:
  version: VERSION
  js:
384
    misc/tabledrag.js: { weight: -1 }
385
386
387
388
  dependencies:
    - core/jquery
    - core/drupal
    - core/drupalSettings
389
    - core/once
390
391
392
393
394
395
396
397
398

drupal.tableheader:
  version: VERSION
  js:
    misc/tableheader.js: {}
  dependencies:
    - core/jquery
    - core/drupal
    - core/drupalSettings
399
    - core/once
400
401
402
403
404
405
406
407
408
    - core/drupal.displace

drupal.tableresponsive:
  version: VERSION
  js:
    misc/tableresponsive.js: {}
  dependencies:
    - core/jquery
    - core/drupal
409
    - core/once
410
411
412
413
414
415
416

drupal.tableselect:
  version: VERSION
  js:
    misc/tableselect.js: {}
  dependencies:
    - core/drupal
417
    - core/drupal.checkbox
418
    - core/jquery
419
    - core/once
420
421
422
423
424
425
426

drupal.timezone:
  version: VERSION
  js:
    misc/timezone.js: {}
  dependencies:
    - core/jquery
427
    - core/once
428
429
430
431
432
433
    - core/drupal

drupal.vertical-tabs:
  version: VERSION
  js:
    # Load before core/drupal.collapse.
434
    misc/vertical-tabs.js: { weight: -1 }
435
436
437
438
439
  css:
    component:
      misc/vertical-tabs.css: {}
  dependencies:
    - core/jquery
440
    - core/once
441
442
443
444
    - core/drupal
    - core/drupalSettings
    - core/drupal.form

445
446
447
448
es6-promise:
  version: "4.2.8"
  license:
    name: MIT
449
    url: https://raw.githubusercontent.com/stefanpenner/es6-promise/v4.2.8/LICENSE
450
451
452
453
    gpl-compatible: true
  js:
    assets/vendor/es6-promise/es6-promise.auto.min.js: { weight: -20, minified: true }

454
455
jquery:
  remote: https://github.com/jquery/jquery
456
  version: "3.6.0"
457
458
  license:
    name: MIT
459
    url: https://raw.githubusercontent.com/jquery/jquery/3.6.0/LICENSE.txt
460
    gpl-compatible: true
461
  js:
462
    assets/vendor/jquery/jquery.min.js: { minified: true, weight: -20 }
463
464

jquery.cookie:
465
  version: VERSION
466
  js:
467
    misc/jquery.cookie.shim.js: {}
468
469
  dependencies:
    - core/jquery
470
471
472
    - core/drupal
    - core/js-cookie
  deprecated: The %library_id% asset library is deprecated in Drupal 9.0.0 and will be removed in Drupal 10.0.0. Use the core/js-cookie library instead. See https://www.drupal.org/node/3104677
473
474
475
476

jquery.farbtastic:
  remote: https://github.com/mattfarina/farbtastic
  # @todo Ping @robloach or @mattfarina to retroactively create this release.
477
  version: "1.2"
478
479
  license:
    name: GNU-GPL-2.0-or-later
480
    url: https://raw.githubusercontent.com/mattfarina/farbtastic/master/LICENSE.txt
481
    gpl-compatible: true
482
  js:
483
    assets/vendor/farbtastic/farbtastic.js: { minified: true }
484
485
486
487
488
489
490
  css:
    component:
      assets/vendor/farbtastic/farbtastic.css: {}
  dependencies:
    - core/jquery

jquery.form:
491
  remote: https://github.com/jquery-form/form
492
  version: "4.3.0"
493
494
  license:
    name: GNU-GPL-2.0-or-later
495
    url: https://raw.githubusercontent.com/jquery-form/form/master/LICENSE
496
    gpl-compatible: true
497
  js:
498
    assets/vendor/jquery-form/jquery.form.min.js: { minified: true }
499
500
501
  dependencies:
    - core/jquery

502
503
jquery.joyride:
  remote: https://github.com/zurb/joyride
504
505
506
507
508
509
  # We rely on a fix (commit c2b3866) that occurred after 2.1.0 was released.
  # @see https://www.drupal.org/node/2898808.
  # @todo Update to 2.1.1 or later when that's released.
  # Version is set at 2.1.0.1 allowing version_compare to consider this lower
  # than 2.1.1 however greater than 2.1.0
  version: "2.1.0.1"
510
511
  license:
    name: MIT
512
    url: https://raw.githubusercontent.com/zurb/joyride/v2.1.0/README.markdown
513
    gpl-compatible: true
514
  js:
515
    assets/vendor/jquery-joyride/jquery.joyride-2.1.js: { }
516
  deprecated: The "%library_id%" asset library is deprecated in drupal:9.2.0 and is removed from drupal:10.0.0. Use the core/shepherd library instead. See https://www.drupal.org/node/3195234
517
518
519
  dependencies:
    - core/jquery

520
521
522
523
524
525
526
527
528
529
shepherd:
  remote: https://github.com/shipshapecode/shepherd
  version: "8.3.1"
  license:
    name: MIT
    url: https://raw.githubusercontent.com/shipshapecode/shepherd/v8.3.1/LICENSE
    gpl-compatible: true
  js:
    assets/vendor/shepherd/shepherd.min.js: { minified: true }

530
531
jquery.once:
  remote: https://github.com/RobLoach/jquery-once
532
  version: "2.2.3"
533
534
  license:
    name: GNU-GPL-2.0-or-later
535
    url: https://raw.githubusercontent.com/RobLoach/jquery-once/2.2.3/LICENSE.md
536
    gpl-compatible: true
537
  js:
538
    assets/vendor/jquery-once/jquery.once.min.js: { weight: -19, minified: true }
539
540
  dependencies:
    - core/jquery
541
    - core/jquery.once.bc
542
  deprecated: The %library_id% asset library is deprecated in Drupal 9.3.0 and will be removed in Drupal 10.0.0. Use the core/once library instead. See https://www.drupal.org/node/3158256
543
544
545
546
547
548
549
550
551

jquery.once.bc:
  version: VERSION
  js:
    misc/jquery.once.bc.js: { weight: -19 }
  dependencies:
    - core/jquery
    - core/once
    - core/drupal.object.assign
552
553

jquery.ui:
554
  version: &jquery_ui_version 1.12.1
555
  license: &jquery_ui_license
556
    name: Public Domain
557
    url: https://raw.githubusercontent.com/jquery/jquery-ui/1.12.1/LICENSE.txt
558
    gpl-compatible: true
559
  js:
560
561
562
563
564
565
566
567
568
569
570
571
572
573
574
    assets/vendor/jquery.ui/ui/labels-min.js: { weight: -11.7, minified: true }
    assets/vendor/jquery.ui/ui/data-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/disable-selection-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/escape-selector-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/focusable-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/form-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/ie-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/jquery-1-7-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/keycode-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/plugin-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/safe-active-element-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/safe-blur-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/scroll-parent-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/unique-id-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/version-min.js: { weight: -11.9, minified: true }
575
576
  css:
    component:
577
      assets/vendor/jquery.ui/themes/base/core.css: { weight: -11.8 }
578
    theme:
579
      assets/vendor/jquery.ui/themes/base/theme.css: { weight: -11.8 }
580
581
  dependencies:
    - core/jquery
582
    - core/tabbable.jquery.shim
583
  deprecated: &jquery_ui_unused_deprecated The "%library_id%" asset library is deprecated in drupal:9.2.0 and is removed from drupal:10.0.0. See https://www.drupal.org/node/3067969
584
585

jquery.ui.autocomplete:
586
587
  version: *jquery_ui_version
  license: *jquery_ui_license
588
  js:
589
    assets/vendor/jquery.ui/ui/widgets/autocomplete-min.js: { weight: -11.7, minified: true }
590
591
  css:
    component:
592
      assets/vendor/jquery.ui/themes/base/autocomplete.css: { weight: -11.7 }
593
594
595
596
597
  dependencies:
    - core/jquery.ui
    - core/jquery.ui.widget
    - core/jquery.ui.position
    - core/jquery.ui.menu
598
  deprecated: *jquery_ui_unused_deprecated
599
600

jquery.ui.button:
601
602
  version: *jquery_ui_version
  license: *jquery_ui_license
603
  js:
604
605
606
    assets/vendor/jquery.ui/ui/widgets/button-min.js: { weight: -11.5, minified: true }
    assets/vendor/jquery.ui/ui/widgets/checkboxradio-min.js: { weight: -11.6, minified: true }
    assets/vendor/jquery.ui/ui/widgets/controlgroup-min.js: { weight: -11.7, minified: true }
607
608
  css:
    component:
609
610
611
      assets/vendor/jquery.ui/themes/base/button.css: { weight: -11.5 }
      assets/vendor/jquery.ui/themes/base/checkboxradio.css: { weight: -11.6 }
      assets/vendor/jquery.ui/themes/base/controlgroup.css: { weight: -11.7 }
612
613
614
  dependencies:
    - core/jquery.ui
    - core/jquery.ui.widget
615
  deprecated: *jquery_ui_unused_deprecated
616

617
jquery.ui.dialog:
618
619
620
  version: *jquery_ui_version
  license: *jquery_ui_license
  js:
621
622
623
624
625
626
627
628
629
630
631
632
633
634
635
636
637
638
639
640
641
642
643
644
645
    # All weights are based on on the requirements defined within each file.
    assets/vendor/jquery.ui/ui/widgets/dialog-min.js: { weight: -11.4, minified: true }
    assets/vendor/jquery.ui/ui/widgets/button-min.js: { weight: -11.5, minified: true }
    assets/vendor/jquery.ui/ui/widgets/checkboxradio-min.js: { weight: -11.6, minified: true }
    assets/vendor/jquery.ui/ui/widgets/draggable-min.js: { weight: -11.6, minified: true }
    assets/vendor/jquery.ui/ui/widgets/resizable-min.js: { weight: -11.6, minified: true }
    assets/vendor/jquery.ui/ui/widgets/controlgroup-min.js: { weight: -11.7, minified: true }
    assets/vendor/jquery.ui/ui/form-reset-mixin-min.js: { weight: -11.7, minified: true }
    assets/vendor/jquery.ui/ui/labels-min.js: { weight: -11.7, minified: true }
    assets/vendor/jquery.ui/ui/widgets/mouse-min.js: { weight: -11.7, minified: true }
    assets/vendor/jquery.ui/ui/data-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/disable-selection-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/escape-selector-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/focusable-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/form-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/ie-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/jquery-1-7-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/keycode-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/plugin-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/safe-active-element-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/safe-blur-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/scroll-parent-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/unique-id-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/widget-min.js: { weight: -11.8, minified: true }
    assets/vendor/jquery.ui/ui/version-min.js: { weight: -11.9, minified: true }
646
647
  css:
    component:
648
649
650
651
652
653
654
655
      assets/vendor/jquery.ui/themes/base/dialog.css: { weight: -11.4 }
      assets/vendor/jquery.ui/themes/base/button.css: { weight: -11.5 }
      assets/vendor/jquery.ui/themes/base/checkboxradio.css: { weight: -11.6 }
      assets/vendor/jquery.ui/themes/base/resizable.css: { weight: -11.6 }
      assets/vendor/jquery.ui/themes/base/controlgroup.css: { weight: -11.7 }
      assets/vendor/jquery.ui/themes/base/core.css: { weight: -11.8 }
    theme:
      assets/vendor/jquery.ui/themes/base/theme.css: { weight: -11.8 }
656
657
  dependencies:
    - core/jquery
658
    - core/tabbable.jquery.shim
659
    - core/drupal.jquery.position
660
  deprecated: *jquery_ui_unused_deprecated
661
662

jquery.ui.draggable:
663
664
  version: *jquery_ui_version
  license: *jquery_ui_license
665
  js:
666
    assets/vendor/jquery.ui/ui/widgets/draggable-min.js: { minified: true }
667
668
669
670
  dependencies:
    - core/jquery.ui
    - core/jquery.ui.mouse
    - core/jquery.ui.widget
671
  deprecated: *jquery_ui_unused_deprecated
672
673

jquery.ui.menu:
674
675
  version: *jquery_ui_version
  license: *jquery_ui_license
676
  js:
677
    assets/vendor/jquery.ui/ui/widgets/menu-min.js: { weight: -11.7, minified: true }
678
679
  css:
    component:
680
      assets/vendor/jquery.ui/themes/base/menu.css: { weight: -11.7 }
681
682
  dependencies:
    - core/jquery.ui
683
    - core/jquery.ui.position
684
    - core/jquery.ui.widget
685
  deprecated: *jquery_ui_unused_deprecated
686
687

jquery.ui.mouse:
688
689
  version: *jquery_ui_version
  license: *jquery_ui_license
690
  js:
691
692
    assets/vendor/jquery.ui/ui/widgets/mouse-min.js: { weight: -11.7, minified: true }
    assets/vendor/jquery.ui/ui/ie-min.js: { weight: -11.8, minified: true }
693
694
  dependencies:
    - core/jquery.ui.widget
695
  deprecated: *jquery_ui_unused_deprecated
696

697
698
699
700
701
702
703
704
705
706
707
708
drupal.jquery.position:
  # For most positioning needs, the core/popperjs library should be used. This
  # is a modified version of jQuery UI position for that does not require any
  # jQuery UI assets, only jQuery. It is provided by core for use with
  # pre-existing libraries that expect the jQuery UI position API. Popperjs is
  # recommended for any new uses.
  version: VERSION
  js:
    misc/position.js: {}
  dependencies:
    - core/jquery

709
jquery.ui.position:
710
711
  version: *jquery_ui_version
  license: *jquery_ui_license
712
  dependencies:
713
    - core/drupal.jquery.position
714
  deprecated: *jquery_ui_unused_deprecated
715
716

jquery.ui.resizable:
717
718
  version: *jquery_ui_version
  license: *jquery_ui_license
719
  js:
720
    assets/vendor/jquery.ui/ui/widgets/resizable-min.js: { weight: -11.6, minified: true }
721
722
  css:
    component:
723
      assets/vendor/jquery.ui/themes/base/resizable.css: { weight: -11.6 }
724
725
726
727
  dependencies:
    - core/jquery.ui
    - core/jquery.ui.widget
    - core/jquery.ui.mouse
728
  deprecated: *jquery_ui_unused_deprecated
729
730

jquery.ui.widget:
731
732
  version: *jquery_ui_version
  license: *jquery_ui_license
733
  js:
734
    assets/vendor/jquery.ui/ui/widget-min.js: { weight: -11.8, minified: true }
735
736
  dependencies:
    - core/jquery.ui
737
  deprecated: *jquery_ui_unused_deprecated
738
739

modernizr:
740
741
  # Block the page from being loaded until Modernizr is initialized.
  header: true
742
  remote: https://github.com/Modernizr/Modernizr
743
744
  license:
    name: MIT
745
    url: https://modernizr.com/license/
746
    gpl-compatible: true
747
  version: "3.11.7"
748
  js:
749
    assets/vendor/modernizr/modernizr.min.js: { preprocess: 0, weight: -21, minified: true }
750
    misc/modernizr-additional-tests.js: { preprocess: 0, weight: -20 }
751
752
753

normalize:
  remote: https://github.com/necolas/normalize.css
754
  version: "8.0.1"
755
756
  license:
    name: MIT
757
    url: https://raw.githubusercontent.com/necolas/normalize.css/8.0.1/LICENSE.md
758
    gpl-compatible: true
759
760
  css:
    base:
761
      assets/vendor/normalize-css/normalize.css: { weight: -20 }
762
      misc/normalize-fixes.css: { weight: -19 }
763

764
765
once:
  remote: https://git.drupalcode.org/project/once
766
  version: "1.0.1"
767
768
  license:
    name: GNU-GPL-2.0-or-later
769
    url: https://git.drupalcode.org/project/once/-/raw/v1.0.1/LICENSE.md
770
771
772
773
774
775
    gpl-compatible: true
  js:
    assets/vendor/once/once.min.js: { weight: -19, minified: true }
  dependencies:
    - core/drupal.element.matches

776
777
picturefill:
  remote: https://github.com/scottjehl/picturefill
778
  version: "3.0.3"
779
780
  license:
    name: MIT
781
    url: https://raw.githubusercontent.com/scottjehl/picturefill/3.0.3/LICENSE
782
    gpl-compatible: true
783
  js:
784
    assets/vendor/picturefill/picturefill.min.js: { weight: -10, minified: true }
785

786
popperjs:
787
  version: "2.9.2"
788
789
  license:
    name: MIT
790
    url: https://raw.githubusercontent.com/popperjs/popper-core/v2.9.2/LICENSE.md
791
792
793
    gpl-compatible: true
  js:
    assets/vendor/popperjs/popper.min.js: { minified: true }
794
795
796
797
  dependencies:
    - core/drupal.array.find
    - core/es6-promise
    - core/drupal.object.assign
798

799
800
sortable:
  remote: https://github.com/SortableJS/Sortable
801
  version: "1.13.0"
802
803
  license:
    name: MIT
804
    url: https://raw.githubusercontent.com/SortableJS/Sortable/1.13.0/LICENSE
805
806
807
808
    gpl-compatible: true
  js:
    assets/vendor/sortable/Sortable.min.js: { minified: true }

809
810
tabbable:
  remote: https://github.com/focus-trap/tabbable
811
  version: "5.2.0"
812
813
  license:
    name: MIT
814
    url: https://raw.githubusercontent.com/focus-trap/tabbable/v5.2.0/LICENSE
815
816
817
818
819
820
821
822
823
824
825
    gpl-compatible: true
  js:
    assets/vendor/tabbable/index.umd.min.js: { weight: -1, minified: true }
  dependencies:
    - core/css.escape

tabbable.jquery.shim:
  version: VERSION
  js:
    misc/jquery.tabbable.shim.js: {}
  dependencies:
826
    - core/drupal
827
828
829
    - core/tabbable
    - core/jquery

830
831
underscore:
  remote: https://github.com/jashkenas/underscore
832
  version: "1.13.1"
833
834
  license:
    name: MIT
835
    url: https://raw.githubusercontent.com/jashkenas/underscore/1.13.1/LICENSE
836
    gpl-compatible: true
837
  js:
838
    assets/vendor/underscore/underscore-min.js: { weight: -20, minified: true }
839
840
841
842
843
844
845
846
847
848
849
850
851
852
853
854
855
856
857
858
859

drupal.dialog.off_canvas:
  version: VERSION
  js:
    misc/dialog/off-canvas.js: {}
  css:
    base:
      misc/dialog/off-canvas.reset.css: {}
      misc/dialog/off-canvas.base.css: {}
      misc/dialog/off-canvas.css: {}
      # Add group setting to make sure this CSS load before any jQuery UI Dialog
      # CSS.
      misc/dialog/off-canvas.theme.css: { group: 200 }
    component:
      misc/dialog/off-canvas.motion.css: {}
      misc/dialog/off-canvas.button.css: {}
      misc/dialog/off-canvas.form.css: {}
      misc/dialog/off-canvas.table.css: {}
      misc/dialog/off-canvas.details.css: {}
      misc/dialog/off-canvas.tabledrag.css: {}
      misc/dialog/off-canvas.dropbutton.css: {}
860
      misc/dialog/off-canvas.layout.css: {}
861
862
  dependencies:
    - core/jquery
863
    - core/once
864
865
866
867
868
    - core/drupal
    - core/drupal.ajax
    - core/drupal.announce
    - core/drupal.dialog
    - core/drupal.dialog.ajax
869
870
871

js-cookie:
  remote: https://github.com/js-cookie/js-cookie
872
  version: "3.0.0-rc.0"
873
874
  license:
    name: MIT
875
    url: https://raw.githubusercontent.com/js-cookie/js-cookie/v3.0.0-rc.0/LICENSE
876
877
878
    gpl-compatible: true
  js:
    assets/vendor/js-cookie/js.cookie.min.js: {}