system.install 38.3 KB
Newer Older
Dries's avatar
 
Dries committed
1
<?php
2

3 4 5 6
/**
 * @file
 * Install, update and uninstall functions for the system module.
 */
7

8
use Drupal\Component\Utility\Crypt;
9
use Drupal\Component\Utility\Environment;
10
use Drupal\Component\Utility\SafeMarkup;
11
use Drupal\Core\Url;
12 13
use Drupal\Core\Database\Database;
use Drupal\Core\Language\Language;
14
use Drupal\Core\Site\Settings;
15
use Drupal\Core\StreamWrapper\PublicStream;
16

17
/**
18
 * Implements hook_requirements().
19 20 21 22 23 24 25
 */
function system_requirements($phase) {
  $requirements = array();

  // Report Drupal version
  if ($phase == 'runtime') {
    $requirements['drupal'] = array(
26
      'title' => t('Drupal'),
27
      'value' => \Drupal::VERSION,
Steven Wittens's avatar
Steven Wittens committed
28 29
      'severity' => REQUIREMENT_INFO,
      'weight' => -10,
30
    );
31

32 33
    // Display the currently active installation profile, if the site
    // is not running the default installation profile.
34
    $profile = drupal_get_profile();
35
    if ($profile != 'standard') {
36
      $info = system_get_info('module', $profile);
37
      $requirements['install_profile'] = array(
38 39
        'title' => t('Installation profile'),
        'value' => t('%profile_name (%profile-%version)', array(
40 41 42 43 44 45 46
          '%profile_name' => $info['name'],
          '%profile' => $profile,
          '%version' => $info['version']
        )),
        'severity' => REQUIREMENT_INFO,
        'weight' => -9
      );
47
    }
48 49
  }

50
  // Web server information.
51
  $software = \Drupal::request()->server->get('SERVER_SOFTWARE');
52
  $requirements['webserver'] = array(
53
    'title' => t('Web server'),
Steven Wittens's avatar
Steven Wittens committed
54
    'value' => $software,
55 56
  );

57 58 59 60
  // Test PHP version and show link to phpinfo() if it's available
  $phpversion = phpversion();
  if (function_exists('phpinfo')) {
    $requirements['php'] = array(
61
      'title' => t('PHP'),
62
      // $phpversion is safe and output of l() is safe, so this value is safe.
63
      'value' => SafeMarkup::set(($phase == 'runtime') ? $phpversion . ' (' . \Drupal::l(t('more information'), new Url('system.php')) . ')' : $phpversion),
64 65 66 67
    );
  }
  else {
    $requirements['php'] = array(
68
      'title' => t('PHP'),
69
      'value' => $phpversion,
70
      'description' => t('The phpinfo() function has been disabled for security reasons. To see your server\'s phpinfo() information, change your PHP settings or contact your server administrator. For more information, <a href="@phpinfo">Enabling and disabling phpinfo()</a> handbook page.', array('@phpinfo' => 'http://drupal.org/node/243993')),
71 72 73 74
      'severity' => REQUIREMENT_INFO,
    );
  }

75
  if (version_compare($phpversion, DRUPAL_MINIMUM_PHP) < 0) {
76
    $requirements['php']['description'] = t('Your PHP installation is too old. Drupal requires at least PHP %version.', array('%version' => DRUPAL_MINIMUM_PHP));
77
    $requirements['php']['severity'] = REQUIREMENT_ERROR;
78 79
    // If PHP is old, it's not safe to continue with the requirements check.
    return $requirements;
80
  }
81

82 83
  // Test for PHP extensions.
  $requirements['php_extensions'] = array(
84
    'title' => t('PHP extensions'),
85
  );
86 87 88 89 90 91 92 93 94 95 96 97 98 99

  $missing_extensions = array();
  $required_extensions = array(
    'date',
    'dom',
    'filter',
    'gd',
    'hash',
    'json',
    'pcre',
    'pdo',
    'session',
    'SimpleXML',
    'SPL',
100
    'tokenizer',
101 102 103 104 105 106 107 108 109
    'xml',
  );
  foreach ($required_extensions as $extension) {
    if (!extension_loaded($extension)) {
      $missing_extensions[] = $extension;
    }
  }

  if (!empty($missing_extensions)) {
110
    $description = t('Drupal requires you to enable the PHP extensions in the following list (see the <a href="@system_requirements">system requirements page</a> for more information):', array(
111 112 113
      '@system_requirements' => 'http://drupal.org/requirements',
    ));

114 115 116 117 118 119 120 121 122 123 124
    // We use twig inline_template to avoid twig's autoescape.
    $description = array(
      '#type' => 'inline_template',
      '#template' => '{{ description }}{{ missing_extensions }}',
      '#context' => array(
        'description' => $description,
        'missing_extensions' => array(
          '#theme' => 'item_list',
          '#items' => $missing_extensions,
        ),
      ),
125
    );
126

127
    $requirements['php_extensions']['value'] = t('Disabled');
128 129
    $requirements['php_extensions']['severity'] = REQUIREMENT_ERROR;
    $requirements['php_extensions']['description'] = $description;
130 131
  }
  else {
132
    $requirements['php_extensions']['value'] = t('Enabled');
133
  }
134

135 136 137
  if ($phase == 'install' || $phase == 'update') {
    // Test for PDO (database).
    $requirements['database_extensions'] = array(
138
      'title' => t('Database support'),
139
    );
140

141
    // Make sure PDO is available.
142
    $database_ok = extension_loaded('pdo');
143
    if (!$database_ok) {
144
      $pdo_message = t('Your web server does not appear to support PDO (PHP Data Objects). Ask your hosting provider if they support the native PDO extension. See the <a href="@link">system requirements</a> page for more information.', array(
145 146 147 148 149
        '@link' => 'http://drupal.org/requirements/pdo',
      ));
    }
    else {
      // Make sure at least one supported database driver exists.
150
      $drivers = drupal_detect_database_types();
151 152
      if (empty($drivers)) {
        $database_ok = FALSE;
153
        $pdo_message = t('Your web server does not appear to support any common PDO database extensions. Check with your hosting provider to see if they support PDO (PHP Data Objects) and offer any databases that <a href="@drupal-databases">Drupal supports</a>.', array(
154 155 156 157 158 159 160
          '@drupal-databases' => 'http://drupal.org/node/270#database',
        ));
      }
      // Make sure the native PDO extension is available, not the older PEAR
      // version. (See install_verify_pdo() for details.)
      if (!defined('PDO::ATTR_DEFAULT_FETCH_MODE')) {
        $database_ok = FALSE;
161
        $pdo_message = t('Your web server seems to have the wrong version of PDO installed. Drupal requires the PDO extension from PHP core. This system has the older PECL version. See the <a href="@link">system requirements</a> page for more information.', array(
162 163 164
          '@link' => 'http://drupal.org/requirements/pdo#pecl',
        ));
      }
165
    }
166

167
    if (!$database_ok) {
168
      $requirements['database_extensions']['value'] = t('Disabled');
169
      $requirements['database_extensions']['severity'] = REQUIREMENT_ERROR;
170
      $requirements['database_extensions']['description'] = $pdo_message;
171 172
    }
    else {
173
      $requirements['database_extensions']['value'] = t('Enabled');
174
    }
175
  }
176 177
  else {
    // Database information.
178
    $class = Database::getConnection()->getDriverClass('Install\\Tasks');
179 180
    $tasks = new $class();
    $requirements['database_system'] = array(
181
      'title' => t('Database system'),
182 183 184
      'value' => $tasks->name(),
    );
    $requirements['database_system_version'] = array(
185
      'title' => t('Database system version'),
186 187 188
      'value' => Database::getConnection()->version(),
    );
  }
189

190
  // Test PHP memory_limit
191
  $memory_limit = ini_get('memory_limit');
192
  $requirements['php_memory_limit'] = array(
193
    'title' => t('PHP memory limit'),
194
    'value' => $memory_limit == -1 ? t('-1 (Unlimited)') : $memory_limit,
195
  );
196

197
  if (!Environment::checkMemoryLimit(DRUPAL_MINIMUM_PHP_MEMORY_LIMIT, $memory_limit)) {
198
    $description = array();
199
    if ($phase == 'install') {
200
      $description['phase'] = t('Consider increasing your PHP memory limit to %memory_minimum_limit to help prevent errors in the installation process.', array('%memory_minimum_limit' => DRUPAL_MINIMUM_PHP_MEMORY_LIMIT));
201 202
    }
    elseif ($phase == 'update') {
203
      $description['phase'] = t('Consider increasing your PHP memory limit to %memory_minimum_limit to help prevent errors in the update process.', array('%memory_minimum_limit' => DRUPAL_MINIMUM_PHP_MEMORY_LIMIT));
204
    }
205
    elseif ($phase == 'runtime') {
206
      $description['phase'] = t('Depending on your configuration, Drupal can run with a %memory_limit PHP memory limit. However, a %memory_minimum_limit PHP memory limit or above is recommended, especially if your site uses additional custom or contributed modules.', array('%memory_limit' => $memory_limit, '%memory_minimum_limit' => DRUPAL_MINIMUM_PHP_MEMORY_LIMIT));
207
    }
208

209
    if (!empty($description['phase'])) {
210
      if ($php_ini_path = get_cfg_var('cfg_file_path')) {
211
        $description['memory'] = t('Increase the memory limit by editing the memory_limit parameter in the file %configuration-file and then restart your web server (or contact your system administrator or hosting provider for assistance).', array('%configuration-file' => $php_ini_path));
212 213
      }
      else {
214
        $description['memory'] = t('Contact your system administrator or hosting provider for assistance with increasing your PHP memory limit.');
215
      }
216

217 218 219 220 221 222 223 224 225 226 227 228 229
      $handbook_link = t('For more information, see the online handbook entry for <a href="@memory-limit">increasing the PHP memory limit</a>.', array('@memory-limit' => 'http://drupal.org/node/207036'));

      $description = array(
        '#type' => 'inline_template',
        '#template' => '{{ description_phase }} {{ description_memory }} {{ handbook }}',
        '#context' => array(
          'description_phase' => $description['phase'],
          'description_memory' => $description['memory'],
          'handbook' => $handbook_link,
        ),
      );

      $requirements['php_memory_limit']['description'] = $description;
230
      $requirements['php_memory_limit']['severity'] = REQUIREMENT_WARNING;
231
    }
232
  }
233

234
  // Test configuration files and directory for writability.
235
  if ($phase == 'runtime') {
236 237 238
    $conf_errors = array();
    $conf_path = conf_path();
    if (!drupal_verify_install_file($conf_path, FILE_NOT_WRITABLE, 'dir')) {
239
      $conf_errors[] = t("The directory %file is not protected from modifications and poses a security risk. You must change the directory's permissions to be non-writable.", array('%file' => $conf_path));
240
    }
241
    foreach (array('settings.php', 'settings.local.php', 'services.yml') as $conf_file) {
242 243
      $full_path = $conf_path . '/' . $conf_file;
      if (file_exists($full_path) && !drupal_verify_install_file($full_path, FILE_EXIST|FILE_READABLE|FILE_NOT_WRITABLE)) {
244
        $conf_errors[] = t("The file %file is not protected from modifications and poses a security risk. You must change the file's permissions to be non-writable.", array('%file' => $full_path));
245 246 247 248 249 250 251
      }
    }
    if (!empty($conf_errors)) {
      if (count($conf_errors) == 1) {
        $description = $conf_errors[0];
      }
      else {
252 253 254 255 256 257 258 259 260 261
        // We use twig inline_template to avoid double escaping.
        $description = array(
          '#type' => 'inline_template',
          '#template' => '{{ configuration_error_list }}',
          '#context' => array(
            'configuration_error_list' => array(
              '#theme' => 'item_list',
              '#items' => $conf_errors,
            ),
          ),
262
        );
263
      }
264
      $requirements['configuration_files'] = array(
265
        'value' => t('Not protected'),
266
        'severity' => REQUIREMENT_ERROR,
267
        'description' => $description,
268 269 270
      );
    }
    else {
271
      $requirements['configuration_files'] = array(
272
        'value' => t('Protected'),
273 274
      );
    }
275
    $requirements['configuration_files']['title'] = t('Configuration files');
276 277
  }

278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310
  // Test the contents of the .htaccess files.
  if ($phase == 'runtime') {
    // Try to write the .htaccess files first, to prevent false alarms in case
    // (for example) the /tmp directory was wiped.
    file_ensure_htaccess();
    $htaccess_files['public://.htaccess'] = array(
      'title' => t('Public files directory'),
      'directory' => drupal_realpath('public://'),
    );
    if (\Drupal::config('system.file')->get('path.private')) {
      $htaccess_files['private://.htaccess'] = array(
        'title' => t('Private files directory'),
        'directory' => drupal_realpath('private://'),
      );
    }
    $htaccess_files['temporary://.htaccess'] = array(
      'title' => t('Temporary files directory'),
      'directory' => drupal_realpath('temporary://'),
    );
    foreach ($htaccess_files as $htaccess_file => $info) {
      // Check for the string which was added to the recommended .htaccess file
      // in the latest security update.
      if (!file_exists($htaccess_file) || !($contents = @file_get_contents($htaccess_file)) || strpos($contents, 'Drupal_Security_Do_Not_Remove_See_SA_2013_003') === FALSE) {
        $requirements[$htaccess_file] = array(
          'title' => $info['title'],
          'value' => t('Not fully protected'),
          'severity' => REQUIREMENT_ERROR,
          'description' => t('See <a href="@url">@url</a> for information about the recommended .htaccess file which should be added to the %directory directory to help protect against arbitrary code execution.', array('@url' => 'http://drupal.org/SA-CORE-2013-003', '%directory' => $info['directory'])),
        );
      }
    }
  }

311
  // Report cron status.
312
  if ($phase == 'runtime') {
313
    $cron_config = \Drupal::config('system.cron');
314
    // Cron warning threshold defaults to two days.
315
    $threshold_warning = $cron_config->get('threshold.requirements_warning');
316
    // Cron error threshold defaults to two weeks.
317
    $threshold_error = $cron_config->get('threshold.requirements_error');
318
    // Cron configuration help text.
319
    $help = t('For more information, see the online handbook entry for <a href="@cron-handbook">configuring cron jobs</a>.', array('@cron-handbook' => 'http://drupal.org/cron'));
320

321
    // Determine when cron last ran.
322
    $cron_last = \Drupal::state()->get('system.cron_last');
323
    if (!is_numeric($cron_last)) {
324
      $cron_last = \Drupal::state()->get('install_time', 0);
325
    }
326

327
    // Determine severity based on time since cron last ran.
328
    $severity = REQUIREMENT_INFO;
329
    if (REQUEST_TIME - $cron_last > $threshold_error) {
330
      $severity = REQUIREMENT_ERROR;
331
    }
332
    elseif (REQUEST_TIME - $cron_last > $threshold_warning) {
333 334 335 336
      $severity = REQUIREMENT_WARNING;
    }

    // Set summary and description based on values determined above.
337
    $summary = t('Last run !time ago', array('!time' => \Drupal::service('date.formatter')->formatInterval(REQUEST_TIME - $cron_last)));
338
    $description = '';
339
    if ($severity != REQUIREMENT_INFO) {
340
      $description = t('Cron has not run recently.') . ' ' . $help;
341
    }
342

343 344
    $description .= ' ' . t('You can <a href="@cron">run cron manually</a>.', array('@cron' => \Drupal::url('system.run_cron')));
    $description .= '<br />' . t('To run cron from outside the site, go to <a href="!cron">!cron</a>', array('!cron' => \Drupal::url('system.cron', array('key' => \Drupal::state()->get('system.cron_key'), array('absolute' => TRUE)))));
345

346
    $requirements['cron'] = array(
347
      'title' => t('Cron maintenance tasks'),
348 349
      'severity' => $severity,
      'value' => $summary,
350 351 352 353 354
      // @todo This string is concatenated from t() calls, safe drupal_render()
      //   output, whitespace, and <br /> tags, so is safe. However, as a best
      //   practice, we should not use SafeMarkup::set() around a variable. Fix
      //   in: https://www.drupal.org/node/2296929
      'description' => SafeMarkup::set($description),
355
    );
356
  }
357
  if ($phase != 'install') {
358
    $filesystem_config = \Drupal::config('system.file');
359
    $directories = array(
360
      PublicStream::basePath(),
361 362 363 364 365 366
      // By default no private files directory is configured. For private files
      // to be secure the admin needs to provide a path outside the webroot.
      $filesystem_config->get('path.private'),
      file_directory_temp(),
    );
  }
367

368 369
  // During an install we need to make assumptions about the file system
  // unless overrides are provided in settings.php.
370
  if ($phase == 'install') {
371
    $directories = array();
372
    if ($file_public_path = Settings::get('file_public_path')) {
373
      $directories[] = $file_public_path;
374 375 376
    }
    else {
      // If we are installing Drupal, the settings.php file might not exist yet
377 378
      // in the intended site directory, so don't require it.
      $directories[] = conf_path(FALSE) . '/files';
379
    }
380 381
    if (!empty($GLOBALS['config']['system.file']['path']['private'])) {
      $directories[] = $GLOBALS['config']['system.file']['path']['private'];
382
    }
383 384
    if (!empty($GLOBALS['config']['system.file']['path']['temporary'])) {
      $directories[] = $GLOBALS['config']['system.file']['path']['temporary'];
385 386 387 388 389 390
    }
    else {
      // If the temporary directory is not overridden use an appropriate
      // temporary path for the system.
      $directories[] = file_directory_os_temp();
    }
391 392
  }

393 394 395
  // Check the config directory if it is defined in settings.php. If it isn't
  // defined, the installer will create a valid config directory later, but
  // during runtime we must always display an error.
396
  if (!empty($GLOBALS['config_directories'])) {
397 398 399
    foreach ($GLOBALS['config_directories'] as $type => $directory) {
      $directories[] = config_get_config_directory($type);
    }
400 401
  }
  elseif ($phase != 'install') {
402
    $requirements['config directories'] = array(
403 404 405
      'title' => t('Configuration directories'),
      'value' => t('Not present'),
      'description' => t('Your %file file must define the $config_directories variable as an array containing the name of a directories in which configuration files can be written.', array('%file' => conf_path() . '/settings.php')),
406 407 408 409
      'severity' => REQUIREMENT_ERROR,
    );
  }

410
  $requirements['file system'] = array(
411
    'title' => t('File system'),
412
  );
413

414 415 416
  $error = '';
  // For installer, create the directories if possible.
  foreach ($directories as $directory) {
417 418 419
    if (!$directory) {
      continue;
    }
420
    if ($phase == 'install') {
421
      file_prepare_directory($directory, FILE_CREATE_DIRECTORY | FILE_MODIFY_PERMISSIONS);
422
    }
423 424 425 426
    $is_writable = is_writable($directory);
    $is_directory = is_dir($directory);
    if (!$is_writable || !$is_directory) {
      $description = '';
427
      $requirements['file system']['value'] = t('Not writable');
428
      if (!$is_directory) {
429
        $error = t('The directory %directory does not exist.', array('%directory' => $directory));
430 431
      }
      else {
432
        $error = t('The directory %directory is not writable.', array('%directory' => $directory));
433 434 435
      }
      // The files directory requirement check is done only during install and runtime.
      if ($phase == 'runtime') {
436
        $description = t('You may need to set the correct directory at the <a href="@admin-file-system">file system settings page</a> or change the current directory\'s permissions so that it is writable.', array('@admin-file-system' => \Drupal::url('system.file_system_settings')));
437 438 439 440
      }
      elseif ($phase == 'install') {
        // For the installer UI, we need different wording. 'value' will
        // be treated as version, so provide none there.
441
        $description = t('An automated attempt to create this directory failed, possibly due to a permissions problem. To proceed with the installation, either create the directory and modify its permissions manually or ensure that the installer has the permissions to create it automatically. For more information, see INSTALL.txt or the <a href="@handbook_url">online handbook</a>.', array('@handbook_url' => 'http://drupal.org/server-permissions'));
442 443 444
        $requirements['file system']['value'] = '';
      }
      if (!empty($description)) {
445 446 447 448 449 450 451 452
        $description = array(
          '#type' => 'inline_template',
          '#template' => '{{ error }} {{ description }}',
          '#context' => array(
            'error' => $error,
            'description' => $description,
          ),
        );
453 454 455
        $requirements['file system']['description'] = $description;
        $requirements['file system']['severity'] = REQUIREMENT_ERROR;
      }
456 457
    }
    else {
458 459 460
      // This function can be called before the config_cache table has been
      // created.
      if ($phase == 'install' || file_default_scheme() == 'public') {
461
        $requirements['file system']['value'] = t('Writable (<em>public</em> download method)');
462 463
      }
      else {
464
        $requirements['file system']['value'] = t('Writable (<em>private</em> download method)');
465
      }
466 467 468
    }
  }

469 470 471
  // See if updates are available in update.php.
  if ($phase == 'runtime') {
    $requirements['update'] = array(
472 473
      'title' => t('Database updates'),
      'value' => t('Up to date'),
474 475 476
    );

    // Check installed modules.
477
    foreach (\Drupal::moduleHandler()->getModuleList() as $module => $filename) {
478 479 480 481 482
      $updates = drupal_get_schema_versions($module);
      if ($updates !== FALSE) {
        $default = drupal_get_installed_schema_version($module);
        if (max($updates) > $default) {
          $requirements['update']['severity'] = REQUIREMENT_ERROR;
483
          $requirements['update']['value'] = t('Out of date');
484
          $requirements['update']['description'] = t('Some modules have database schema updates to install. You should run the <a href="@update">database update script</a> immediately.', array('@update' => \Drupal::url('system.db_update')));
485 486 487 488
          break;
        }
      }
    }
489 490 491
    if (!isset($requirements['update']['severity']) && \Drupal::service('entity.definition_update_manager')->needsUpdates()) {
      $requirements['update']['severity'] = REQUIREMENT_ERROR;
      $requirements['update']['value'] = t('Out of date');
492
      $requirements['update']['description'] = t('Some modules have database schema updates to install. You should run the <a href="@update">database update script</a> immediately.', array('@update' => \Drupal::url('system.db_update')));
493
    }
494 495
  }

496 497
  // Verify the update.php access setting
  if ($phase == 'runtime') {
498
    if (Settings::get('update_free_access')) {
499
      $requirements['update access'] = array(
500
        'value' => t('Not protected'),
501
        'severity' => REQUIREMENT_ERROR,
502
        'description' => t('The update.php script is accessible to everyone without authentication check, which is a security risk. You must change the @settings_name value in your settings.php back to FALSE.', array('@settings_name' => '$settings[\'update_free_access\']')),
503 504 505 506
      );
    }
    else {
      $requirements['update access'] = array(
507
        'value' => t('Protected'),
508 509
      );
    }
510
    $requirements['update access']['title'] = t('Access to update.php');
511 512
  }

513 514
  // Display an error if a newly introduced dependency in a module is not resolved.
  if ($phase == 'update') {
515
    $profile = drupal_get_profile();
516 517
    $files = system_rebuild_module_data();
    foreach ($files as $module => $file) {
518
      // Ignore disabled modules and installation profiles.
519
      if (!$file->status || $module == $profile) {
520 521 522 523 524 525
        continue;
      }
      // Check the module's PHP version.
      $name = $file->info['name'];
      $php = $file->info['php'];
      if (version_compare($php, PHP_VERSION, '>')) {
526
        $requirements['php']['description'] .= t('@name requires at least PHP @version.', array('@name' => $name, '@version' => $php));
527 528 529 530 531 532 533 534
        $requirements['php']['severity'] = REQUIREMENT_ERROR;
      }
      // Check the module's required modules.
      foreach ($file->requires as $requirement) {
        $required_module = $requirement['name'];
        // Check if the module exists.
        if (!isset($files[$required_module])) {
          $requirements["$module-$required_module"] = array(
535 536
            'title' => t('Unresolved dependency'),
            'description' => t('@name requires this module.', array('@name' => $name)),
537 538 539 540 541 542 543 544
            'value' => t('@required_name (Missing)', array('@required_name' => $required_module)),
            'severity' => REQUIREMENT_ERROR,
          );
          continue;
        }
        // Check for an incompatible version.
        $required_file = $files[$required_module];
        $required_name = $required_file->info['name'];
545
        $version = str_replace(\Drupal::CORE_COMPATIBILITY . '-', '', $required_file->info['version']);
546 547 548 549
        $compatibility = drupal_check_incompatibility($requirement, $version);
        if ($compatibility) {
          $compatibility = rtrim(substr($compatibility, 2), ')');
          $requirements["$module-$required_module"] = array(
550 551
            'title' => t('Unresolved dependency'),
            'description' => t('@name requires this module and version. Currently using @required_name version @version', array('@name' => $name, '@required_name' => $required_name, '@version' => $version)),
552 553 554 555 556 557 558 559 560
            'value' => t('@required_name (Version @compatibility required)', array('@required_name' => $required_name, '@compatibility' => $compatibility)),
            'severity' => REQUIREMENT_ERROR,
          );
          continue;
        }
      }
    }
  }

561
  // Test Unicode library
562
  include_once DRUPAL_ROOT . '/core/includes/unicode.inc';
563 564
  $requirements = array_merge($requirements, unicode_requirements());

565
  if ($phase == 'runtime') {
566
    // Check for update status module.
567
    if (!\Drupal::moduleHandler()->moduleExists('update')) {
568
      $requirements['update status'] = array(
569
        'value' => t('Not enabled'),
570
        'severity' => REQUIREMENT_WARNING,
571 572 573 574
        'description' => t('Update notifications are not enabled. It is <strong>highly recommended</strong> that you enable the Update Manager module from the <a href="@module">module administration page</a> in order to stay up-to-date on new releases. For more information, <a href="@update">Update status handbook page</a>.', array(
          '@update' => 'http://drupal.org/documentation/modules/update',
          '@module' => \Drupal::url('system.modules_list'),
        )),
575 576 577 578
      );
    }
    else {
      $requirements['update status'] = array(
579
        'value' => t('Enabled'),
580 581
      );
    }
582
    $requirements['update status']['title'] = t('Update notifications');
583

584
    if (Settings::get('rebuild_access')) {
585 586 587 588 589 590 591
      $requirements['rebuild access'] = array(
        'title' => t('Rebuild access'),
        'value' => t('Enabled'),
        'severity' => REQUIREMENT_ERROR,
        'description' => t('The rebuild_access setting is enabled in settings.php. It is recommended to have this setting disabled unless you are performing a rebuild.'),
      );
    }
592 593
  }

594 595 596 597 598 599 600 601 602 603 604 605 606 607 608 609 610 611 612
  // Ensure that if upgrading from 7 to 8 we have no disabled modules.
  if ($phase == 'update' && db_table_exists('system')) {
    $modules = db_query('SELECT name, info FROM {system} WHERE type = :module AND status = 0 AND schema_version <> :schema_uninstalled', array(
      ':module' => 'module',
      ':schema_uninstalled' => SCHEMA_UNINSTALLED,
    ))->fetchAllKeyed(0, 1);
    array_walk($modules, function (&$value, $key) {
      $info = unserialize($value);
      $value = $info['name'];
    });
    if (!empty($modules)) {
      $requirements['disabled_modules'] = array(
        'severity' => REQUIREMENT_ERROR,
        'title' => t('Disabled modules'),
        'value' => format_plural(count($modules), 'The %modules module is disabled.', 'The following modules are disabled: %modules', array('%modules' => implode(', ', $modules))),
        'description' => t('Drupal 8 no longer supports disabled modules. Please either enable or uninstall them before upgrading.'),
      );
    }
  }
613 614 615
  return $requirements;
}

616
/**
617
 * Implements hook_install().
618
 */
619
function system_install() {
620
  // Populate the cron key state variable.
621
  $cron_key = Crypt::randomBytesBase64(55);
622
  \Drupal::state()->set('system.cron_key', $cron_key);
623 624 625 626 627

  // Populate the site UUID.
  \Drupal::config('system.site')
    ->set('uuid', \Drupal::service('uuid')->generate())
    ->save();
628 629
}

630
/**
631
 * Implements hook_schema().
632 633 634
 */
function system_schema() {
  $schema['batch'] = array(
635
    'description' => 'Stores details about batches (processes that run in multiple HTTP requests).',
636
    'fields' => array(
637
      'bid' => array(
638
        'description' => 'Primary Key: Unique batch ID.',
639 640 641
        // This is not a serial column, to allow both progressive and
        // non-progressive batches. See batch_process().
        'type' => 'int',
642
        'unsigned' => TRUE,
643 644
        'not null' => TRUE,
      ),
645
      'token' => array(
646
        'description' => "A string token generated against the current user's session id and the batch id, used to ensure that only the user who submitted the batch can effectively access it.",
647 648
        'type' => 'varchar',
        'length' => 64,
649 650
        'not null' => TRUE,
      ),
651
      'timestamp' => array(
652
        'description' => 'A Unix timestamp indicating when this batch was submitted for processing. Stale batches are purged at cron time.',
653
        'type' => 'int',
654 655
        'not null' => TRUE,
      ),
656
      'batch' => array(
657
        'description' => 'A serialized array containing the processing data for the batch.',
658
        'type' => 'blob',
659
        'not null' => FALSE,
660
        'size' => 'big',
661
      ),
662
    ),
663
    'primary key' => array('bid'),
664 665 666 667
    'indexes' => array(
      'token' => array('token'),
    ),
  );
668 669

  $schema['flood'] = array(
670
    'description' => 'Flood controls the threshold of events, such as the number of contact attempts.',
671
    'fields' => array(
672
      'fid' => array(
673
        'description' => 'Unique flood event ID.',
674
        'type' => 'serial',
675 676
        'not null' => TRUE,
      ),
677
      'event' => array(
678
        'description' => 'Name of event (e.g. contact).',
679 680 681
        'type' => 'varchar',
        'length' => 64,
        'not null' => TRUE,
682 683
        'default' => '',
      ),
684 685
      'identifier' => array(
        'description' => 'Identifier of the visitor, such as an IP address or hostname.',
686 687 688
        'type' => 'varchar',
        'length' => 128,
        'not null' => TRUE,
689 690
        'default' => '',
      ),
691
      'timestamp' => array(
692
        'description' => 'Timestamp of the event.',
693 694
        'type' => 'int',
        'not null' => TRUE,
695
        'default' => 0,
696
      ),
697 698 699 700 701 702
      'expiration' => array(
        'description' => 'Expiration timestamp. Expired events are purged on cron run.',
        'type' => 'int',
        'not null' => TRUE,
        'default' => 0,
      ),
703
    ),
704
    'primary key' => array('fid'),
705
    'indexes' => array(
706
      'allow' => array('event', 'identifier', 'timestamp'),
707
      'purge' => array('expiration'),
708
    ),
709
  );
710

711
  $schema['key_value'] = array(
712
    'description' => 'Generic key-value storage table. See the state system for an example.',
713 714 715 716 717 718 719 720 721 722 723 724 725 726 727 728 729 730 731 732 733 734 735 736 737
    'fields' => array(
      'collection' => array(
        'description' => 'A named collection of key and value pairs.',
        'type' => 'varchar',
        'length' => 128,
        'not null' => TRUE,
        'default' => '',
      ),
      'name' => array(
        'description' => 'The key of the key-value pair. As KEY is a SQL reserved keyword, name was chosen instead.',
        'type' => 'varchar',
        'length' => 128,
        'not null' => TRUE,
        'default' => '',
      ),
      'value' => array(
        'description' => 'The value.',
        'type' => 'blob',
        'not null' => TRUE,
        'size' => 'big',
      ),
    ),
    'primary key' => array('collection', 'name'),
  );

738 739 740 741 742 743 744 745 746 747 748 749 750 751 752 753 754 755 756 757 758 759 760 761 762 763 764 765 766 767 768 769 770 771
  $schema['key_value_expire'] = array(
    'description' => 'Generic key/value storage table with an expiration.',
    'fields' => array(
      'collection' => array(
        'description' => 'A named collection of key and value pairs.',
        'type' => 'varchar',
        'length' => 128,
        'not null' => TRUE,
        'default' => '',
      ),
      'name' => array(
        // KEY is an SQL reserved word, so use 'name' as the key's field name.
        'description' => 'The key of the key/value pair.',
        'type' => 'varchar',
        'length' => 128,
        'not null' => TRUE,
        'default' => '',
      ),
      'value' => array(
        'description' => 'The value of the key/value pair.',
        'type' => 'blob',
        'not null' => TRUE,
        'size' => 'big',
      ),
      'expire' => array(
        'description' => 'The time since Unix epoch in seconds when this item expires. Defaults to the maximum possible time.',
        'type' => 'int',
        'not null' => TRUE,
        'default' => 2147483647,
      ),
    ),
    'primary key' => array('collection', 'name'),
    'indexes' => array(
      'all' => array('name', 'collection', 'expire'),
772
      'expire' => array('expire'),
773 774 775
    ),
  );

776 777 778 779 780 781 782 783 784 785 786 787 788 789 790 791 792
  $schema['queue'] = array(
    'description' => 'Stores items in queues.',
    'fields' => array(
      'item_id' => array(
        'type' => 'serial',
        'unsigned' => TRUE,
        'not null' => TRUE,
        'description' => 'Primary Key: Unique item ID.',
      ),
      'name' => array(
        'type' => 'varchar',
        'length' => 255,
        'not null' => TRUE,
        'default' => '',
        'description' => 'The queue name.',
      ),
      'data' => array(
793
        'type' => 'blob',
794 795 796 797 798 799 800 801 802 803 804 805 806 807 808 809 810 811 812 813
        'not null' => FALSE,
        'size' => 'big',
        'serialize' => TRUE,
        'description' => 'The arbitrary data for the item.',
      ),
      'expire' => array(
        'type' => 'int',
        'not null' => TRUE,
        'default' => 0,
        'description' => 'Timestamp when the claim lease expires on the item.',
      ),
      'created' => array(
        'type' => 'int',
        'not null' => TRUE,
        'default' => 0,
        'description' => 'Timestamp when the item was created.',
      ),
    ),
    'primary key' => array('item_id'),
    'indexes' => array(
814 815
      'name_created' => array('name', 'created'),
      'expire' => array('expire'),
816 817 818
    ),
  );

819 820 821 822 823 824 825 826 827 828
  $schema['router'] = array(
    'description' => 'Maps paths to various callbacks (access, page and title)',
    'fields' => array(
      'name' => array(
        'description' => 'Primary Key: Machine name of this route',
        'type' => 'varchar',
        'length' => 255,
        'not null' => TRUE,
        'default' => '',
      ),
829 830
      'path' => array(
        'description' => 'The path for this URI',
831 832 833 834 835