composer.json 1.98 KB
Newer Older
1 2 3 4 5 6 7 8
{
  "name": "drupal/core",
  "description": "Drupal is an open source content management platform powering millions of websites and applications.",
  "type": "drupal-core",
  "license": "GPL-2.0+",
  "require": {
    "php": ">=5.4.5",
    "sdboyer/gliph": "0.1.*",
9 10 11 12 13 14 15 16 17 18 19 20 21
    "symfony/class-loader": "2.7.*",
    "symfony/console": "2.7.*",
    "symfony/css-selector": "2.7.*",
    "symfony/dependency-injection": "2.7.*",
    "symfony/event-dispatcher": "2.7.*",
    "symfony/http-foundation": "2.7.*",
    "symfony/http-kernel": "2.7.*",
    "symfony/routing": "2.7.*",
    "symfony/serializer": "2.7.*",
    "symfony/translation": "2.7.*",
    "symfony/validator": "2.7.*",
    "symfony/process": "2.7.*",
    "symfony/yaml": "2.7.*",
22
    "twig/twig": "1.18.*",
23
    "doctrine/common": "~2.4.2",
24 25 26 27
    "doctrine/annotations": "1.2.*",
    "guzzlehttp/guzzle": "~5.0",
    "symfony-cmf/routing": "1.3.*",
    "easyrdf/easyrdf": "0.9.*",
28
    "phpunit/phpunit": "4.6.*",
29
    "zendframework/zend-feed": "2.4.*",
30 31
    "mikey179/vfsStream": "1.*",
    "stack/builder": "1.0.*",
32 33 34
    "egulias/email-validator": "1.2.*",
    "behat/mink": "~1.6",
    "behat/mink-goutte-driver": "~1.1",
35 36
    "fabpot/goutte": "^2.0.3",
    "masterminds/html5": "~2.1"
37
  },
38 39
  "minimum-stability": "dev",
  "prefer-stable": true,
40 41 42 43 44 45 46 47
  "autoload": {
    "psr-4": {
      "Drupal\\Core\\": "lib/Drupal/Core",
      "Drupal\\Component\\": "lib/Drupal/Component",
      "Drupal\\Driver\\": "../drivers/lib/Drupal/Driver"
    },
    "files": [
      "lib/Drupal.php"
48 49 50 51 52 53 54
    ],
    "classmap": [
      "lib/Drupal/Component/Utility/Timer.php",
      "lib/Drupal/Component/Utility/Unicode.php",
      "lib/Drupal/Core/Database/Database.php",
      "lib/Drupal/Core/DrupalKernel.php",
      "lib/Drupal/Core/DrupalKernelInterface.php",
55
      "lib/Drupal/Core/Site/Settings.php"
56 57 58 59 60
    ]
  },
  "config": {
    "preferred-install": "dist",
    "autoloader-suffix": "Drupal8"
61 62 63
  },
  "scripts": {
    "pre-autoload-dump": "Drupal\\Core\\Composer\\Composer::preAutoloadDump"
64 65
  }
}