Verified Commit ec1959ee authored by apaderno's avatar apaderno Committed by apaderno
Browse files

Issue #3291760 by dpineda, apaderno: The documentation suggests to use a...

Issue #3291760 by dpineda, apaderno: The documentation suggests to use a release of the plugin that isn't compatible with the CKEditor release used by Drupal
parent c9c95433
......@@ -6,6 +6,7 @@ CONTENTS OF THIS FILE
* Recommended modules
* Installation
* Configuration
* FAQ
* Maintainers
......@@ -20,7 +21,7 @@ This plugin provides the Advanced dialog window tab to extend some editor dialog
windows. Other plugins don't need to implement the same features for their
dialog windows.
SOme of the CKEditor plugins that use the Advanced tab are:
Some of the CKEditor plugins that use the Advanced tab are:
* The [Link](https://ckeditor.com/cke4/addon/link) plugin
* The [Image](https://ckeditor.com/cke4/addon/image) plugin
......@@ -58,27 +59,28 @@ INSTALLATION
```
* Add the following lines to the "repositories" section in the composer.json
file.
file. The 4.18.0 release of the plugin is the only release that is defined
compatible with the release of CKEditor used by Drupal 9.x.
```json
{
"type": "package",
"package": {
"name": "ckeditor/dialogadvtab",
"version": "4.8.0",
"version": "4.14.0",
"type": "drupal-library",
"extra": {
"installer-name": "ckeditor/plugins/dialogadvtab"
},
"dist": {
"url": "https://download.ckeditor.com/dialogadvtab/releases/dialogadvtab_4.8.0.zip",
"url": "https://download.ckeditor.com/dialogadvtab/releases/dialogadvtab_4.14.0.zip",
"type": "zip"
}
}
}
```
* Run `composer require 'ckeditor/dialogadvtab:4.8.0'` to download the plugin.
* Run `composer require 'ckeditor/dialogadvtab:4.14.0'` to download the plugin.
CONFIGURATION
......@@ -90,6 +92,21 @@ CONFIGURATION
- Drag the advanced icon button to your toolbar and save
FAQ
---
Q: Can I use a release of the plugin that is more recent than the one indicated
by the README.md file?
A: The README file shows how to install the plugin its
[project page](https://ckeditor.com/cke4/addon/dialogadvtab) defines
compatible with the release of CKEditor used by the Drupal release required
by the module. You can install a more recent version, if you find out it's
compatible with the Drupal release you are using.
The README.md file will be updated to show how to install the plugin
compatible with the Drupal release required by the module.
MAINTAINERS
-----------
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment