Verified Commit 1b54a959 authored by apaderno's avatar apaderno Committed by apaderno
Browse files

Issue #3257659 by apaderno: Improve formatting, spelling, grammar, and content...

Issue #3257659 by apaderno: Improve formatting, spelling, grammar, and content of the README.md file
parent 7e34b4ff
CKEDITOR ADVANCED TAB FOR DIALOGS
====================
CONTENTS OF THIS FILE
---------------------
* Introduction
* Requirements
* Recommended modules
* Installation
* Configuration
* Maintainers
INTRODUCTION
------------
This module integrates the [dialogadvtab](
https://ckeditor.com/cke4/addon/dialogadvtab) CKEditor plugin for Drupal 8.
This module integrates the
[dialogadvtab](https://ckeditor.com/cke4/addon/dialogadvtab) CKEditor plugin
with Drupal.
This plugin provides the Advanced dialog window tab to extend some editor dialog
windows. Other plugins don't need to implement the same features for their
dialog windows.
This plugin provides the Advanced dialog window tab to extend
some editor dialog windows.
Thanks to this other plugins do not need to implement
the same features for their dialog windows.
SOme of the CKEditor plugins that use the Advanced tab are:
* The [Link](https://ckeditor.com/cke4/addon/link) plugin
* The [Image](https://ckeditor.com/cke4/addon/image) plugin
* The [Flash](https://ckeditor.com/cke4/addon/flash) plugin
* The [Table](https://ckeditor.com/cke4/addon/table) plugin
* The [IFrame](https://ckeditor.com/cke4/addon/iframe) plugin
* The [Div](https://ckeditor.com/cke4/addon/div) Container plugin
Among the plugins that implement the Advanced tab are:
* The [Link](https://ckeditor.com/cke4/addon/link) plugin
* The [Image](https://ckeditor.com/cke4/addon/image) plugin
* The [Flash](https://ckeditor.com/cke4/addon/flash) plugin
* The [Table](https://ckeditor.com/cke4/addon/table) plugin
* The [IFrame](https://ckeditor.com/cke4/addon/iframe) plugin
* The [Div](https://ckeditor.com/cke4/addon/div) Container plugin
REQUIREMENTS
------------
* CKEditor Module (Core)
This module requires the following modules:
* [CKEditor](https://www.drupal.org/docs/8/core/modules/ckeditor)
INSTALLATION
------------
### Install via Composer (recommended)
If you use Composer to manage dependencies, edit composer.json as follows.
* Run `composer require --prefer-dist composer/installers` to ensure you have
the composer/installers package. This facilitates installation into directories
other than vendor using Composer.
* In composer.json, make sure the "installer-paths" section in "extras" has an
entry for `type:drupal-library`. For example:
```json
{
"libraries/{$name}": ["type:drupal-library"]
}
```
* Add the following to the "repositories" section of composer.json:
```json
{
"type": "package",
"package": {
"name": "ckeditor/dialogadvtab",
"version": "4.8.0",
"type": "drupal-library",
"extra": {
"installer-name": "ckeditor/plugins/dialogadvtab"
},
"dist": {
"url": "https://download.ckeditor.com/dialogadvtab/releases/dialogadvtab_4.8.0.zip",
"type": "zip"
* Install as you would normally install a contributed Drupal module. Visit
https://www.drupal.org/node/1897420 for further information.
* Run `composer require --prefer-dist composer/installers` to ensure you have
the composer/installers package. This facilitates installation into
directories other than vendor using Composer.
* Make sure the "extras/installer-paths" section in the composer.json file has
an entry for `type:drupal-library`, for example the following one.
```json
{
"libraries/{$name}": ["type:drupal-library"]
}
```
* Add the following lines to the "repositories" section in the composer.json
file.
```json
{
"type": "package",
"package": {
"name": "ckeditor/dialogadvtab",
"version": "4.8.0",
"type": "drupal-library",
"extra": {
"installer-name": "ckeditor/plugins/dialogadvtab"
},
"dist": {
"url": "https://download.ckeditor.com/dialogadvtab/releases/dialogadvtab_4.8.0.zip",
"type": "zip"
}
}
}
}
```
* Run `composer require 'ckeditor/dialogadvtab:4.8.0'` to download the plugin.
```
* Run `composer require 'drupal/ckeditor_advanced_tab:^1.0.0'` to download the
CKEditor Advanced Tab module, and enable it [as per usual](
https://www.drupal.org/docs/8/extending-drupal-8/installing-drupal-8-modules).
* Run `composer require 'ckeditor/dialogadvtab:4.8.0'` to download the plugin.
Install Manually
* Download the [dialogadvtab](https://ckeditor.com/cke4/addon/dialogadvtab)
CKEditor plugin.
* Extract and place the plugin contents in the following directory:
`/libraries/ckeditor/plugins/dialogadvtab/`.
* Install the CKEditor Advanced Tab module [as per usual](
https://www.drupal.org/docs/8/extending-drupal-8/installing-drupal-8-modules).
CONFIGURATION
-------------
* Configure the WYSIWYG buttons in
Administration » Configuration » Content authoring » Text formats and editors:
Administration » Configuration » Content authoring » Text formats and editors
- Drag the advanced icon button to your toolbar and save
MAINTAINERS
-----------
Current maintainers:
* Julien de Nas de Tourris ([julien](https://www.drupal.org/u/julien))
Current maintainers:
* Alberto Paderno (apaderno) - https://www.drupal.org/u/apaderno
* Chris Burge - https://www.drupal.org/u/chris-burge
* Julien de Nas de Tourris (julien) - https://www.drupal.org/u/julien
* Stephen Mulvihill (smulvih2) - https://www.drupal.org/u/smulvih2
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment