Commit e3bb8b94 authored by frjo's avatar frjo

Better error message when Colorbox plugin is missing. Require the v1.3.18 version of the plugin.

parent 968b9721
......@@ -32,7 +32,7 @@ function colorbox_requirements($phase) {
);
}
if (version_compare($colorbox_version, COLORBOX_MIN_PLUGIN_VERSION, '>=')) {
if (version_compare($colorbox_version, COLORBOX_MIN_PLUGIN_VERSION, '=')) {
$requirements['colorbox_plugin'] = array(
'title' => $t('Colorbox plugin'),
'severity' => REQUIREMENT_OK,
......@@ -44,7 +44,7 @@ function colorbox_requirements($phase) {
'title' => $t('Colorbox plugin'),
'value' => $t('At least @a', array('@a' => COLORBOX_MIN_PLUGIN_VERSION)),
'severity' => REQUIREMENT_ERROR,
'description' => $t('You need to download the !colorbox and extract the entire contents of the archive into the %path folder of your server.', array('!colorbox' => l(t('Colorbox plugin'), 'http://colorpowered.com/colorbox/'), '%path' => $library_path)),
'description' => $t('You need to download the !colorbox, extract the archive and place the colorbox directory in the %path directory on your server.', array('!colorbox' => l($t('Colorbox plugin v1.3.18'), 'http://www.jacklmoore.com/colorbox/colorbox-1.3.18.zip'), '%path' => $library_path)),
);
}
}
......
......@@ -9,7 +9,7 @@
* The default path to the Colorbox directory.
*/
define('COLORBOX_PATH', 'sites/all/libraries/colorbox');
define('COLORBOX_MIN_PLUGIN_VERSION', '1.3.16');
define('COLORBOX_MIN_PLUGIN_VERSION', '1.3.18');
define('COLORBOX_MIN_JQUERY_VERSION', '1.3.1');
define('COLORBOX_MAX_JQUERY_VERSION', '1.4+');
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment